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Software only in accordance with the restrictions of this license.
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Third-party owners from whom Bay Networks has acquired license rights to software that is incorporated
into Bay Networks products shall have the right to enforce the provisions of this license against licensee.

Licensee shall not remove or obscure any copyright, patent, trademark, trade secret, or similar intellectual
property or restricted rights notice within or affixed to any Software and shall reproduce and affix such
notice on any backup copy of Software or copies of software resulting from modification or combination
performed by licensee as permitted by this license.

Licensee shall not reverse assemble, reverse compile, or in any way reverse engineer the Software. [Note:
For licensees in the European Community, the Software Directive dated 14 May 1991 (as may be
amended from time to time) shall apply for interoperability purposes. Licensee must notify Bay Networks
in writing of any such intended examination of the Software and Bay Networks may provide review and
assistance.]

Notwithstanding any foregoing terms to the contrary, if licensee licenses the Bay Networks product “Site
Manager,” licensee may duplicate and install the Site Manager product as specified in the Documentation.
This right is granted solely as necessary for use of Site Manager on hardware installed with licensee’s
network.

This license will automatically terminate upon improper handling of Software, such as by disclosure, or
Bay Networks may terminate this license by written notice to licensee if licensee fails to comply with any
of the material provisions of this license and fails to cure such failure within thirty (30) days after the
receipt of written notice from Bay Networks. Upon termination of this license, licensee shall discontinue
all use of the Software and return the Software and Documentation, including all copies, to Bay Networks.

Licensee’s obligations under this license shall survive expiration or termination of this license.
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About This Guide

If you are responsible for configuring and managing Wellfleet ™
routers, you need to read this guide. This guide is intended for
experienced network operators. It describes how to manage Wellfleet
routers using Wellfleet’s Site Manager application. It assumes that the
reader has a technical understanding of data communications and a
basic understanding of how Site Manager works.

Refer to this guide for instruction on

Accessing and viewing trap messages and event messages
Responding to trap messages and event messages
Accessing and viewing statistics

Accessing and using files to boot routers

Basic system administration

g O O o o a

Editing a configuration file after replacing a link module

Note: The Site Manager windows shown in this book are from an
X Window System™ UNIX® environment. Minor variations in
screen appearance may occur from platform to platform.
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Before You Begin

Before You Begin

Refer to the guide Quick-Starting Wellfleet Routers for information on
how to install Site Manager on your computer.

Refer to the guide Using Site Manager Software for an introduction to
Bay Networks’ network management application.

Refer to the guide Configuring Wellfleet Routers for information on how
to use the Configuration Manager tool.

Refer to the guide Customizing SNMP, BOOTP, and RARP Services for
more information on SNMP.

How to Get Help

For additional information or advice, contact the Bay Networks Help
Desk in your area:

United States 1-800-2LAN-WAN
Valbonne, France (33) 92-966-968
Sydney, Australia (61) 2-903-5800

Tokyo, Japan (81) 3-328-0052
Conventions
angle brackets (< >) Indicate that you choose the text to enter based on

the description inside the brackets. Do not type the
brackets when entering the command. Example: if
command syntax is ping <ip_address>, you enter
ping 192.32.10.12

arrow character (=) Separates menu and option names in instructions.
Example: Protocols=>AppleTalk identifies the
AppleTalk option in the Protocols menu.

brackets ([ 1) Indicate optional elements. You can choose none,
one, or all of the options.
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About This Guide

user entry text

command text

italic text

screen text
ellipsis points
quotation marks (“”)

vertical line (])

Acronyms

ACE

Denotes text that you need to enter. Example: Start
up the Windows environment by entering the
following after the prompt: win

Denotes command names in text. Example: Use the
xmodem command.

Indicates variable values in command syntax
descriptions, new terms, file and directory names,
and book titles.

Indicates data that appears on the screen. Example:
Set Trap Monitor Filters

Horizontal (. . .) and vertical ( : ) ellipsis points
indicate omitted information.

Indicate the title of a chapter or section within a
book.

Indicates that you enter only one of the parts of the
command. The vertical line separates choices. Do not
type the vertical line when entering the command.

Example: If the command syntax is
show at routes | nets, you enter either
show at routes or show at nets, but not both.

Advanced Communications Engine

Bay Networks’ Access Link Node

Bay Networks’ Access Node Router

Address Resolution Protocol

Access Stack Node

Bay Networks’ Backbone Concentrator Node Router
Border Gateway Protocol

Bay Networks’ Backbone Link Node Router
Bay Networks’ Backbone Link Node-2 Router
Bootstrap Protocol

Carrier Sense Multiple Access/Carrier Detect
Connectionless Network Protocol
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Acronyms

DLSw
DMAP
DOS
EGP
FDDI
FN

FRE
GAME
HSSI
ICMP
1P

IPX
LLC
MIB
NSAP
NVFS
NVRAM
OSI
OSPF
PCMCIA

PPP
PPX
RFC
SIMM
SMDS
SNMP
TCP/IP
TFTP
UDP
VINES
XNS

data link switching

direct memory access processor
disk operating system

Exterior Gateway Protocol

Fiber Distributed Data Interface
Bay Networks’ Feeder Node Router
fast routing engine

Bay Networks’ Gate Access Management Entity
High Speed Serial Interface
Internet Control Message Protocol
Internet Protocol

Internet Packet Exchange Protocol
logical link control

management information base
network service access point
Nonvolatile file system

Nonvolatile read access memory
Open Systems Interconnection
Open Shortest Path First

Personal Computer Memory Card International
Association

Point-to-Point Protocol

parallel packet express

Request for Comment

Single Inline Memory Module
Switched Multimegabit Data Service
Simple Network Management Protocol
Transmission Control Protocol/Internet Protocol
Trivial File Transfer Protocol

User Datagram Protocol

Virtual Networking System

Xerox Networking Systems Protocol
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Chapter 1
Overview of Router Management

To manage your Wellfleet routers, you can use Site Manager to do the
following:

Configure the router

Monitor traps and events

Monitor statistics

Manage router files

Monitor changes to router configuration files
Customize router software images

Perform administrative functions

g O o o o a a o a

Track network availability and response time
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Configuring the Router

Configuring the Router

You can configure your router remotely using the Configuration
Manager tool in Site Manager. The Configuration Manager lets you do
the following:

o o o o o o a0

Add network interfaces to the router using default values
Customize network interfaces for your network environment
Configure inbound and outbound traffic filters on interfaces

Assign priorities to certain types of traffic that an interface receives
Reconfigure the router’s connection to the Technician Interface (TI)
Specify a router’s hardware configuration

Specify administrative information about the router

To access the Configuration Manager tool, select Tools=>Configuration
Manager from the Site Manager main window. You must then specify
the operating mode (Local File, Remote File, or Dynamic):

a

Use Local File mode to create or edit a configuration file locally on
the Site Manager workstation for later implementation on the
router.

Use Remote File mode if you can access the router over the network
but want to implement the configuration at a later date.

Use Dynamic mode if you can access the router over the network
and want to configure the system in real time.

For more information on using the Configuration Manager, refer to
Configuring Wellfleet Routers.
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Monitoring Traps and Events

Two types of messages help you manage a router:

a  Trap messages provide real-time information on the operating
status of the routers running on your network. Routers using the
Simple Network Management Protocol (SNMP), an industry
standard, produce trap messages. You use the Trap Monitor to view
these messages.

a Event messages also provide information on the operating status of
the routers running on your network; however, event messages
provide a more detailed description. You use the Events Manager to
display event messages.

For an overview of how your routers are functioning, use the Trap
Monitor first; then use the Events Manager for more complete event
descriptions.

Table 1-1 compares trap and event messages. Refer to Event Messages
for Wellfleet Routers for information on how to respond to messages.

Table 1-1. Comparing Trap Messages and Event Messages

Trap Messages Event Messages

Real-time display Detailed display (not in real time)

SNMP-standard Wellfleet-specific

Usually view before event mes- Usually view after trap messages

sages

Expensive to view (but fast) Inexpensive to view (but slower)

Brief messages provided Descriptive messages provided (see
Event Messages for Wellfleet Routers)

continued on the next page
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Monitoring Traps and Events

Table 1-1.  Comparing Trap Messages and Event Messages (continued)

Trap Messages

Event Messages

Real-time display

Detailed display (not in real time)

No list of messages provided

List of messages and recommended
responses provided (see Event Mes-
sages for Wellfleet Routers)

Use Configuration Manager to
configure SNMP agent to send
messages to Trap Monitor

Use Trap Monitor to view and filter
messages

Use Events Manager to view and
filter messages

Can configure SNMP agent to send
event messages to Trap Monitor

Cannot configure SNMP agent to
send trap messages to Events
Manager

Can save messages to ASCII file

Can save messages to ASCII file

Stored in workstation’s trap his-
tory file

Stored in router’s event log

Stamped with workstation’s time

Stamped with router’s time




Overview of Router Management

Viewing Trap Messages

You view trap messages in real time using the Trap Monitor tool. To
access the Trap Monitor, select Tools>Trap Monitor from the Site
Manager main window. The Trap Monitor lets you view event
messages along with trap messages.

Before using the Trap Monitor, you must use the Configuration
Manager to do the following:

o Specify the Internet Protocol (IP) address of your Site Manager
workstation.

a Configure the SNMP agent located inside your router to send
specified trap messages to the Site Manager workstation.

o Ifyou use more than one network management application, change
the trap port assigned to your Site Manager application so that Site
Manager will continue to receive trap messages from the router.

The Trap Monitor tool receives trap messages from all SNMP agents
on the network that are configured to send the messages. Once you
configure an agent to send SNMP trap messages to your Site Manager
workstation, a trap history file saves a running history of these
messages. The Trap Monitor dynamically displays trap messages from
the trap history file after you load the file into the Trap Monitor
window. Chapter 2 describes how to load the file into the Trap Monitor
window.

Figure 1-1 shows a sample Trap Monitor window and Table 1-2
describes the window contents.
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Monitoring Traps and Events

@] Wellfleet Trap Monitor &
File View

Slot Entity

Tinestamp Node

Tec 27 20:43:% . 19% 52, 156. 10
[lec 27 93:43: 59 ~192, 32,156, 10
Dec 27 22:43:35 192,32, 156, 10
Dec 27 22:43:39 192,32, 156, 10
Dec 27 22:43:48 192,32, 156, 10
Dec 27 22:43:50 192,32, 156, 10
Dec 27 22:43:56 192,32, 156, 10
Dec 27 22:44:00 192,82, 156, 10
Dec 27 22:44:07 192,32, 156, 10
Dec 27 22:44:11 192,32, 156, 10

44 192,32, 156, 1
Dec 27 22:44:21) (192,32, 156, 10

4 CSMACD

1 ™(3MBCD ~ ) Cormector MCVRL Carrier Jost,” =

4 CSMACD
4 COMACcD
4 CoMACD
4 CSMACD
4 CSMACD
4 CSMACD
4 COMACD
4 CSMACD

4 »
ﬁD(CSMACD) é&%{ "Connector KCVR1 carrier lost,”)

Description n

(W) ”Connector XCVRl carrier lost.”

(W) "Connector XCVR1 carrier lost,”
(W) "Connector ACVRL carrier lost,”
(W) *Connector XCVR1 carrier lost,”
(W) "Connector XCVR1 carrier lost.”
(W) "Connector XCVRl carrier lost,”
(W) "Connector XCVRl carrier lost.”
(W) "Commector XCVR1 carrier lost,”
W) ::Cormector XCVR1 carrier Jost.,”

y \

Timestamp Node

vy

Slot  Entity

Description

Severity
Figure 1-1. Wellfleet Trap Monitor Window
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Table 1-2.  Trap Message Details

ltem Description

Timestamp Date and time that the Site Manager
workstation received the trap message

Node IP address of the router whose SNMP agent
generated the trap message

Slot Slot hosting the entity that generated the
trap message

Entity Abbreviated name of entity that generated
the trap message

Severity Severity level of trap message: Fault,
Warning, Information, Debug, or Trace.
First letter is used (for example, W stands
for Warning)

Description Text describing the trap

You can use the entity, severity, slot, and node to filter the types of trap
messages you want to view in the Trap Monitor window.

The Trap Monitor tool lets you do the following:

o Save the trap messages you see in the Trap Monitor window to an
ASCII file on your workstation. You can view or print the file later.

o Clear the Trap Monitor window to display only the latest messages

or empty the trap history file entirely to start a new log.
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You can configure the SNMP agent to send specified trap messages to
the Trap Monitor window as follows:

Configuring the SNMP Agent

By category—none, generic, specific, all

By entity

By event message (entity/event code)

Note: To save routing resources, configure the SNMP agent so that it
sends only important data, such as fault, warning, and
information messages.

For more information about using the Trap Monitor, see Chapter 2.

Viewing Event Messages

You view event messages using the Events Manager tool. To access the
Events Manager, select Tools>Events Manager from the Site Manager
main window. Each time you want to view the most current version of
a router’s event log, you must use the Events Manager to retrieve the
event log. The Events Manager does not display event messages in real
time.

The Events Manager lets you view event messages from the router
whose IP address you specify in the Wellfleet Site Manager window or
from the Options menu in the Events Manager window.

Figure 1-2 shows a sample Events Manager window and Table 1-3
describes its contents.
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@ Wellflect Events Manager B
File View Options Find Help
System Neme: 192,32, 156,9 Display:
& Descending
Log File Name: WELLFLT, LOG
Log File Source: Current Log Number of records: 5261
# 59: 12/04/93 15:43:58 INFO SLOT 4 MIB Event Code: 3
Service initializing,
# 68: 12/04/93 15:43:58 INFO SLOT 4 NOV_SYNC Event Code: 2
Service initializing,
# 7b: 12/04/93 15:43:58 INFO SLOT 4 DP Event Code: 4
Service initializing,
# 90: 12/04/93 15:43:59 INFO SLOT 4 S¥S Event Code: 3
Service initializing,
# 480: 12/06/93 16:48:52  INFO SLOT 3 MIB Event Code: 5
wfConsole, wiltloreEnable, 0 set to 2
#519: 12/06/93 17:28:26  WARNING SLOT 3 TI Event Code: 2
Invalid login attempt by quit
#3195: 12/15/93 16:47:11 INFO SLOT 2 TFTP Event Code: 2
Protocol initializing,
#3207: 12/15/93 16:47:12 INFO SLOT 2 TCP Event Code: 5
TCP is UP,
#3209: 12/15/93 16:47:12 INFO SLOT 2 TCP Event Code: 6
TCP Opened: 0,0.0.0,23 - 0.0, 0,0, 0 TCB: 0x3053d240
#3210: 12/15/93 16:47:12 INFO SLOT 2 TELNET Event Code: 5
Connection Manager listening on TCP port 23
#3211: 12/15/93 16:47:15 WARNING SLOT 2 CSMACD Event Code: 7
Connector XCVR1 no SQE.
218: Y0/15/93 16:47:15 (0 LOT 2(ARP Event Code: (D)
TUITE 1 UD Ofl CiTCUiL 1
#3727 [2/15793 J6:47:10  INEp SLOY] 2T Event Code: l:

\/

Event
Number

Timestamp Severity Slot !ntity Iévznt
ode

Description
Figure 1-2. Wellfleet Events Manager Window
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Monitoring Traps and Events

Table 1-3.  Event Message Details

Detail Description

Event number | Event’s place in the event log (See the Number of
Records field for the total count.)

Timestamp Date and time the event occurred, as recorded by the
router

Severity Severity level of event message

Slot Slot hosting the entity that generated the event message

Entity Abbreviated name of entity that generated the event
message

Event code Event code, as shown in Event Messages for Wellfleet
Routers

Description Text describing the event

You can use the router IP address, entity, severity, and slot to filter
event messages in the Events Manager window.

You can use the entity and event code to look up an event message in
Event Messages for Wellfleet Routers.

The Events Manager lets you do the following:

0 Search for messages in the log displayed.

a Save the event messages you see in the Events Manager window to
an ASCII file on your workstation. You can then view or print the

file later.

o  Reload an event log saved in binary format back into the Events
Manager window. (Storing a log on a diskette or memory card
inside the router saves the log in binary format.)

0o Clear the events displayed in the Events Manager window.
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For more information on using the Events Manager, see Chapter 3.

Monitoring Statistics

Site Manager uses an SNMP-based polling mechanism to request the
following:

0 Real-time data link layer statistics providing circuit information

o Network layer statistics providing protocol information

When it receives this data, Site Manager displays the information in a
statistics window. Using the Statistics Manager tool, you can do the
following:

Connect to a router

View the Wellfleet Management Information Base (MIB)
Display statistics screens

Build custom statistics screens

Edit custom statistics screens

g O o o a a

Add or remove statistics screens from the current screen list

To access the Statistics Manager tool, select Tools>Statistics Manager
from the Site Manager main window. The Statistics Manager provides
four tools that you can access from the Statistics Manager’s Tools
menu (Figure 1-3). Table 1-4 describes these tools.

[®] Statistics Manager
File View Options [Tools |Window

SYP fgent: 192, EMC

Screen Builder.., PF4L Protocols
rScreen Manager.,. PR5pY IP» RIP

Circuit Name (#

Launch Facility,..
|

Figure 1-3. Statistics Manager Tools Menu
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Monitoring Statistics

Note: The Quick Set tool is not a selectable option at this time.

Table 1-4.  Statistics Manager Tools

Tool Function

Quick Get Lets you view objects in the Management Information
Base (MIB)

Screen Lets you design your own custom statistics screens

Builder

Screen Man- | Lets you manage your statistics screen database and

ager specify a current statistics screen list

Launch Lets you select statistics screens from the current screen

Facility list and launch (or display) the screens

The following sections describe each of these tools, as well as how to
get online help. Later, we describe where the Statistics Manager stores
default and custom-built statistics files on your UNIX workstation or
PC.

For more information on using the Statistics Manager, see Chapter 4.

Using the Quick Get Tool

You use Quick Get to view the MIB and retrieve instances of selected
MIB objects from the router. The Wellfleet MIB is a Wellfleet
proprietary database that contains the router’s configuration
parameters and statistics.

Quick Get includes a MIB Browser, which you use to scroll though the
MIB and select those objects about which you want to retrieve
information. Quick Get retrieves all instances of the specified MIB
objects and displays the statistics in a window.
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Quick Get helps you debug your network (for example, if you want to
monitor MIB objects). It is also an easy way to view the MIB and
decide which objects you want to include on your customized statistics
screens.

Using the Screen Manager Tool

You use the Screen Manager to manage the statistics screen database
and to define a current screen list. The database contains over 75
default statistics screens. In addition, you can design and save up to
4,000 customized screens. The current screen list is a subset of the
entire database of statistics screens — usually those you use most
often. It can contain both default and custom-built screens. Note that
you can display only those statistics screens that you have added to the
current screen list.

Using the Launch Facility Tool

You use the Launch Facility tool to display any statistics screens that

are on the current screen list. When you launch a statistics screen, Site
Manager polls the router for all instances of the MIB objects specified

on the screen, then formats and displays the data in columns.

There are two types of statistics screens:

a  Circuit mode: The Statistics Manager continually polls the router
for statistics and updates the statistics screen with new data. You
determine how often the Statistics Manager retrieves these
statistics by specifying a polling rate.

7 Table mode: The Statistics Manager retrieves statistics from the
router only once — when you launch the screen. You must refresh
the screen each time you want to update it with new data.

Using the Screen Builder Tool

You use the Screen Builder to create custom statistics screens. The
MIB Browser lets you select up to nine objects to include on the screen.
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For each object you select, you design how the statistics appear on the
screen. The screen shows each object’s statistics in a single column
below a column heading.

The Screen Builder lets you specify the following:
a Aname for the column heading
a The column width

a The format in which the screen displays the statistics (decimal or
hexadecimal)

You can also use the Screen Builder to edit custom screens. For
example, you can redefine how to display statistics, or you can add or
delete objects from the screen.

Using Online Help

Site Manager provides online help for each Statistics Manager tool. To
get help, click on the Help button at the bottom of the screen. To exit
the Help window, click on OK.

Locating Statistics Files

Depending on whether you load Site Manager on a UNIX or DOS
computer, the Statistics Manager stores all statistics screen files in one
of the following directories.

Platform Default Screen Directory Custom Screen Directory
UNIX {usr/wf/lib/.wfscrns $(HOME) | .wfscrns
DOS \wf\lib\wfscrns \wf\wfscrns

For more information on using the Statistics Manager, refer to
Chapter 4.
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Managing Router Files

You can display a list of the system files stored on a Wellfleet router’s
active volume using the Router Files Manager tool. The Router Files
Manager lets you

o Display the files on all disk volumes in a Wellfleet router

o Transfer and copy files between volumes on a Wellfleet router’s
disk, and between the router and the Site Manager workstation

0 Delete files from a Wellfleet router’s disk volume
7 Compact Wellfleet memory cards

a0 Partition the nonvolatile file system (NVFS) on Wellfleet Access
Node (AN) or Access Stack Node (ASN) routers

To access the Router Files Manager, select Tools>Router Files
Manager from the Site Manager main window. For more information
about using the Router Files Manager, refer to Chapter 5.

Monitoring Changes to Router Configuration Files

Two features are available for you to track changes to router
configuration files:

a  The Report Generator tool

a The audit trail feature

The Report Generator tool translates the router’s binary configuration
file to an ASCII file. You can use any standard text editor to view and
print the file. You can also use source comparison utilities to compare
one report with another to detect configuration changes. To access the
Report Generator tool, select Tools>Report Generator from the Site
Manager main window.

In organizations where network managers at branch locations share
router management responsibilities, central administrators can use
audit trail logs to monitor configuration changes. An audit trail log is
an ASCII file that describes the changes made to a router configuration
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file. Each router you audit has its own audit trail log file. Whenever
someone changes a router configuration file, the audit trail feature (if
enabled for that router) appends the changes to the audit trail log.

Note: The audit trail feature keeps track of router configuration
changes made in remote mode or dynamic mode only. The
feature does not track changes made in local mode, or those
made using the Technician Interface (TT).

With audit trail logging enabled, when you configure the router in
remote mode, Site Manager does the following once you save your
configuration changes:

o Transfers the configuration file to the router, as usual
0 Creates the audit trail log file (if it doesn’t already exist)
0 Appends the configuration changes to the audit trail log file

If you configure the router in dynamic mode, Site Manager does the
following each time an SNMP SET occurs:

o Updates the configuration on the router.

0 Logs the SET to the audit trail log file. Site Manager creates the
audit trail log file (if it does not already exist), and appends the
changes to the file.

Note: To prevent an audit trail log file from becoming too large, you
should periodically delete old information in it or delete the file
itself.

You can configure the audit trail feature to send you (and other
network managers) a copy of the audit trail log file whenever Site
Manager updates it with new information. For routers configured in
dynamic mode, the audit trail feature sends the log file after every
tenth SNMP set.
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For more information on using the Report Generator tool and the audit
trail feature, refer to Chapter 6.

Customizing Router Software Images

Site Manager provides a tool, the Image Builder, that lets you
customize the router software images you receive from Bay Networks.
A router software image is a group of executable files that operates the
protocols on your network in conjunction with a Wellfleet router. You
can do the following to modify a router software image:

)

m}

Remove a protocol that you do not use. For example, you might
want to remove protocols to make more space available on the
media that contains the router software image. Alternatively, you
can add protocols that you inadvertently removed.

Replace an existing image with an entirely new one.

To access the Image Builder, select Tools>Image Builder. For more
information on using the Image Builder tool, refer to Modifying
Software Images for Wellfleet Routers.

Performing Administrative Functions

You can perform the following administrative tasks from Site

Manager:

o Booting (warm-starting) the router

0 Resetting (warm-starting) a single processor module in the router

0 Clearing the router’s event log

0 Setting the router’s date and time

0 Testing the router’s connection to a remote device on the network
using one of five protocols: IP, IPX®, OSI, VINES®, or AppleTalk®

a Configuring the kernel; that is, reallocating the global and local

memory on FRE2 and ACE32 processor modules, Access Nodes,
and Access Feeder Nodes
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Tracking Network Availability and Response Time

You can perform these tasks using the Site Manager Administration

menu (Figure 1-4).

@ Wellfleet Site Manager

File View Options Tools iAdmimistration l Help
Boot Router...

{Connectionl ;&atisticaﬂ [Eeget Slot... iles
Clear Log... . Connections
Router Date and Time...
Ping from Router 2 B9 Up

System Name/IP Address: 1 Kernel Configuration,., [»164 Up

SMMP ID (Community) : A T S Th 09 Up

Figure 1-4. Administration Menu

For more information about using each of the administrative functions,

refer to Chapter 7.

You can track network availability and response time using the Ping
MIB. The Ping MIB is a group of tables that store the following
information for one or more ping requests:

0 General ping information, such as the address you want to ping,
whether you want to use trace routing and source routing, and the

frequency of the ping.

o Trace route data that shows the IP addresses the ping went
through to reach its destination.

a9  Source route data, which contains the IP addresses that you want
the ping to go through instead of those in the routing table.

o History data about previous pings that you chose to initiate at
specific intervals. See Chapter 8 for information on setting ping

intervals.
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Overview of Router Management

To use the Ping MIB, you must first define the IP addresses that you
want to ping. You can enter the addresses of routers, host computers,
or any device on the network. The Ping MIB stores the results of the
ping requests. You can then monitor those results using the Statistics
Manager in Site Manager. You might also create your own application
to query the Ping MIB, analyze the data, and generate reports of the
information. You can also use such applications as IBM®
NetView®/6000, SunNet Manager, and HP® OpenView to work with
the Ping MIB.

For more information on using the Ping MIB, refer to Chapter 8.

Keeping a Log

You should make several copies of the log on the next page to organize
your management files. Keep the log in a handy place near your Site
Manager workstation. Use this log to list the filenames and directories
of all your configuration files, trap history files, and event logs.
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Keeping a Log

LOG

Filename

Location

Description

Date
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Chapter 2
Using the Trap Monitor

For general information about monitoring traps, see “Monitoring Traps
and Events” in Chapter 1. For specific information about using
buttons, windows, and other Site Manager features, refer to Using Site
Manager Software.

Use the Trap Monitor to do the following:
o Display the trap history file

Filter trap messages

Clear the Trap Monitor window
Clear the trap history file

a o o Q

Save trap messages




Connecting to a Router

Connecting to a Router

Before you can use the Trap Monitor tool, you must configure the
Simple Network Management Protocol (SNMP) agent inside the router
to send specified trap messages to the Trap Monitor. To do this, you
must first connect to the router as follows:

1. From the Wellfleet Site Manager window, select Options>Router
Connection.

The Router Connection Options window appears (Figure 2-1).

[® Router Comnection Options

Node Name/IP Address 32, 32, 156, 68
Identity (Community)

Timeout (seconds) h

Retries (per request) w

Figure 2-1. Router Connection Options Window

2. In the Node Name/IP Address field, type the IP address of the
router you want to configure. Then click on OK.

The Wellfleet Site Manager window displays the router’s system
information.
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Using the Trap Monitor

Configuring the Router’s SNMP Agent

You must configure the SNMP agent in a router such that it will

0 Recognize your Site Manager workstation as a valid SNMP
manager

o Send specified trap messages to your Site Manager workstation
To configure the SNMP agent, use the Configuration Manager tool,
which you also use to

o Enable the SNMP agent on the router

a Save the result of your configuration entries on the router

This section explains briefly how to accomplish these tasks. For more

information on how to customize traps a router sends, refer to
Customizing SNMP, BOOTP, and RARP Services.

Identifying Site Manager as an SNMP Manager

To configure the router’s SNMP agent to send trap messages to your
Site Manager workstation, you must first tell the router to recognize
your Site Manager workstation as a valid SNMP manager.

1. From the Wellfleet Site Manager window, select
Tools>Configuration Manager. Then select Local File, Remote File,
or Dynamic mode.

The Configuration Manager window appears (Figure 2-2).
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Configuring the Router's SNMP Agent

[® Configuration Manager

File Options Platform Circuits Protocols Dialup Window Help
Configuration Mode: dynamic
P Agent: 192, 32, 156, 63
File Name: |
Model: Link Node (LN}
MIB Version: 7,80
Color Key: Used Tnused
Slot Description Connectors
5 Enpty Slot WohE ] [HoNE ) {NGNE | [T HONE |
4 ! Empty Slot | oK |§ NONE |§ NONE |§ NONE |
3 i 5450 Quad Ethernet | ] ] XCURZ XCURI
2 15430 Dual Sync, Dual Ethernet| coM2 | RCURS ]
1 !  System Resource Module | JHH OLE

Figure 2-2. Configuration Manager Window

2. From the Configuration Manager window, select

Protocols=>IP->SNMP=>Communities.

The SNMP Community List window appears (Figure 2-3).

[® SAMP Community List §
File Community

SNMP Communities:

v

Figure 2-3. SNMP Communities List
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Using the Trap Monitor

3. From the SNMP Community List window, select
Community->Managers.

The SNMP Manager List window appears (Figure 2-4).

o 0 Taneer List
File Manager

Community: public

SWMP Managers:

Figure 2-4. SNMP Manager List

4. From the SNMP Manager List window, select Manager->Add
Manager.

The Add SNMP Manager window appears (Figure 2-5).

@] 4dd SNMP Manager

SNMP Manager IP Address

Cancel

Figure 2-5. Add SNMP Manager Window
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Configuring the Router's SNMP Agent

5. Type the IP address of your Site Manager workstation. Then click
on OK.

The SNMP Manager List window displays your workstation’s IP
address.

6. Save this configuration to a file and volume on the router.

Saving a Configuration

To save a configuration to a file and volume on the router, select
File=>Save or File>Save As from the Wellfleet Configuration Manager
window. Exiting from the Configuration Manager window also prompts
you to save a configuration. Specify the filename and router volume,
then select Save. Note the name and router volume you specified.

Refer to Configuring Wellfleet Routers for more information on using
the Configuration Manager tool.

Running Multiple Network Management Applications

If you are running another network management application (besides
Site Manager) on your workstation, you must configure Site Manager
to receive trap messages via another port on your Site Manager
workstation. This is necessary for the following reasons:

d The router can only send trap messages to one network
management application at a time.

a  Only one application can map to a port at a time.

Note: By default, a network management application installed on
your workstation binds to UDP (User Datagram Protocol) port
162. This port is dedicated to receiving SNMP traps from the
SNMP agent. Since Site Manager is the preferred network
management application for receiving trap messages, we
recommend that, when running another manager, you configure
Site Manager to bind to an alternative UDP port where Site
Manager can continue to receive trap messages.

2-6



Using the Trap Monitor

To configure the SNMP agent to send trap messages to Site Manager
via a different port, follow these steps:

1. From the Configuration Manager window, select
ProtocolsIP->SNMP->Communities.

2. From the SNMP Community List window that appears, select
Community->Managers.

3. From the SNMP Manager List window, select Manager->Edit
Manager.

The Trap Port and Trap Types window appears with the default
value 162 (Figure 2-6).

os 000000300

Configuration Mode: dynamic

SNMP Agent: 192, 32,156, 7 i Yalues. .. |

Trap Port

Traps Types I GENERIC ! lﬂ

Figure 2-6. Trap Port and Trap Types Window
4. To select a port number, use the Values button or type a port
number in the Trap Port field.

You can enter any port number on your Site Manager workstation,
as long as another application is not using that port.

5. Click on OK in the Trap Port and Trap Types window.

6. Save this configuration to a file and volume on the router. For
information, see the previous section, “Saving a Configuration.”

7. Exit Site Manager by selecting File>Exit from the Wellfleet Site
Manager window.
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Configuring the Router's SNMP Agent

8. Restart Site Manager using either the UNIX or DOS commands
shown in Table 2-1.

Table 2-1.  Restarting Site Manager on a New Port
Platform Steps
UNIX 1. Open a command line window.
2. Enter wfsm -e <port number> at the prompt.
DOS 1. Select the PC/Site Manager icon.
2. Select File>Properties.
3. Add -e <port number> to the end of the command
line.
4. Double-click on the PC/Site Manager icon.

Note: You must specify the new port number every time you restart
Site Manager.

Configuring Traps Sent by a Router

You can specify by category, entity, or event the types of trap messages
you want a router to send to your Site Manager workstation.

Specifying Traps by Category

You can configure a router to send

o All traps

a Generic traps
a  Specific traps
o

No traps
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Using the Trap Monitor

To specify the trap types you want to receive at your workstation,
follow these steps:

1. From the Configuration Manager window, select
Protocols=2IP>SNMP->Communities.

2. From the SNMP Communities List window that appears, select
Community->Managers.

3. From the SNMP Manager List window that appears, select
Manager->Edit Manager. The Trap Types and Trap Port window
appears with the default value GENERIC in the Trap Types field
(Figure 2-7).

Configuration Mode: dynamic

SNMP figent: 192,32, 156, 7

Trap Port

Traps Types | GENERIC ¥ fﬂ

Figure 2-7. Specifying a Trap Category

4. Click in the Trap Types field. Use the Values button to select an
option; then click on OK in the Values Selection window. Table 2-2
describes the different trap types.
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Configuring the Router's SNMP Agent

Table 2-2.  Categories of Traps

Category Description

NONE Prohibits the SNMP agent from transmitting traps to
this manager.

GENERIC Configures the agent to transmit well-defined SNMP
traps (cold-start, warm-start, and authentication failure
traps).

The agent is automatically enabled to send cold-start and
warm-start traps. However, you must enable the Authen-
tication Failure Trap parameter if you want the agent to

transmit authentication failure traps as well.

SPECIFIC Configures the agent to transmit all enabled trap mes-
sage types (fault, warning, debug, information, and trace
traps) from the protocol entities on your network.

ALL Configures the agent to transmit cold-start and warm-
start traps, as well as all other enabled traps (authentica-
tion failure, fault, warning, debug, information, and trace
traps).

Note: You will usually want to select GENERIC or SPECIFIC when
you configure the SNMP agent to send traps. These options
minimize the agent’s use of router resources.

5. Click on OK in the Trap Port and Trap Types window.

6. Save this configuration to a file and volume on the router.

Note: If you select SPECIFIC, you must further specify by entity the
kinds of trap messages you want the SNMP agent to send to
your workstation. Proceed to the section “Specifying Traps by
Entity.”
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Using the Trap Monitor

Specifying Traps by Entity

If you configure an SNMP agent to send SPECIFIC trap types to your
Site Manager workstation, you must specify which protocols (entities)
will send which trap types (fault, warning, information, debug, or

trace) to your workstation. Proceed as follows:

1. From the Wellfleet Configuration Manager window, select
Protocols=>IP>SNMP-Trap Configuration->Interfaces.

The Trap Configuration window appears (Figure 2-8).

dvailable Entities

Slot:

411 Entities
ACE
APPLETALK
ARP

4TM DXI
BGP3

BGP

BOD

BOOT
BOOTP
CSMACD
DECnet IV
DLS

DMap

Dos

DP

[® Trap Configuration §

Current Entities

[Events: O Fault

1 Warning

1 Debug

O Trace

{1 Info

Figure 2-8. Trap Configuration Window

2. Select the appropriate slot.

3. Select an entity whose trap messages you want to receive at your
Site Manager workstation.
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Configuring the Router's SNMP Agent

4. Select the severity levels for that entity’s trap messages.
Click on Update.

The entity and severity levels are added to the Current Entities
field.

6. Repeat Steps 2 through 5 for every entity whose trap messages you
want to receive at your Site Manager workstation. Then click on
Save.

7. Save this configuration to a file and volume on the router.

The entities you select will now send the trap types you selected to
your workstation.

Specifying Traps by Event Type

You can configure a router to always (or never) send trap messages
that you designate by their unique entity code and event number.
Proceed as follows:

1. From the Wellfleet Configuration Manager window, select
Protocols=>IP->SNMP-Trap Configuration->Exceptions.

The Traps Exceptions Lists window appears (Figure 2-9).

[®] Traps Exceptions Lists &2

.
-

41ways/Never Trap I f

Figure 2-9. Traps Exceptions List
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Using the Trap Monitor

2. To add an event message to the list of trap messages sent to your

router, click on Add in the Traps Exceptions Lists window.

The Add Trap window appears (Figure 2-10).

mudlrap B8l e

Configuration Mode: dynamic {::::ﬁz::::]
SNMP Agent: 192, 32, 156, 7

Entity Code

Event Code | I

Always/Never Trap | ‘i '

Figure 2-10. Add Trap Window

3. To determine which Entity Code and Event Code values to specify,
refer to Event Messages for Wellfleet Routers.

4. Use the Values button to enter values in the three fields shown in
the Add Trap window. Table 2-3 shows the values you should enter.

Table 2-3.  Entering Values in the Add Trap Window

Field Value
Entity Code Enter a value between 0 and 61.
Event Code Enter a value between 0 and 255.

Always/Never Trap Enter ALWAYS.

5. Click on OK in the Add Trap window.
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Configuring the Router's SNMP Agent

The entity’s event type appears in the Traps Exceptions Lists
window (Figure 2-11).

[® Traps Exceptions Lists (NN

Done

¥
| ——

* ™

Always/Never Trap [ ALways §|

Figure 2-11. Traps Exceptions Lists Window

You have now specified a particular entity’s event message to be
sent to your Site Manager workstation’s Trap Monitor.

6. Repeat this procedure for every entity’s event message you want
sent to the Trap Monitor.

7. Click on the Apply and Done buttons.
8. Save this configuration to a file and volume on the router.
You have now configured the SNMP agent inside each specified router

to send event messages, along with trap messages, to your Site
Manager workstation’s Trap Monitor.

Enabling an SNMP Agent

By default, the SNMP agent is always enabled. However, if the agent is
disabled at some point, you will have to enable it. To enable an SNMP
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Using the Trap Monitor

agent to send trap messages to your Site Manager workstation, follow
this procedure:

1. From the Wellfleet Configuration Manager window, select
Protocols=>IP->SNMP->Global.

The Edit SNMP Global Parameters window appears (Figure 2-12).

[®] Edit SNMP Global Parameters 8

Configuration Mode: dynamic
SNMP Agent: 192,32, 156,7
Enable
Use Lock ﬁm———_}
Lock TimeOut [2 |
Suthentication Failure Traps IENABLE f

Figure 2-12. Edit SNMP Global Parameters Window

2. Use the Values button and select the Enable option from the Values
Selection window (Figure 2-13). Then click on OK.

[®] Values Selection §
Enable
@ ENABLE
< DISABLE
K iCancel)

Figure 2-13. Enabling an SNMP Agent
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Using the Trap Monitor

3. Save this configuration to a file and volume on the router.

You have now configured this router’s SNMP agent to send trap
messages to your Site Manager workstation.

Viewing Trap Messages

Your Site Manager workstation receives all types of trap messages that
routers in your network are configured to send. However, the Trap
Monitor tool lets you choose, from all trap messages received by the
workstation, which traps you want to view in the Trap Monitor
window. You can filter trap message types by severity or by IP address
(using address filters).

The next section describes how to configure the Trap Monitor to receive
trap messages from routers throughout your network.

Using the Trap Monitor

The Trap Monitor tool lets you filter and view trap messages. Before
you use the Trap Monitor tool to view trap messages, configure the
SNMP agent in each router to send trap messages, as described earlier.
The agent running in the router sends only the trap types that you
enable in the router configuration. The Trap Monitor running in your
Site Manager workstation subsequently filters and displays a subset of
all the trap messages it receives from routers in your network.

Note: If you configure your routers to send traps, do not exit the Trap
Monitor window. Otherwise, the routers log this message:

ICMP Destination unreachable

Displaying the Trap History File

The trap history file contains trap messages that you specified be sent
to your Site Manager workstation. The Trap Monitor dynamically
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Using the Trap Monitor

displays trap messages from this file after you load the trap history file
into the Wellfleet Trap Monitor window.

Use the Load History File feature to display all trap messages since
you last cleared the history file.

1. From the Wellfleet Site Manager window, select Tools=>Trap
Monitor.

The Wellfleet Trap Monitor window appears.

2. From the Wellfleet Trap Monitor window, select File-»Load History
File.

The Wellfleet Trap Monitor window displays incoming trap
messages, along with trap messages logged since you last cleared
the history file.

Figure 2-14 shows a Wellfleet Trap Monitor window with messages.
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Using the Trap Monitor

OfDEaCSgeEyoeey 2 000000

File View Help
Tigest. Node Slot Entity Description

[Des 27 22:43:% _192.52.156.10_ _ _ _ & _COMACD _ (W) Connector KCVRL carrier lost.> _ _ 1R
Dec 27 £2:43:29 192, 32,756, 10 4 TCSMECD ~ W) “Connector XCVRI carrier Iost.”

Dec 27 22:43:35 192,32,156, 10 4 CSMACD (W) "Commector XCVR1 carrier lost,”

Dec 27 22:43:39 192, 32,156, 10 4 (SMACD (W) “Connector XCVRL carrier lost,”

Dec 27 22:43:46 192,32, 156, 10 4 CSMACD (W) "Connector XCVRl carrier lost,”

Dec 27 22:43:50 192,32,156, 10 4 CSMACD (W) "Commector XCVR1 carrier lost,”

Dec 27 22:43:56 192,32, 156, 10 4 CSMACD (W) "Commector XCVR1 carrier lost,”

Dec 27 22:44:00 192,32,158, 10 4 CSMACD (W) “Connector XCVR1 carrier lost,”

Dec 27 22:44:07 192,32,156, 10 4 CSMACD (W) "Connector XCVR1 carrier lost,”

Dec 27 22:44:11 192,32, 156, 10 4 CSMACD (W) “Comnector XCVR1 carrier lost,”

Dec 27 22:44:17 192,32,156, 10 4 CSMACD (W) “Connector XCVR1 carrier lost,”

Dec 27 22:44:21 192,32,156,10 4 (SMACD (W) “Connector XCVR1 carrier lost,”

< -

Figure 2-14. Wellfleet Trap Monitor Window

You can scroll through the trap messages using the scroll bars on the
bottom and right side of the window.

Filtering Trap Messages

The Trap Monitor gives you two viewing options:
a  Select Trap Types
0 Set Address Filters

Using these options, you can filter by severity or by router IP address

all trap messages that the Trap Monitor tool receives. The Trap
Monitor displays only those trap types that you specify.
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Filtering by Severity

To filter trap messages by type (fault, warning, information, debug, or
trace), proceed as follows:

1. From the Wellfleet Trap Monitor window, select View=>Select Trap
Types.

The Selected Trap-Type window appears (Figure 2-15).

[®] Selected Trap-Typdd]

i 0K | Cancel |

W {arning

M Information
{1 Debug
1 Trace

Figure 2-15. Selected Trap-Type Window

2. Select the trap types you want the Trap Monitor to display, then
click on OK.

Note: The fault, warning, and information types are usually the most

useful types to select.

The Wellfleet Trap Monitor window displays only those trap messages
that you specify. Refer to the later section “Clearing the Trap Monitor
Window” to learn how to remove unwanted messages from the window.

Filtering by Router IP Address

Filtering messages by IP source address specifies which routers’ trap
messages you want to appear in the Trap Monitor window. Specifying a
full IP address causes the Trap Monitor to show trap messages that
originate from the SNMP agent at that address only.
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Using the Trap Monitor

Specifying a partial IP address causes the Trap Monitor to show trap
messages from all router SNMP agents that have the same partial IP
address that you specify in the address filters window.

To configure an address filter from the Wellfleet Trap Monitor window,
follow these steps:

1. Select View=>Set Address Filters. The Address Filters window
appears (Figure 2-16).

[®] Address Filters §

Save| | Cancel |

265, 265, 265, 255
255, 255, 255, 255
205, 265, 265, 255

Figure 2-16. Address Filters Window

A default address filter of 0.0.0.0 causes the Trap Monitor to
display trap messages from all Wellfleet routers that you configure
to send trap messages to your Site Manager workstation.

The default address filter entry, 255.255.255.255, is merely a
placeholder for an IP address that you choose to enter.

2. In the Address Filters window, specify one or more IP addresses
and/or address filters.

You can enter as many as five complete IP addresses or address
filters. The remaining fields must display the placeholder IP
number 255.255.255.255.

Figure 2-17 shows a sample Address Filters window.
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[® Address Filters

Save| | Cancel |

128,0.0.0
192,32, 0.0

140, 250. 200, 1N
255, 265, 255, 255
265, 255, 255, 255

Figure 2-17. Sample Address Filters Window

With this configuration, you can view trap messages from all
routers with IP addresses starting with 128. and 192.32., along
with those from the router at IP address 140.250.200.1.

3. Click on Save.
Once you save the filter entries, the Trap Monitor displays trap

messages only from those routers with an IP address that matches the
value you specify in the Address Filters window.

Clearing the Trap Monitor Window

To clear the Wellfleet Trap Monitor window, select View—>Clear
Window. The Trap Monitor clears the window of all trap messages.

Since the system constantly updates the trap history file, new trap
messages appear right away.

Clearing the Trap History File

The trap history file can hold only a fixed number of messages. When it
reaches its limit, it starts overwriting the log at the beginning. The
Trap Monitor lets you empty the current trap history file so that you
can start a new log of trap messages.
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From the Wellfleet Trap Monitor window, select File=>Clear History
File.

The Trap Monitor updates the trap history file and begins immediately
to store new trap messages.

Saving Trap Messages

The Trap Monitor lets you save the traps currently displayed in the
Wellfleet Trap Monitor window to an ASCII file on your Site Manager
workstation. You can later view, edit, or print this file.

To save trap messages to an ASCII file, proceed as follows:
1. From the Wellfleet Trap Monitor window, select File=>Save Traps.
The Trap Monitor prompts you to name the file (Figure 2-18).

Save Traps to File

Enter file name: ]I . E

Figure 2-18. Saving Traps to a File

2. Type a directory and filename; then click on Save.

The system saves the log to an ASCII file on your computer. (If you
do not specify a directory, the system saves the file to your local
directory.) The Wellfleet Trap Monitor window reappears.

Note: You cannot reload an ASCII file back into the Trap Monitor.
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Chapter 3
Using the Events Manager

For general information about monitoring events, see “Monitoring
Traps and Events” in Chapter 1. For specific information about using
buttons, windows, and other Site Manager features, refer to Using Site
Manager Software.

Use the Events Manager to do the following:
Display event logs

Filter event messages

Search for an event message

Refresh the Events Manager window
Clear the Events Manager window

Save event messages

a o o o o a Qa

Clear the current event log
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Connecting to a Router

Connecting to a Router

When you view a router’s event messages, you can connect to the
router from either the Wellfleet Site Manager window or the Wellfleet
Events Manager window.

To connect to a router using the Events Manager, proceed as follows:

1. Select Tools»Events Manager from the Wellfleet Site Manager
window.

The Events Manager window appears.

2. From the Wellfleet Events Manager window, select
Options=>Router Connection.

The Router Connection Options window appears (Figure 3-1).

[®] Router Connection Options

Node Name/IP Address W32, 32, 156,68
Identity (Conmumity)

Tineout (seconds) e —

Retries (per request) M

Figure 3-1. Router Connection Options Window

3. In the Node Name/IP Address field, type the IP address of the
router to which you want to connect. Then click on OK.

The Wellfleet Events Manager window displays the specified IP
address.




Using the Events Manager

Displaying Event Logs

You must know how to load an event log into the Wellfleet Events
Manager window, as event messages do not appear in the window until
you retrieve this log. There are three types of event logs that you can
load into the Events Manager:

a  Current: The log in the router’s memory
a Remote: The log on the router’s flash card or floppy diskette

a  Local: The log transferred and saved (in binary format) to the Site
Manager workstation

When you retrieve an event log file using Site Manager, you are using
the Trivial File Transfer Protocol (TFTP) to transfer this file from the
router’s memory to the Site Manager workstation.

Displaying the Current Log
The current log is the temporary log file in the router’s memory.

Before you display these event messages, you must first connect to the
router whose event log you want to view. Then, to display the current

log in the router’s memory, select File>Get Current Log File from the
Wellfleet Events Manager window.

Event messages appear in the Wellfleet Events Manager window,
along with the following information (Figure 3-2):

0 WELLFLT.LOG appears in the Log Filename field.
O Current Log appears in the Log File Source field.

a The total number of events appears in the Number of Records field.

Refer to Event Messages for Wellfleet Routers for a listing of event
messages and suggested responses.
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Displaying Event Logs

@ Wellflect Bvents Manager @ il 8 2 0 2 2 2 @ =
File View Options Find Help
Systen Name: 192,32, 156,9 Display:
& Descending
Log File Name: WELLFLT, LOG
Log File Source: Current Log Number of records: 5261
# 59: 12/04/93 15:43:58 INFO SLOT 4 MIB Event Code: 3 if»
Service initializing, 1
# 68: 12/04/93 15:43:58 INFO SLOT 4 NOV_SYNC Event Code: 2
Service initializing,
# 7b: 12/04/93 15:43:58  INFO SLOT 4 DP Event Code: 4
Service initializing,
# 90: 12/04/93 15:43:59  INFO SLOT 4 SYS Event Code: 3
Service initializing,
# 480: 12/06/93 16:48:52  INFO SLOT 3 MIB Event Code: 5
wiConsole, wiMoreEnable, § set to 2
# 519: 12/06/93 17:28:26 WARNING SLOT 3 TI Event Code: 2
Invalid login attempt by quit
#3195: 12/15/93 16:47:11  INFO SLOT 2 TFTP Event Code: 2
Protocol initializing,
#3207: 12/15/93 16:47:12  INFO SLOT 2 TCP Event Code: 5
TCP is TP,
#3209: 12/15/93 16:47:12  INFO SLOT 2 TCP Event Code: 6
TCP Opened: 0.0,0.0,23 - 0,0, 0,0, 0 TCB: 0x3053d240
#3210: 12/15/93 16:47:12  INFO SLOT 2 TELNET Event Code: 5
Connection Manager listening on TCP port 23
#3211: 12/15/93 16:47:15 WARNING SLOT 2 CSMACD Event Code: 7
Connector XCVRL no SQE,
#3218: 12/15/93 16:47:15 INFO SLOT 2 ARP Event Code: 1
Service is up on circuit 1
#3225: 12/15/93 16:47:15 INFO SLOT 2 IP Event Code: 2 ip®
RE T

Figure 3-2. Wellfleet Events Manager Window

You can scroll through the event messages using the scroll bars on the
bottom and right side of the window. Select Ascending to display events
from the latest to the earliest time that they occurred. Select
Descending to display events from earliest to latest.
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Displaying a Remote Log

A remote log resides on the router’s memory card or floppy diskette. To
display a remote log, you must retrieve the log from the router’s media.

Before you display any event messages, you must connect to the router
whose event messages you want to view. After doing this, proceed as
follows:

1. From the Wellfleet Events Manager window, select File=>Get
Remote Log File.

The Load Remote Log File window appears (Figure 3-3).

[®] Load Remote Log File [l

File name: ll E
Volume:

Directory: | 1

[+
| < S— >

Figure 3-3. Load Remote Log File Window

2. Select the volume that contains the log file from the Volume pull-
down menu.

3. Enter the filename.
4. Click on Open.
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The router transfers the file to the Site Manager workstation, where
Site Manager displays the events listed in the file in the Wellfleet
Events Manager window. Along with event messages from the router’s
memory card or diskette, the following data appears in the Wellfleet
Events Manager window:

0 The filename you selected appears in the Log Filename field.

O Remote Log appears in the Log File Source field.

a  The total number of events appears in the Number of records field.

Displaying a Local Log

A local log resides on the hard drive of your Site Manager workstation.
Before you display any event messages, you must connect to the router
whose event log you want to view. After doing this, proceed as follows:

1. From the Wellfleet Events Manager window, select File>Load
Local Log File.

A Load Local Log window appears (Figure 3-4).

[@ Load Local Log &L i 1)

Filter

I/ extra/sngr/* §
Directories Files

L] atmprot

. atmpvc

. wastebasket atmvep

. wfscrns . Rauthority

Ed . Kdefaults

JILL . Xdefaults, open
NEWSTATS . cshre

bruce . desksetdefaults
FN_ Ew
Selection

I/ extra/sngr/ i
{Filter | {Cancel |

Figure 3-4. Load Local Log Window
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2. Select the directory that contains the log file in the Directories box
until the path to the directory appears in the Selection window.

3. Select or type in the filename in the Selection box after the
pathname.

4. Click on OK.

Along with the event messages from this file, the following data
appears in the Wellfleet Events Manager window:

a The filename you selected appears in the Log Filename field.
0 The name Local Log appears in the Log File Source field.

a The total number of events appears in the Number of records field.

Filtering Event Messages

You can specify the types of event messages that appear in the
Wellfleet Events Manager window by specifying filters. You can filter
the event messages by router IP address, severity, slot, or entity. The
Filters feature in the Trap Monitor window specifically filters for
severity, slot, and entity.

Note: Filtering does not affect how events are logged in the router’s
memory. Event messages are filtered only in the Events
Manager window, not in their source.

Filtering by Severity, Slot, and Entity
Filter the event messages shown in the Wellfleet Events Manager
window as follows:
1. Display events in the Wellfleet Events Manager window.
2. Select View=>Filters.
The Filtering Parameters window appears (Figure 3-5).

This window highlights the activated parameters. You can use the
Toggle button to quickly switch between highlighted and
nonhighlighted options.




Filtering Event Messages

[® Filtering Paraneters B

Legeﬁg[é ight Include in display
nclude in dis
i :

Lowlight Exclude from display
Severity Entities

ENT - |

{ OK | iRefresh| 1Toggle| |Cancel]|

Figure 3-5. Filtering Parameters Window

You can change the filtering setup by highlighting any Severity,
Slot, or Entities parameter you want included in the next event log
display. You can then do the following:

o Click on Refresh to refilter the event messages in the Events
Manager window.

o Click on OK to save the changes you made in the Filtering
Parameters window without automatically refiltering the event
messages in the Events Manager window.

3. Select the parameters you are interested in. Then click on Refresh
or OK.

Notice that the number of records does not change; a complete listing
of the number of event messages is always provided.

Note: We recommend filtering for trace events only when you

diagnose network problems. You do not need to filter for debug
events.
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Filtering by Router IP Address

Filtering by router IP address requires that you connect to a router
from the Wellfleet Site Manager window or Wellfleet Events Manager
window. See the earlier section “Connecting to a Router.” Then display
a current event log, remote event log, or local event log using the File
menu. See “Displaying Event Logs,” described earlier.

Event messages appear in the Wellfleet Events Manager window. You
have effectively “filtered” a log by router IP address.

Searching for an Event Message

The Events Manager provides Find and Find Next options for locating
an event that contains text that you specify.

Locate an event containing the text you specify as follows:
1. Display events in the Wellfleet Events Manager window.
2. Select Find->Find.

The Find Text Pattern window appears (Figure 3-6).

[@ Find Text Pattern

Text Pattern: 1R

e

Figure 3-6. Find Text Pattern Window

3. Type the text you want to find.

You can type up to 255 characters (including spaces) in this box.

Note: The Find Text Pattern window is case-sensitive.
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4. Click on Find.

Site Manager searches from the first event highlighted in the log to
the first instance of the text pattern and highlights the event that
contains the text pattern.

5. Select Find=>Find Next to find the next instance of the same text
pattern.

Refreshing the Events Manager Window

To redisplay a log file in Site Manager’s memory after you set up new
filters, select View->Refresh Display from the Wellfleet Events
Manager window.

The Events Manager displays the events that match the filters you last
saved, according to the setting of the Ascending/Descending option in
the Wellfleet Events Manager window.

Clearing the Events Manager Window

To clear the events in the Wellfleet Events Manager window, select
View—=>Clear Window.

The Wellfleet Events Manager window clears and remains empty until
the next time you load an event log or refresh the display.

Saving Event Messages

You can save the event messages that appear in the Wellfleet Events
Manager window to an ASCII file on your Site Manager workstation.
You can then print the log using any tool on your workstation.

To save an event log to an ASCII file, follow these steps:
1. Display the event log in the Wellfleet Events Manager window.

2. Filter the event messages displayed.
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3. Select File>Save Output to Disk.
The Save Log window appears (Figure 3-7).

@ Save Log §1
Filter
|/extra/smgr/* l
Directories Files
L] atmprot
o atmpvc
. wastebasket atmvep
.wiscrns . Xauthority
Ed . Adefaults
JILL . Kdefaults, open
NEWSTATS . cshre
bruce . desksetdefaults
Selection
|/extra/srmgr/ %
o] [Feer] Cancel

Figure 3-7. Save Log Window

4. Select the directory path in which you want to save the file.
The path appears in the Selection window.

5. Enter the filename in the Selection window after the path.

6. Click on OK.

The Events Manager saves the log to an ASCII file in the specified
local directory. (If you do not specify a directory, the file is
automatically saved to your local directory.)

Note: For viewing purposes, you can reload into the Events Manager
event logs stored in binary format. You cannot reload into the
Events Manager event logs stored in ASCII format.
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Clearing the Current Event Log

The router’s event log can hold only a fixed number of messages. When
it reaches its limit, it starts overwriting the log at the beginning. To
clear a router’s current event log, select Administration>Clear Log
from the Wellfleet Site Manager window. A confirmation window
appears (Figure 3-8).

[®] message_popup (L

§ Proceed with "Clear Log” ?

|Cancel

Figure 3-8. Confirmation Window

Click on OK in the confirmation window to delete all the event
messages that are currently stored in the router’s memory. Site
Manager enters a message in the event log indicating that it has
cleared the log. New event messages automatically start filling the
event log again.
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Chapter 4
Using the Statistics Manager

For general information about monitoring router statistics, see
“Monitoring Statistics” in Chapter 1. For specific information about
using buttons, windows, and other Site Manager features, refer to
Using Site Manager Software.

Use the Statistics Manager to do the following:
Access statistics

Connect to a router

View the Wellfleet MIB

Define the current screen list

Display statistics screens

Create statistics filters

Search for statistics information

Save statistics information

o o o o o o o o a

Build custom statistics screens
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Accessing Statistics

You access all router statistics from the Statistics Manager window. To
access this window, begin at the Wellfleet Site Manager window and
select Tools>Statistics Manager. The Statistics Manager window
appears (Figure 4-1).

[®] Statistics Manager &

File View Options Tools Window

SNMP Agent: 192,32,156,9

Circuit Nameg#l Slot Connector  Type  Protocols
ol (1) P CSMACD

1o 2 1 IP, RIP
031 3 1 TOKEN SR, LLC2, LSS
031, 1162 (8) 8 1 TOKEN  LLCZ, LSS, DLS, LIC2 (VO)
E22 (4) 2 2 CSMACD LB, SPT, IP, RIP, EGP, OSPF
$31 () 3 1 SN FR, PRQ

832 () 3 2 SYNC  PPP, OSI

s41 (7) 4 1 SYNC  SMDS, AT

542 (8) 4 2 SYNC %25

xvcd, 2, 204102, 0 4 2 SNC 08I, X25(UC)

Figure 4-1. Statistics Manager Window

Note: The Statistics Manager requires an active connection to a
target router to display router statistics. The next section
describes how to use the Statistics Manager tool to establish or
change a connection to a router.

The Statistics Manager window displays the current router’s
configuration. That is, it displays the circuit type and location of the
router’s network interfaces and the bridging and routing protocols that
are enabled on each interface.
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Connecting to a Router

To connect to a router from the Statistics Manager window, proceed as
follows:

1. Select Options>Router Connection.

The Router Connection Options window appears (Figure 4-2).

[®] Router Comnection Options 2]

Node Name/IP Address 82, 32, 156, 68
Identity (Community)

Timeout (seconds)

Retries (per request)

%)
I

Figure 4-2. Router Connection Options Window

2. Specify the target router’s IP address in the Node Name/IP Address
field. Then click on OK.

The SNMP Agent field in the Statistics Manager window displays the
IP address of the router you specified. (See Figure 4-1.)

Viewing the Wellfleet MIB

You view the Wellfleet Management Information Base (MIB) using the
Quick Get tool. Quick Get includes a MIB Browser tool that lets you
scroll through and select up to ten objects from the MIB. You then use
Quick Get to get all instances of objects you select and to display that
information in columns in the Quick Get Facility window.
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To access the Quick Get Facility window, begin at the Statistics
Manager window and select Tools=>Quick Get. The Quick Get Facility
window appears (Figure 4-3).

[®] Quick Get Facility
Mib ObJects
wiHardwareConfig ObJect Information
wiSoftwareConfig #ccess: Read-Only
wiSysten Type: Integer
wiline Symtax:
witpplication
MIB Read Description,.,
Browser Retrieval Filter

Instance ID:

Display Information
Instance ID: < Yes OMNo

4] Retrieve Request

Output

[ S— ]

Figure 4-3. Quick Get Facility Window

The MIB Browser operates the MIB Objects window located in the top
left corner of the window.
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Using the MIB Browser

The Wellfleet MIB is organized as a hierarchical tree. When you first
activate Quick Get, the MIB Browser displays the five object groups at
the top of the tree:

0  wfHardwareConfig
o  wiSoftwareConfig
o wifSystem

o wfLine

0 wfApplication

Beneath these five object groups, related objects are organized in
subordinate object groups, or tables (for example, Figure 4-4 shows
part of the MIB tree for the wfSystem object group). The prefix wf that
precedes each MIB object indicates that it is a Wellfleet enterprise-
specific object.

wfHardwareConfig, wfSoftwareConfig, wfSystem, wiLine, wfApplication

N

wiServices wfSystem

wiGame... wfConsole... wfTl Rui... wiSysDescrip
wfSysObjectID
wfSysContact
wiSysLocation
wiSysServices
wfGmtOffSet
wfMibVersion

Figure 4-4. MIB Tree for System Group
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To access individual objects, first select the top-level object group. The
MIB Browser brings you down one level in the tree and displays
subordinate object groups. Continue selecting object groups and
descending through the MIB tree until the MIB Browser displays the
individual objects that you want to select.

You can differentiate between object groups and individual objects by
noting their position in the MIB Browser window. Object groups are
flush left with the window; individual objects are indented slightly.

Use the scroll bar to scroll through the MIB. To move backward in the
MIB tree, select the Back option. Table 4-1 describes where to find
different types of MIB information.

Table 4-1.  Finding MIB Information

Top-Level MIB Object

Group Types of Objects/Information | Example
wiHardwareConfig Objects pertaining to Router backplane
router hardware configura- | ID, power supply,
tion temperature, serial
number
wiSoftwareConfig Objects pertaining to the Interface drivers
type of protocol and driver
software that is loaded,
and information required
to load the software
wiSystem Objects pertaining to the System record, con-
router system software sole, remote console,
circuit name table
wifLines Objects pertaining to driv- | FDDI tables, line
ers and lines state, line traffic
wfApplication LAN, WAN, and Bridge Routing tables,
information packet

information, protocol
state information
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Getting Instances of Selected Objects

You can select and retrieve instances for as many as ten MIB objects at
one time. To locate individual objects, find the object group or table
that logically categorizes the objects you are interested in.

Proceed as follows:
1. Select the top-level object group to which the objects belong.

The MIB Objects field displays a list of subordinate groups. For
example, when you select wfApplication, the objects shown in
Figure 4-5 appear.

[® Quick Get Facility
Mib ObJects

Back... i ObJect Information

wfDatalink fccess:

wiDecGroup Type:

wfInternet Syntax:

witppletalkiGroup

wilpxGroup | Read Description... |

wfOsiGroup

wiVinesGroup . .

wianGroup Retrieval Filter

wiAnsGroup Instance ID: '::j

wiTestGroup

wilLanManagerGroup Display Information
Instance ID: @ Yes < lo

Output

Figure 4-5. Sample Quick Get Facility Window
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Select additional object groups or tables until you reach the
individual objects you are interested in.

For example, to see the current state of all IP interfaces configured
on the router, select wflnternet, wflpRouting, wfIpGroup,
wflplInterfaceTable. Then select the wfIPInterfaceState and
wfIPInterfaceAddr objects located beneath the wflpInterfaceTable
group.

Select each object in which you are interested. Note that selectable
objects are indented.

When you select an individual object, the Object Information field
at the top right of the Quick Get Facility window displays the
following information about that object:

Access Whether the object is user-configurable

(read-write) or nonconfigurable (read-only)
Type The type of object (integer, octet, string)
Syntax The possible values for the object

Click on Read Description to display a Statistics Help window that
contains a more detailed description of the object. Click on OK to
exit the Statistics Help window.

To deselect an object listed under MIB Objects, select the object
again.

Use selections in the Display Information and Retrieval Filter
fields of the Quick Get Facility window to determine the format of
MIB objects retrieved to the Output field of that window.

You can use the Quick Get Facility to display

a All (unfiltered) or specific (filtered) instances of MIB objects
selected in the Mib Objects field

o All (filtered or unfiltered) instances of selected MIB objects,
with or without their associated instance IDs
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To display without instance IDs all instances of MIB objects

selected in the Mib Objects field (Figure 4-6):
a. Leave the Retrieval Filter field blank.

b. Select No in the Display Information field.
c. Click on the Retrieve Request button.

[®] Quick Get Facility

Mib ObJjects

Back, ..

wfIpBaseRtEntry
wfIpBaseRouteDest
wfIpBaseRouteIfIndex
wiTpBaseRouteletricl
wflpBaseRouteMetric2
wfIpBaseRouteletric3
wiTpBaseRouteMetricd
ywiTpBaseRoutellextHop
wiIpBaseRouteType
wfTpBaseRouteProto
wiTpBaseRoutedge
wilpBaseRouteMask
wilpBaseRouteMetrich
wfIpBaseRouteInfo

ObJect Information
Access: Read-Only
Type: Integer
Syntax:

{ Read Description... |

Retrieval Filter
Instance ID:

Display Information
Instance ID: < Yes € No

Retrieve Request

Output

wfTpBaseRouteNextHop
192,32, 156, 65
192,32, 156, 65
192,32, 156,65
192,32, 156,65
192, 32, 156, 65
192,32, 156, 65
192,32, 156, 65
192,32, 156,65
192, 32, 156, 65

Ik o ——————

»

Figure 4-6. All Instances Retrieved (Unfiltered) without Instance IDs

To display with instance IDs all instances of MIB objects selected in
the Mib Objects field (Figure 4-7):

a. Leave the Retrieval Filter field blank.
b. Select Yes in the Display Information field.
c. Click on the Retrieve Request button.
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[® Quick Get Facility

Mib Objects

Back, .. ObJect Information
wilpBaseRtEntry fccess: Read-Only
wilpBaseRouteDest Type: Integer
wiTpBaseRoutel fIndex Syntax:
wfTpRaseRouteMetricl
wiTpBaseRouteletric? { Read Description... |
wilpBaseRouteMetric3
waaseRou["]etr Retrieval Filter
| PR
wilpBaseRouteProto
wf&pgasegouteagek Display Information
wiTpBaseRoutellas .
wiIpBaseRouteletrich Instance ID: @ Yes Olo
pBaseRouteInfo
- ———
Output
Instance ID wfIpBaseRouteNextHop -
13,1, 0.0 192, 32, 156, 66
192,32, 1.0 192, 32, 156, 65
192,32, 2.0 192, 32, 196, 65
192,32, 4,0 192,32, 156, 65
192,32,5.0 192, 32, 156, 65
192,32.6, 0 192, 32, 156, 65
192,32, 7,0 192, 32, 156, 65
192,328, 0 192, 32, 166, 65
192,32,9,0 192, 32, 166, 65 ¥
B —— ™

Figure 4-7. All Instances Retrieved (Unfiltered) with Instance IDs

To display without instance IDs only specific (filtered) instances of
MIB objects selected in the Mib Objects field (Figure 4-8):

a. Enter all or part of the instance ID for the desired MIB object(s)
in the Retrieval Filter field. (Entering more of the instance ID
narrows the object search.)

b. Select No in the Display Information field.

c. Click on the Retrieve Request button.
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[® Quick Get Facility

Mib Obgects
Back. .. B Object Information
wfIpBaseRtEntry Access: Read-Only

wfTpRaseRouteDest Type: Integer

wiTpBaseRouteIfIndex Syntax:
wfIpBaseRouteletricl

wfIpBaseRouteletric? | Read Description... |
wiIpBaseRouteletric3d
wilpBaseRouteMetricd
wiTpBaseRoutetlzztHop

Retrieval Filter

wfIpBageRouteType Instance ID: |192,168,

wiTpBaseRouteProto
wiIpBaseRoutefge Display Information

wilpBaseRoutetask Instance ID: < Yes @ No
wiTpBaseRouteMetrich

wfIBaseRouteInfo ¥ Retrisvs Feqmest

4 —— >
Qutput

wilpBaseRouteNextHop
192, 32, 156, 65
192, 32, 156, 65
192, 32, 156, 65
192, 32, 156, 65
192, 32, 156, 65

[ —

Figure 4-8. Specific Instances Retrieved without Instance IDs

To display without instance IDs only specific (filtered) instances of
MIB objects selected in the Mib Objects field (Figure 4-9):

a. Enter all or part of the instance ID for the desired MIB object(s)
in the Retrieval Filter field. (Entering more of the instance ID
narrows the object search.)

b. Select Yes in the Display Information field.
c. Click on the Retrieve Request button.
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[®] Quick Get Facility

Mib Objects

Back.. Ob3ect Information

wfIpBaseRtEntry Access: Read-Only
wfTpBaseRouteDest Type: Integer
wETpBaseRoutelfIndex Syntax:
wflpBaseRouteMetricl
wiTpBaseRouteMetric? { Read Description,.. |
wilpBaseRouteletric3
B R Retrieval Filter
wfIpBaseRouteType Instance ID: 192,32, 156}
wfIpBaseRouteProto
wfTpBaseRoutedge Display Information
wflpBaseRoutetlask Instance ID: 4 Yes < No
wfIpBaseRouteMetrich
wfIBaseRouteInfo

-4 ———— e

Qutput

Instance ID  wflpBaseRoutelextHop
192, 32, 156, 64 192,32, 156, 68
192,32, 156, 128 192, 32, 156, 65

Felp

Figure 4-9. Specific Instances Retrieved with Instance IDs
5. Click on Stop Retrieval to halt retrieval of MIB objects selected in
the Mib Objects field.

6. Click on Retrieve Request each time you want to refresh the
information displayed in the Output field.

7. To exit the Quick Get Facility window, click on Done.

Defining the Current Screen List

The current screen list is a subset of the default statistics screens and
any custom statistics screens you build. (More information follows on
the Screen Builder tool you use to custom design router statistics
screens.)
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Note: When you first use the Statistics Manager, the current screen
list is empty. To view router statistics, you must add statistics
screens to the current screen list.

To manage your statistics screen database most effectively, add to the
current screen list only those statistics screens that you use most
often.

Adding Statistics Screens

To add a statistics screen to the current screen list, follow these steps:

1. From the Statistics Manager window, select Tools=2>Screen
Manager.

The Screen Manager window appears (Figure 4-10).

[®@] Screen Manager

Default Screeng Current

Gt_aarp. dat fppleTalk B8RP 1 e Screen List

::E— cL dg;t ggﬁ%ﬂ ﬁg’g‘nT%E %tﬁaarp. dat fppleTalk 8ARP Ta| [
- : pRoute

Zt‘faarng: gZE iggﬁ%ﬁ E%t-}'g‘g ip_trfc. dat IP Traffic Inform

at_tddp, dat AppleTalk DDP Tra at_main.dat  Applelalk Main In

at_rtmp, dat  8ppleTalk Routing
ZE_E?E};I). gg% iggﬁ%‘gﬁ E]%EOTEZ add ) at_tarp, dat AppleTalk &RP Tra
= at_tddp, dat 8ppleTalk DDP Tra
at_techo, dat AppleTalk ECHO Tr

at_tnbpl, dat AppleTalk NBP Tra
at_tnbp2, dat 8ppleTalk NBP Tra

User Screens

Tphrp IP frp Table || [Copy Default || iry qut o
: _trt, ppleTalk Route T
EnetTrfc CSMACD Traffic In at_tzipl, dat AppleTalk ZIP Tra

HesiTrfe HSSI Traffic Info at_tzip2 dat AppleTalk Zip Tra

SMDS SMDS Main Informa :
Dise  one et T e e |
Bridge Learning Bridge I =

traffic Line Traffic 4 ——— ]
IP Routing Table

LK ] 1 Help | { Cancel |

Figure 4-10. Screen Manager Window
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The Screen Manager displays the default statistics screens, grouped by
protocol. Use the scroll bar to scroll through the list. If you have not yet
built any custom statistics screens, then the User Screens list is empty.
Later, it will display any custom screens you create using the Screen
Builder.

The Statistics Manager identifies each default statistics screen using a
filename with the .dat extension, followed by a description that
describes the type of data the screen displays. In the example shown in
Figure 4-11 the statistics screen displays IP routing statistics.

Filename  Screen Description

ip_rte.dat IP Routing Table

Figure 4-11. Example of Filename and Screen Description

2. Highlight the statistics screen you want to add to the Current
Screen List, then click on Add.

The Current Screen List can contain both default screens and
custom screens at the same time, so you can add statistics screens
from either list. The Statistics Manager updates the Current
Screen List to include the statistics screen that you add.

Repeat steps 1 and 2 to add additional statistics screens to the
current screen list.

3. Click on OK to update the current screen list and save your
changes, or click on Cancel to exit the Screen Manager window
without saving the changes.

You can use the Launch Facility to display any screen on the current
screen list. For instructions, see “Displaying Statistics Screens” later
in this chapter.
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Removing Statistics Screens

To remove a statistics screen from the Current Screen List, follow
these steps:

1.

From the Statistics Manager window, select Tools=>Screen
Manager.

The Screen Manager window appears.

Highlight the statistics screen you want to remove from the current
screen list. Then click on Remove.

The Statistics Manager removes the statistics screen you select.
Repeat Steps 1 and 2 to remove additional statistics screens.

Click on OK to exit the window and save your changes, or click on
Cancel to exit without saving the changes.

Displaying Statistics Screens

Use the Launch Facility to display statistics screens.

Note: Before you can display a statistics screen, you must add it to the

current screen list. For instructions, see the previous section,
“Defining the Current Screen List.”

To display a statistics screen, follow these steps:

1.

From the Statistics Manager window, select Tools>Launch
Facility.

The Statistics Launch Facility window displays the statistics
screens that are in the Current Screen List (Figure 4-12).
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[®] Statistics Launch Facility

Statistics Screens
at_aarp, dat  &ppleTalk S8RP Table
IpRoute

hp trfo, dat  IP Traffic Information
at_main, dat A&ppleTalk Main Information
at_rtmp, dat 8ppleTalk Routing Table
at_tarp, dat 8ppleTalk ARP Traffic
at_tddp, dat  8ppleTalk DDP Traffic
at_techo, dat &ppleTalk ECHO Traffic
at_tnbpl, dat &ppleTalk NEP Traffic #1
at_tnbp2, dat &ppleTalk NBP Traffic #2
at_trt.dat  AppleTalk Route Traffic
at_tzipl,dat 8ppleTalk ZIP Traffic #1

kl :

Figure 4-12. Selecting a Screen
2. Select one of the statistics screens and click on Launch.

Once you launch the statistics screen, Site Manager begins retrieving
the specified MIB objects from the router. After a short time, a
statistics screen appears, such as the one shown in Figure 4-13.
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[® IP Traffic Information 2]

File View Options Filters Search Help

Screen Name: ip_trfc, dat
Description: IP Traffic Information
Snmp Agent : 192, 32, 156, 65

Number of Elements: 4

Circuit Name IP Address State Datagrams RCVD Datagrams HMIT .
] 0, i) i
E24 192, 32, 156,65 Up 37399568 39536304
041 192,32, 156,129 Up 417463 458611
E21 192, 32, 180, 43 Up 39508309 34535891

Figure 4-13. Statistics Screen

Refreshing Active Statistics Screens

To update a statistics screen, select View->Refresh Display.

The Statistics Manager retrieves the MIB objects from the router and
updates the statistics screen with the new data.

Specifying Circuit Mode Statistics Polling Rate

A circuit mode statistics screen is one that the Statistics Manager
continually updates with new data. When viewing a circuit mode
screen, you can specify how often the Statistics Manager polls the
router to update the data.
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To specify the polling rate, begin at a statistics screen and proceed as
follows:

1. Select Options=>Poll Rate.
The Polling Rate window appears (Figure 4-14).

[® Polling Rate {1 0

Poll Rate (secs): T — _—

Figure 4-14. Polling Rate Window

2. Use the slidebar to specify a polling rate; then click on OK.

Zeroing Circuit Mode Statistics

You can reset all counters in a circuit mode statistics screen to zero
through the Zero All Counters menu option. You can also reset all

counters in a selected row to zero through the Zero Current Row
Counters menu option.

Note: These functions affect only the values displayed in Site
Manager circuit mode statistics windows, and have no effect on
the actual value of counter objects in a router MIB.

Zeroing All Counters in a Screen

To clear all counters in a circuit mode statistics screen, select
Options=>Zero All Counters.

Figure 4-15 shows a typical response to the Zero All Counters option.
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[® IP Traffic Information 2]
File View Options Filters Search Help

Screen Name: 1p_trfc, dat .
Description: IP Traffic Information
Snmp Agent - 192, 32, 156, 65

Number of Elements: 4

Circuit Name IP Address State Datagramg RCVD Datagrams XMIT

S3l L0.0.1 Down 0 0 il
24 192, 32, 156, 65 Up

B21 192, 32, 180, 43 Up

Figure 4-15. Zeroing All Counters in a Screen

Note: In this example, the counters Datagrams RCVD and
Datagrams XMIT reset to zero in the statistics screen. This type
of reset has no effect on the actual, current values of these
counter objects in the router MIB.

The Zero All Counters command stores the value of every counter
object in the display at reset time. Each stored value provides a
reference point for counter values displayed following the reset; that is,
after resetting all counters in the display.

a The Statistics Manager displays only the difference between the
counter value at reset time (the last known reference value) and
the actual, current (MIB) value of the same counter.

a  The counter values in display reflect the amount of change incurred
beyond the reference values stored at reset time.
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Zeroing All Counters in a Specific Row

To clear all counters in a specific row of a circuit mode statistics screen,
select a row, then select Options>Zero Current Row Counter.

Figure 4-16 shows a typical response to the Zero Current Row
Counters option.

[®] IP Traffic Information 2]

File View Options Filters gSearch Help

Screen Name: ip_trfc, dat .
Description: IP Traffic Information
Srmp Agent - 192, 32, 156, 65

Number of Elements: 4

Circuit Name IP Address State Datagrams RCVD Datagramg XMIT
831 1.0.0.1 Down 0 0 :
. S 192,32,156,85 _ _ _ _ Up_ ___ _ 37248589 _ _ _ _ _ 39398833 _ ______
A R 192,32,196,129 _ _ _ _Up_ _ _ _ __ _ 0 e 0 o e j
E21 192,132,180, 43 Up 39370380 34388427

Figure 4-16. Zeroing All Counters in a Specific Row

The counters Datagrams RCVD and Datagrams XMIT reset to zero in
the selected row. The reset has no effect on the actual, current values of
these counter objects in the router MIB.
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The Zero Current Row Counters command stores the value of every
counter object displayed in the selected row at reset time. Each stored
value provides a reference point for counter values displayed in the
selected row following the reset. That is, after resetting all counters in
a display row

o The Statistics Manager displays only the difference between the
counter value at reset time (the last known reference value) and
the actual, current (MIB) value of the same counter.

o The counter values in display reflect the amount of change incurred
beyond the reference values stored at reset time.

Stopping Statistics Retrieval

To stop the Statistics Manager from collecting any further statistics in
the current screen, select View=>Stop Retrieval.

Creating Statistics Filters

You can set a display filter or a retrieval filter for each Statistics screen
you open from the Statistics Manager Launch Facility.

Without filtering, the Statistics Manager polls a router for the values
of all MIB objects defined in the currently active Statistics screen. The
screen subsequently shows the values of those objects, as determined
by the data returned by the router.

A display filter is a software mechanism that enables the Statistics
Manager to search the entire contents of the currently active Statistics
screen and then

0 Show only those rows that contain an object that in turn contains a
string matching in value to the filter string. (This is the display
filter’s Display option.)

o Hide only those rows that contain an object that in turn contains a
string matching in value to the filter string. (This is the display
filter’s No Display option.)
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Specifying a longer display filter string narrows the number of match
possibilities available from the currently active Statistics screen.

A retrieval filter is a software mechanism that enables the Statistics
Manager to poll a router for only a subset of specific MIB objects. These
objects have Instance IDs that match the full or partial Instance ID
you enter in the Retrieval Filter window.

The currently active Statistics screen subsequently displays the values
of those objects, as determined by the data returned by the polled
router. The Statistics Manager polls only one router in each Statistics
window.

The retrieval filtering mechanism for a statistics screen works
substantially in the same way as does the retrieval filtering
mechanism for the Quick Get Facility. That is, specifying more of the
instance ID in the Retrieval Filter window causes the workstation to
solicit a smaller number of objects from a router. This, in turn,
typically reduces the number of objects displayed in the active
Statistics screen.

Using retrieval filters to collect statistics across your network reduces

1 The amount of processing overhead performed by your Site
Manager workstation and any polled router

a The amount of network bandwidth consumed for the purpose of
periodic polling and poll responses

You can use display filters and retrieval filters in various

combinations. For example, you could

0 Use aretrieval filter first to solicit from routers in your network the
values of certain MIB objects

a  Apply a display filter to hide or show objects in the resulting
Statistics screen
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Using Display Filters
To create a display filter, begin from a statistics screen, then

1. Select Filters>Display Filters.

The Display Filters window prompts you to define the filter (Figure
4-17).

(@ Display Filter

Text: ﬁ ?

O —

Action: 4 Display
£ No Display

{ 0K | iRefresh| | Help | | Cancel |

Figure 4-17. Display Filters Window

2. Enter the text string you want to filter in the Text field.
3. Specify the column where you want the filter to take effect.

Use the slidebar to select the column that displays the statistics
that you want to filter.

In this case, Site Manager displays the statistics for the address
mask in column 5. Thus, you use the slidebar to specify column 5.

4. Select either Display or No Display, depending on the desired
action.

If you want the Statistics Manager to display only those statistics
that match the filter, select Display. If you want the Statistics
Manager to hide those statistics that match the filter, select No
Display.
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5. Click on OK to save the filter in memory, or click on Refresh to
implement the filter immediately.

— If you click on OK, the filter box disappears. There will be no
immediate change to the statistics screen. However, the next
time you refresh the statistics screen, it will display only the
statistics specified by the filter.

— If you click on Refresh, the Statistics Manager immediately
refreshes the screen and displays only the statistics specified by
the filter.

6. Click on OK to exit the Display Filters window.
Display Filter Example:

To filter out of the window shown in Figure 4-18 statistics for the
circuit that has an address mask value of 255.0.0.0, configure the
display filter shown in Figure 4-19.

[® IP Interface Information &8 0 . -
File View Options Search Help

Screen Name: ip_main, dat
Description: IP Interface Information
Snmp Agent = 192,32, 156, 9

CJ.'L‘CUJ.t Wame IP Address State MAC Address Address ["]ask

192, 32, 156, 9 i LoD T 255 . 6 O

Figure 4-18. Statistics Window Unfiltered
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[® Display Filters NI &7

Text:  1256.0,0.00 §
e —

fction: < Display
@ o Display

i 0K | [Refresh| | Help | | Cancel |

Figure 4-19. Sample Display Filters Window

When you click on Refresh in the Display Filters window (Figure 4-19),
the Statistics Manager filters out of the active statistics window the
line with the IP address mask of 255.0.0.0 in column 5.

Figure 4-20 shows the result of applying the display filter to the active
Statistics window.
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[®] IP Interface Information & e
File View Options Search Help

Screen Name: ip_main, dat
Description: IP Interface Information
Snmp 8gent - 192,32, 156. 9

Circuit Name IP Address State MAC Address Address Mask
__ k2L __192.32,156,9 _ _ _ _ Up _ _ _ _0x00004201B8D0 _ _ _ 255,255,286, 0. _ _ _ _ _ _ A

Figure 4-20. Statistics Screen after Filter Inplemented

Using Retrieval Filters

To create a retrieval filter, begin from a statistics screen, then
1. Select Filters>Retrieval Filters.

The Retrieval Filters window appears (Figure 4-21).
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[®] Retrieval Filters

Instance ID: |192,32, 235 |

I OK | iHelp| ICancell

Figure 4-21. Retrieval Filters Window

2. Enter the Instance ID of the object(s) you want to view.

Specifying a partial ID causes the Statistics Manager to poll and
display all objects that begin with the same partial ID.

3. Click on OK to save the filter in memory associated with the
current statistics screen.

4. Select View=>Refresh Display from the statistics screen.
Figure 4-22 shows the result of this retrieval filter. The Statistics

Manager retrieves only one MIB object; no other instances of the same
object exist in the MIB associated with the currently connected router.
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[®] IP Routing Table

File View Options Filters Search Help

Screen Name: ip_rte, dat
Description: IP Routing Table
Snmp Agent @ 192, 32, 156, 6
Number of Elements: 1

Destination Metric Wext Hop Type Protocol fge Index
192,32, 235, 0 3 192, 32, 156, 65 Indirect Rip 0 1 i

Figure 4-22. Statistics Screen After Inplementing a Retrieval Filter

Searching for Statistics Information

You can search for any text string that appears on a statistics screen.

To define the text string to search for, proceed as follows:
1. Select Search->Find.

The Statistics Manager displays a Search Options window that
prompts you to define a text string (Figure 4-23).
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[® Search Options §

Text: [I %

{Find | | Help | | Cancel |

Figure 4-23. Search Options Window

2. Enter the text you want to search for; then click on Find.

The Statistics Manager highlights the line where the next instance
of the text string occurs. Continue clicking on Find in the Search
Options window.

Note: The Search Options window is case-sensitive.

If you still want to search for the text string you defined, but would
rather have the Search Options window disappear, proceed as follows:

1. Click on Cancel in the Search Options window.
The Search Options window disappears.
2. Select Search->Find Next.

The Statistics Manager highlights the line where the next instance
of the text string occurs.

Saving Statistics Information

The Statistics Manager allows you to save the information displayed
on a statistics screen to an ASCII file on your Site Manager
workstation.
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To save the information shown on the statistics screen, proceed as
follows:

1. Select File=>Save As from the statistics screen. A file directory box
appears, prompting you to select a place to store the data.

2. Select a directory in which to store the data.

3. Select a file in which to store the data. To do so, you can either
select an existing file from the file list or type a new name for the
file in the Filename field.

4. Click on OK. Site Manager stores the data in ASCII format.

You can use any text editor to view the data once you store it on your
workstation.

Building Custom Statistics Screens

You can build custom statistics screens. You can select up to nine
different objects from the Wellfleet MIB and define how the screen
displays the statistics you select. After you save the custom statistics
screen, it is added to the Screen Manager’s user screen list.

Designing Statistics Screens

To design a custom statistics screen, proceed from the Statistics
Manager window as follows:
1. Select Tools>Screen Builder.

The Screen Builder Facility window appears (Figure 4-24).
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List of MIB Objects

Information about the selected MIB Objects

[®] Screen Builder Facility

Mib Objects W

utHardwareConf1e
wiSoftwareConfig
wiSysten

wiline
wEpplication

v

ObJect Information
Access:
Type:
Syntax:
["Read Description... |

Column Information and Setup

{Save Column| {Clear Column|  {Total..|

{Preview, ., |

Cornn:[L] 2] B ] 2 ] B B 171 BT [E]

: [+ ObJect: I E

Heading: r §

i e ——

Radix: # Decimal < Hex < fscii
i Save | i Load | | Help | \

Figure 4-24. Screen Builder Facility Window

\

Column attributes
for the object’s statistics

The MIB Browser on the left side of the screen lets you scroll
through the MIB and select MIB objects to add to the screen. (The
section “Using the MIB Browser” explains how to maneuver
through the MIB). The Column Information and Setup portion of
the screen lets you specify how the statistics for the selected objects
appear on the screen.

2. Specify the column you want to define in the screen design by
clicking on the corresponding column number button.
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For example, to define the first column on the statistics screen,
click on the “1” button.

Scroll through the MIB tree and select the MIB object that you
want to list in the column. The Object field in the Column
Information and Setup portion of the screen displays the MIB
object you select.

Select the Heading field and enter a name that describes the type of
statistics that the Statistics Manager will collect and display in
that column. For example, if you select the object
wfIPInterfaceAddr, you could name the column “IP Address.”

Specify the column Width. Click on the slidebar and move it back
and forth until the Screen Builder displays the appropriate column
width.

The width displays in character units. The width you specify here
must be greater than 0 and greater than or equal to the column
heading width. Any data that exceeds the specified column width
will cause the rest of the data on the same line to shift to the right.

As a rule of thumb, allow at least the following widths:

IP addresses 18 units (15 for the address, plus 3 spaces)
MAC addresses 16 units (14 for the address, plus 2 spaces)
Circuit Names/ 18 units

Numbers

Specify whether the Statistics Manager displays statistics in
decimal, hexadecimal, or ASCII format by clicking on the
corresponding button in the Radix field. (You may find the ASCII
radix useful for displaying NetBIOS Names.)

Click on Save Column to save the column attribute information.
The Screen Builder displays an asterisk in the column button for
the column you just saved.

Repeat steps 1 to 7 to add other objects to the statistics screen.
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9. To generate a sum of the values in two or more columns, follow

these steps:

a. Click on the number of the column in which you want to display

the sum.
b. Click on Total.

The Screen Builder Column Total window appears

(Figure 4-25).

[®] Screen Builder Column Total

L]

Select columns to total:

mialajsialalalals
Cold =

Figure 4-25. Screen Builder Column Total Window

c. Click on each column that will contain values that you want to

include in a total.

For example, suppose columns 1, 2, and 3 will contain
information about different kinds of dropped packets. You can
generate a total of all dropped packets by adding the values in

the three columns.

Figure 4-26 shows that column 4 will display the total of the

values in columns 1, 2, and 3.

[® Screen Builder Column Total

Select columns to total:

LIETE]EIElEI M BIE]

Col4 = Coll + Col2 + Col3

(e  [EE] Gt

Figure 4-26. Selecting Columns to Total
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d. Click on Save. You then return to the Screen Builder Facility
window.

e. Click on Save Column in the Screen Builder Facility window to
save the totals column you just specified.

10. To preview the statistics screen you are building, click on the
Preview button.

The statistics screen appears and displays the current column
design. Note, however, that the Statistics Manager does not
retrieve any statistics from the router.

11. Click on Save once you finish building the screen. The Statistics
Save/Load Screen window appears (Figure 4-27). It lists all the
custom statistics screen files that you save in the statistics screen
directory.

[®] Statistics Save/Load Screen 0 I F

Screen Information

Screen Name: l
Description:l,l

Orientation: 4 Circuit < Table

Directory:

i

EnetTrfc  CSMACD Traff
HssiTrfc HSSI Traffic

SMDS SMDS Main In
SymeTrfc SYNC Traffic
Bridee Learning Bri

traffic Line Traffic
ip_rte.dat IP Routing T

| Save | CHelp |

Figure 4-27. Statistics Save/Load Screen

12. Complete the Statistics Save/Load Screen as follows:
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a. Enter a new name for the file in the Screen Name field. If you
are saving the file to a PC, the name you enter must follow
standard DOS format.

b. Enter a description of the screen in the Description field. The
maximum length of the screen description is 40 characters.

c. Specify the screen mode by selecting either Circuit or Table.
Choose Circuit if you want the Statistics Manager to
continually update the screen with new statistics. Choose Table
if you want the Statistics Manager to gather and display
current statistics only once, when you launch the screen.

d. Click on Save to save the statistics screen to a file.

Depending on whether you are running Site Manager on a UNIX or
DOS computer, the Statistics Manager saves all custom screens to
one of the custom screen directories listed:

Platform Custom Screen Directory

UNIX $(HOME)/ .wfscrns
DOS \wf\wfscrns

Displaying Custom Statistics Screens

To view a statistics screen you created, complete the following steps:

1. Add the screen to the current screen list. See “Defining the Current
Screen List” for instructions.

2. Launch the screen. See “Displaying Statistics Screens” for
instructions.

You can also view the text version of the statistics screen file using any
text editor.
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Editing Custom Statistics Screens

You can load a statistics screen that you previously built and edit the
screen. This is a two-step procedure.

Note: The default screens are write-protected, so you cannot edit
them. To customize a default screen, simply use the operating
system to copy it to the custom screen directory on your Site
Manager workstation under a new name. Then load and edit it
as described in this section.

Retrieving a Statistics Screen File

Before you can edit a statistics screen file, you must load (retrieve) it
from your Site Manager workstation.

To retrieve a statistics screen file, begin at the Statistics Manager
screen and proceed as follows:

1. Select Tools>Screen Builder. The Screen Builder window appears.
2. Click on Load. The Statistics Save/Load Screen appears.

3. Highlight the statistics screen file you want to edit. Once you select
a statistics screen file, the Screen Information fields reflect the
screen name and type of data it collects.

4. Click on Load to load the screen’s column attributes into the Screen
Builder.

The Column Information and Setup portion of the Screen Builder
window now reflects the statistics screen you retrieved, beginning with
the first column defined.
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Editing a Statistics Screen File

After you retrieve the statistics screen, use the Screen Builder to edit
the screen.

To edit the screen columns, follow these steps:

1.

3.

Select the number box corresponding to the column you want to
edit.

When you select the column number, the Object, Heading, Width,
and Radix fields are filled in with the current column information.
If the column is currently undefined, these fields remain blank.

To remove all of the current column information, click on the Clear
Column button.

Select and edit any of the column attributes you want to change as
follows:

— If you want the column to contain statistics about a different
object, highlight a new object from the MIB Browser.

— To change the column size, use the slidebar to increase or
decrease the current size.

— To change the column heading, type a new heading.

— To display the integer in a different format, change the Radix
setting.

The section “Designing Statistics Screens” describes how to set
each of the column’s attributes.

Click on Save Column to implement your changes.

4. Repeat this procedure to edit additional columns.

Note: To display the statistics screen and see the results of your edits,

click on Preview.
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5. Click on Save to save your changes to the screen. The Statistics
Save/Load Screen appears. You can either save this modified
window to an existing file or save it under a new name as follows:

— To save the screen to an existing file, select the file from the list
by highlighting it. Then click on Save. Click on OK to allow the
Statistics Manager to overwrite the file.

— To save the screen under a new name, enter the name of the file
in the Screen Name field. Describe the file in the Description
field, and specify whether the screen mode is Circuit or Table.
Then click on Save.

If you save the statistics window under a new name, you must do the
following to view this screen:

1. Add the window to the current screen list. See “Defining the
Current Screen List” for instructions.

2. Launch the screen. See “Displaying Statistics Screens” for
instructions.

For More Information

For information about MIB standards, see the following references:

Structure and Identification of Management Information for
TCP/IP-based Internets (SMI; RFC 1155).

Information Processing Systems - Open Systems Interconnection
Specification of Abstract Syntax Notation One (ISO 8824).
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Chapter 5
Using the Router Files Manager

For general information about using the Router Files Manager, see
“Managing Router Files” in Chapter 1. For specific information about
using buttons, windows, and other Site Manager features, refer to
Using Site Manager Software.

Use the Router Files Manager to do the following:

g O o o O o o a o o Q

Display the contents of a router’s volume

Connect to a router

Name files

Copy files

Delete files

Transfer files

Back up files

Modify a config file in remote configuration mode
Compact file space on a memory card or flash SIMM
Format a memory card or flash SIMM

Partition media on Wellfleet routers
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Displaying the Contents of a Volume

Active

To display files stored on a volume inside the router, begin at the
Wellfleet Site Manager window and select Tools->Router Files
Manager. The Router Files Manager window appears, showing the files

in the active volume (Figure 5-1).

[®] Router Files Manager

File Options Commands

System Name: 192,32, 14,59

Volume ——® Volume:

Files
in Active
Volume

- SIS T
T | e 18 Jul
CONFIG 2108 Jul
AT, BAT 47864 Jul
AT, 4L 4011 Jul
AURP, BAT 19945 Jul
ACE. OUT 1206491 dug
MOD_0037. CFG 1724 Aug
T1_STRID. CFG 2108 Jul
MOD_0041, CF& 52 Aug
SETFAULT, BAT 506 fug
— - |SETFAILT 0 dug

1994
1994
1994
1994
1994
1994
1994
1994
1994
1994
1994

Total size: 1474560
Available free space: 166400
Contiguous free space: 166400

Figure 5-1. Router Files Manager Window
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Active Volumes

In the Router Files Manager window, the active volume is represented
by a number or letter, depending on the type of media the router uses.

. Active -

Media Volume Description

Memory Card or 1through | If the router uses a memory card or

Memory Module 14* a memory module, the active vol-
ume can be from 1 through 14,
depending on the router platform.

Diskette A If the router uses a diskette, the
active volume shown is A.

*This number comes from the number of the slot hosting the first available memory card.
Additional memory cards in the router are optional; they provide redundancy and additional
storage.

In addition, if the router is an Access Node (AN) or Access Stack Node
(ASN), and the media is partitioned, the active volume is represented
by a number (for the slot) and a letter (for the volume). For example, 1a
refers to volume a (the primary volume) on slot 1, and 1b refers to
volume b (the secondary volume) on the same media in slot 1. For more
information, see “Partitioning Media on Wellfleet Routers” later in this
chapter.

To change the volume displayed, select the Volume box. The Volume
box lists all available volumes on the router, as shown below. Select the
volume you want.

L

Yolume:

1)
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Available and Contiguous Free Space

The fields at the bottom of the Router Files Manager window show the
amount of free space in a selected volume. The fields are as follows:

Total size Total number of bytes (used and unused) on
the volume

Available free | Number of unused bytes on the volume
space

Contiguous Number of unused bytes in the largest block
free space available on the volume

Default Filenames

Table 5-1 lists the default router filenames.
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Table 5-1.  Default Router Filenames
Filename Description Notes
ace.out Bootable image The system automatically refer-
for the FN, LN, ences this binary file for booting
ALN, AFN with instructions, unless you specify
diskette, and CN another bootable image. You cannot
: read or change this file. It must
afn.exe Bootable image have the correct filename for the
for the AFN with | soctem to boot successfully after a
flash file system cold-start. The Administra-
an.exe Bootable image tion>Boot Router option does, how-
for the AN ever, let you specify another
software image.
asn.exe Bootable image
for the ASN
bn.exe Bootable image
for the BLN, BCN,
and BNX
asndiag.exe Copy of the diag- You cannot read or change this file.

nostics image for
the ASN

continued on the next page
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Table 5-1.  Default Router Filenames (continued)

Filename

Description

Notes

config

Default configura-
tion file

The system references this binary
file for configuration data when
booting. (However, you can specify
another configuration file with the
Boot Router option.) You can change
the configuration by copying an
alternate configuration file to config.
Also, you can store alternate or
future configurations. This file must
have the config filename for the sys-
tem to configure automatically after
booting. We recommend that you
back up the config file before over-
writing it.

debug.al

ASCII file contain-
ing aliases

Aliases are commands that abbrevi-
ate long or multiple commands.
They are used to debug common net-
work problems.

frediag.exe

Copy of the diag-
nostics image resi-
dent on the
diagnostics PROM
for the BCN and
BLN

You cannot read or change this file.

freboot.exe

Copy of the boot-
strap image resi-
dent on the
bootstrap PROM
for the BCN and
BLN

You cannot read or change this file.

continued on the next page

5-6




Using the Router Files Manager

Table 5-1.

Default Router Filenames (continued)

Filename Description

Notes

install.bat Script containing

TT commands

You use the Wellfleet Technician
Interface commands during the ini-
tial startup.

Configuration file
containing the
MIB variables
associated with
the default TT con-
sole operating
parameters

ti.cfg

This file contains the minimal con-
figuration necessary to operate the
router. You boot with this file when
updating a PROM. You may also
want to boot with this file when
copying a volume to provide full use
of all system buffers. This file is
stored in binary format.

Connecting to a Router

To connect to a router using the Router Files Manager

1. Select Options>Router Connection from the Router Files Manager

window.

The Router Connection Options window appears (Figure 5-2).

[®] Router Commection Options

Node Name/IP Address

Tdentity (Community)

a2, 32, 156, 68

Timeout (seconds) $m
Retries (per request) h

Figure 5-2. Router Connection Options Window
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2. Enter an IP address in the Node Name/IP Address field, then click
on OK.

The Router Files Manager connects you to the specified router. The
IP address of that router appears in the Router Files Manager
window.

Naming a File

Before you go on to the next section, you need to know the rules for
naming files.

o  Filenames must start with an alphabetical character. The
remaining characters must be alphanumeric and may also include
the underscore (_) character.

a Filenames can consist of 1 to 8 characters. Note that configuration
filenames can consist of 1 to 15 characters (including a period).
However, we recommend that you limit filenames to 8 characters to
ensure that all operating systems that we support can recognize
the names.

7 Filename extensions are optional and must be preceded by a
filename and a dot. They can be from 1 to 3 characters.

Also, we recommend that you use the following conventions when you
name files so that you can distinguish files by type.

0 Use the .exe filename extension for software images for FRE
processor modules and “.out” for ACE processor modules. (See
Table 5-1, earlier.)

a  Use the .cfg filename extension for alternate configuration files.
(The default configuration file is config.)

A  Use the .al filename extension for alias files.

a0 Use the .log filename extension for log files.
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Copying a File

You can use the Router Files Manager to copy a file on the router; you
can copy the file to a different volume or to the same volume. To copy a
file, you do the following:

1. Examine the existing filenames.

2. Verify the existence of adequate free space on the destination
volume.

3. Create the copy.

The following sections describe each of these steps.

Examining the Router Destination Volume

The router automatically overwrites any file that has the same
filename as the file you are creating.

To avoid overwriting an existing file, display a list of the volume’s
contents and determine the filenames that are already in use. For
information on how to do this, see “Displaying the Contents of a
Volume” earlier in this chapter.

If you are unfamiliar with the file-naming rules and conventions, refer
to the earlier section “Naming a File” before you proceed.

Verifying Adequate Free Space

You must make sure that the router volume has enough space
available for the copy. Depending on the Router Software Version you
are using, your software might automatically check the available space
for you.

To determine your Router Software Version, select
Help—>Site Manager Version in the Router Files Manager window.
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Routers that run 7.80 (or later) software automatically verify the
existence of adequate free space on the destination volume specified in
a file copy operation.

For routers that use a software version lower than 7.80, you must

0 Determine from the Router Files Manager window the size of the
file you want to copy.

a Determine from the Router Files Manager window the amount of
free space available to receive the file copy on the destination
volume.

— For a router diskette destination volume, use the number of
bytes displayed for Available free space.

— For a router memory card or flash SIMM (Single Inline Memory
Module) destination volume, use the number of bytes displayed
for contiguous free space.

Warning If the destination volume has an insufficient amount of
available free space (or contiguous free space, in the case of

a memory card or flash SIMM volume), the router copies
only part of your source file.

Creating the Copy

Copy a file as follows:
1. In the Router Files Manager window, select the file you want to
copy.

If you select a file that you decide not to copy, click on the file again
to deselect it.

2. Select Commands=>Copy. The Router Files Manager displays the
source filename in a window (Figure 5-3).
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(@]
Copy File
Source Filename: ] @:ACE, OUT §

Figure 5-3. Copy File Window for Source Filename

3. Click on OK.

A window prompts you for the destination filename (Figure 5-4).

[®]
Copy File

Destination Filename: ! 8:ACE, OUT g

Figure 5-4. Copy File Window for Destination Filename

4. Using the following format, overtype the entry in the Destination
Filename field with the volume and filename you want to give this
file.

<volume>:<filename>

Note: Ifyou are copying a file from diskette to memory card, enter the
destination filename in lowercase letters only.

5. Click on OK. A confirmation window appears.
6. Click on OK.

The router copies the source file to the filename and volume you
specified.
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Warning Copying a file to a memory card “volume” that has an
insufficient amount of contiguous free space results in a

corrupted copy of the original source file. You must delete
the corrupted file.

Before you again attempt to copy the same or any other
source file(s) to the same volume, you must compact the
volume. See “Compacting File Space on a Memory Card or
Flash SIMM?” later in this chapter.

Deleting a File

You can delete one or more files at a time from a volume.

t '
Warning You cannot recover a file after it is deleted.

To delete one or more files, follow these steps:

1. In the Router Files Manager window, select each file that you want
to delete.

To select multiple files, just click on each file you want.

If you select a file that you decide not to delete, click on the file
again to deselect it.

2. Select Commands=>Delete.

A window prompts you to confirm your delete request
(Figure 5-5).
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(@ 2]
Proceed with DELETION of File(s):

N1, CFG
CONFIG. DZ

Figure 5-5. Deleting Router Files
3. Click on Yes.

The router deletes the files you specified from the volume displayed.

Transferring a File

The Router Files Manager allows you to transfer files between any
router and Site Manager workstation by selecting File>TFTP

(Figure 5-6).
[®] Router Files Manager §
File |Options Commands Help
) 2. 32, 156, 68
TFTP piGet File(s).., PF3
Exit PF10 Put File(s),.. PF4
CONFIG 1664 Jun 21, 1997 23:60
CN1, CFG 1428 May 23, 1994 12:37
CONETG, 7 o 0l 13

Figure 5-6. Selecting the TFTP Option
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This option invokes the TFTP (Trivial File Transfer Protocol) software
to execute file transfers.

Note: To transfer files to or from a router that uses a diskette-based
file system, you must set the TFTP Retry Time Out parameter
to 10 seconds. If you do not make this adjustment, duplicate
transfer sessions may occur. This, in turn, may result in zero
length or locked files on the diskette. (For more information on
how to set the TFTP Retry Time Out parameter, refer to
Customizing IP Services.)

You can choose TFTP->Put File(s) to transfer one or more files to
several routers at the same time. For example, you might want to
transfer a new boot.exe file to three different routers. Rather than
performing the transfer three times (once for each router), you can
transfer the file to all three routers at once.

To transfer files to multiple routers simultaneously, you must use the
Router Files Manager to set up those routers. The next section
describes how to do this.

If you want to transfer files to only one router, the Router Files
Manager uses the Node Name/IP Address that you specified in the
Router Connection Options window to determine the router to which
you put files. For more information, see the section “Putting a File,”
later in this chapter.

You can choose TFTP->Get File(s) to get one or more files from a router.
Unlike the Put File(s) option, which lets you transfer files to several
routers at the same time, you can get files from only one router at a
time. Again, the Router Files Manager uses the Node Name/IP Address
from the Router Connection Options window to determine the router
from which you get files. For more information, see the section
“Getting a File” later in this chapter.

Note: We recommend that you ping the router before you transfer a
file, if you are running IP in host-only mode and you have
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configured the router with the same IP address on multiple
physical interfaces.

Setting Up Multiple Routers

To set up several routers so that you can put the same files on those

routers at one time, follow these steps:

1. Select Options>Router Connection and complete the Router
Connection Options window for each router to which you want to
transfer the files.

2. Select Options=> Multiple Router Setup. The Multiple Router Setup
window appears (Figure 5-7).

[@ Multiple Router Setup
Default Routers Current Routers
192, 168, 130, 164 4]
192,32, 14,59
Add )}

Volume

1:

1b:

2:

2b:

3: "

b » b

Figure 5-7. Multiple Router Setup Window

The Default Routers window lists the routers to which you are
currently connected. The Current Routers window lists the routers
whose files you want to manage simultaneously. The Volume
window lists all of the volume identifiers for Wellfleet routers.
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3. To transfer files to the same volume(s) on several different routers,
follow these steps:

a. In the Default Routers list, click on each router to which you
want to transfer the same files at the same time.

b. In the Volume list, click on each volume where you want to put
files.

c. Click on Add.

The selected routers and volumes appear in the Current
Routers list (Figure 5-8).

[@ Multiple Router Setup
Default Routers Current Routers
192, 168, 130, 164 B 192, 168, 130, 164, 1:, 2
192,32, 14,59 192,32,14,59, 1:, 2:
add )

Yolume }}

e

Figure 5-8. Adding Routers to the Current Routers List

Using the multiple router setup in Figure 5-8, you can transfer the
same files to volumes 1 and 2 on the routers in the Current Routers
list.
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To transfer files to different volume(s) on several different routers,
follow these steps:

a. In the Default Routers list, click on the router to which you
want to transfer files.

b. In the Volume list, click on the volume(s) where you want to put
files on the router you just selected.

c. Click on Add.

d. Repeat Steps a through c for each router to which you want to
transfer the same files.

The selected routers and volumes appear in the Current
Routers list (Figure 5-9).

[® Multiple Router Sstup
Default Routers Current Routers
192, 168, 130, 164 4] 192, 168,130, 164, 1:
192,32, 14,59 ‘ 192,32,14,59, 2:

Add })
Volume }}
1:
1b:

2:
2b:
3:

Figure 5-9. Adding Routers to the Current Routers List

Using the multiple router setup in Figure 5-9, you can transfer the
same files to volume 1 on the first router in the Current Routers
list, and to volume 2 on the second router in the list.

5-17



Transferring a File

If you inadvertently add a router and volume to the Current
Routers list, you can remove it from that list. To do so, select the
router (in the Current Routers list) and click on Remove.

4. Click on Save.

You can now proceed to “Putting a File” for information on putting files
on the routers.

Getting a File

The Get File option allows you to transfer one or more files from the
router to the Site Manager workstation.

To transfer files from the router to the Site Manager workstation,
begin at the Router Files Manager window and proceed as follows:

1. Select the Options=>Router Connection option from the Router File
Manager window.

2. Enter the IP address of the router that has the files you want to
transfer, then click on OK.

3. Select the router volume from which you need to transfer a file. The
Router Files Manager lists the files on that volume.

4. Select the files you want to transfer from the router to the Site
Manager workstation.

5. Select File®TFTP->Get File(s).
The TFTP Get Files window appears (Figure 5-10).
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[@] TFTP Get Files

Proceed with TFIP Get of file(s) ?
4CE, OUT 41

| < —

Destination Directory:

| Bextra/sngr i
Yes

Figure 5-10. TFTP Get File Window

In this example, you are transferring one file from the router to the
Site Manager workstation.

6. In the Destination Directory field, enter the name of the directory
on your Site Manager workstation where you want to store the file.

7. Click on Yes to proceed.

The Router Files Manager transfers the files to the Site Manager
workstation.

If a file with the same name already exists in the destination
directory on the Site Manager workstation, the file you are
“getting” replaces it.

Putting a File

The Put File option lets you transfer files from the Site Manager
workstation to one or more routers. To transfer a file from the Site
Manager workstation to a router, you must do the following:

1. Choose the router(s) to which you want to transfer the files.
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2. Examine the existing filenames on the router destination volume.

3. Verify the existence of adequate free space on the destination
volume.

4. Transfer the files to the destination volume.

The following sections describe each of these steps.

Choosing the Routers

To transfer files to more than one router at a time, follow the
instructions in the earlier section, “Setting Up Multiple Routers,” to
select the routers you want.

To transfer files to only one router, follow these steps from the Router
Files Manager window:

1. Select the Options=>Router Connection option from the Router File
Manager window.

2. Enter the IP address of the router to which you want to transfer
files, then click on OK.

Note: We recommend that you ping the router before you attempt to
transfer a file if

ad You are running IP in host-only mode on the destination
router

a  You have configured the destination router with the same IP
address on multiple physical interfaces
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Examining the Router Destination Volume

The router automatically overwrites any file that has the same
filename as the file you are transferring from your Site Manager
workstation.

To avoid overwriting an existing file on the router destination volume,
display a list of the volume’s contents and determine the filenames
that are already in use. For information on how to do this, see
“Displaying the Contents of a Volume” earlier in this chapter.

If you are unfamiliar with the file-naming rules and conventions, refer
to the earlier section, “Naming a File,” before you proceed.

Verifying Adequate Free Space on the Destination Volume

You must make sure that the router destination volume has enough
space available for the files you transfer. Depending on the Router
Software Version you are using, your software might automatically
check the available space for you.

To determine your Router Software Version, select Help in the Router
Files Manager window.

Routers that run 7.80 (or later) software automatically verify the
existence of adequate free space on the destination volume specified in
a TFTP Put operation.

For routers that use a software version lower than 7.80, you must

0 Determine from the Router File Manager window the size of the file
you want to transfer to the router via TFTP.

a0 Determine from the Router File Manager window the amount of
free space available to receive file copy on the destination volume.

— For a router diskette destination volume, use the number of
bytes displayed for Available free space.

— For a router memory card or flash SIMM destination volume,
use the number of bytes displayed for Contiguous free space.
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Caution:  The destination volume may reside on a router that is
running a version of the Series 7 software older than 7.80
(for example, 7.60). In this case, if the destination volume
does not have enough free space (or contiguous free space,
for a memory card volume), the router accepts only a partial
(corrupted) copy of your source file.

If you inadvertently transfer a file to a memory card volume
that cannot accommodate your entire source file, delete the
corrupted file copy from the destination volume. (See
“Deleting a File” earlier in this chapter.) Before you transfer
the same or any other source file(s) to the same volume,
compact the contents of that volume. (See “Compacting File
Space on a Memory Card or Flash SIMM” later in this
chapter.)

Transferring Files to the Destination Volume
To transfer files from the Site Manager workstation to one or more
routers, follow these steps from the Router Files Manager window:

1. Select FileTFTP->Put File(s). The TFTP Put File Selection
window appears (Figure 5-11).
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[®] TFTP Put File Selection 2]

Path: I Bextra/smer

Files: Files To Put:

- cshrc [ hdd 3y
- Jogin

. ¥initre

. wastebasket

. Kdefaults

. Openwin-sm

. Rauthority

. desksetdefaults
. openwin-init

. Openwin-menu
.wicfginit v

Multiple Routers:

Figure 5-11. TFTP Put File Selection Window

2. In the Path box, enter the pathname of the directory on the Site
Manager workstation that contains the files you want to transfer.

The files in that directory appear in the Files window.

3. In the Files window, click on each file that you want to transfer to
the router. Then click on Add. The selected files appear in the Files
to Put window.

If you inadvertently add files that you do not want to transfer to the
router, select those files in the Files to Put window. Then click on
Remove.

4. Repeat steps 2 and 3 to select files from other directories that you
want to transfer to the router.
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5. If you select multiple routers (see “Choosing the Routers” earlier),

and you want to transfer the files to all of the routers you selected,
click on Yes in the Multiple Routers field.

If you select only one router, or if you do not want to transfer the
files to all of the routers you set up in the Multiple Router Setup
window, click on No in the Multiple Routers field. In this case, if
you previously set up multiple routers, the Router Files Manager
transfers the selected files only to the router to which you are
currently connected.

Click on OK.

During the file transfer operation, the Router Files Manager
displays the address of the router that is receiving the files. When
the transfer (to each of the routers) is complete, the TFTP Put File
Selection window closes and you return to the Router Files
Manager window.

Backing Up Router Software Files to a Host Computer

We recommend that you use TFTP to back up the contents of each
memory card or flash SIMM to a host computer on your network. After
you back up all files, you can remove the files freboot.exe and
frediag.exe. These files are not required on the router’s memory card,
flash SIMM, or diskette and are distributed only as backups for the
EEPROM:s.

Modifying config Files in Remote Configuration Mode

Use this procedure when you use the Configuration Manager remote
mode to modify a config file.

1. Compact the contents of the memory card or flash SIMM if your

router is equipped with one. (See the next section, “Compacting
File Space on a Memory Card or Flash SIMM.”)

Copy the config file to a new file named temp. (See “Copying a File”
earlier in this chapter.)
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3. Modify temp, using the Configuration Manager remote mode.
(Refer to the appropriate Bay Networks manual for customizing
the type of router software you use.)

4. Save temp. When you save in remote mode, Site Manager
automatically copies the file to the router.

5. To test your modifications, boot the router with the file temp. (Refer
to “Booting a Router” in Chapter 7.)

6. Check the MIB version in the Site Manager main window. If the
version is lower than 7.80, verify that

0 Adequate free space exists on the router’s diskette to copy temp
to another file

7 Adequate contiguous free space exists on the router’s memory
card or flash SIMM to copy temp to another file

Note: Routers that run 7.80 (or later) software automatically verify
the existence of adequate free space on the destination volume
specified in a file copy operation.

7. Copy the file temp to config.
8. Boot the router with config.
9. Delete temp.
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Compacting File Space on a Memory Card or Flash SIMM

Note: References to memory cards in this section also apply to flash
SIMMs (Single Inline Memory Modules).

When you delete a file on a memory card, the file becomes inaccessible,
but the data remains on the memory card.

Eventually all space is used. The Compact option copies the active files
from the memory card to the router’s memory, erases the memory card,
and copies the files back to the memory card.

This procedure gives you more file space, provided that you have more
available free space than contiguous free space (For more information,

refer to “Available and Contiguous Free Space” earlier in this chapter).

Caution: We recommend that you back up the files by copying them to
a second memory card before you use the Compact option.

To compact the files on a memory card, begin at the Router Files
Manager window and proceed as follows:

1. Select the volume that contains the memory card you want to
format.

2. Select Commands->Compact.

A confirmation window appears.
3. Click on OK.

While the operation is in progress, a display of the percentage of the
operation that has been completed appears next the Volume field in
the Router Files Manager window. The router is unavailable for any
other file system requests until it completes the compact procedure.

Note: Upon completion of the compacting operation, the Router Files
Manager automatically displays the list of files stored in the
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memory card. If you issue a file system request before the
router finishes compacting all files on the designated volume,
the message Last command failed appears. (The router did not
successfully complete the command.)

e
Warning During the compacting operation, if the slot that contains
the memory card resets, runs diagnostics, or loses power,

the memory card loses all its data and can become
corrupted.

Formatting a Memory Card or Flash SIMM

Note: References to memory cards in this section also apply to flash
SIMMs (Single Inline Memory Modules).

The Format option allows you to format and initialize a memory card.
Use the Format option to format new memory cards, if you did not
obtain them from Bay Networks.

Warning You cannot recover files from a memory card after you use

the Format option. We recommend that you copy them to a
second memory card before you use the Format option.

To format a volume, begin at the Router Files Manager window and
proceed as follows:
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1. Select the volume that contains the memory card you want to
format.

2. Select Commands->Format.
A confirmation window appears.
3. Click on OK. The router formats and initializes the memory card.

4. Display a list of the volume’s contents when the format operation is
done.

The format process is complete, if the Router Files Manager does not
display a list of files.

Partitioning Media on Wellfleet Routers

Site Manager lets you partition the nonvolatile file system (NVFS) on
Wellfleet Access Nodes (ANs) or Access Stack Nodes (ASNs). These
routers use a single flash file system; that is, the routers have only one
medium where the file system resides. The NVFS for the AN resides on
a Single Inline Memory Module (SIMM). The ASN uses a flash memory
card. (You can stack ASNs and use more than one flash memory card in
the stack to achieve file system redundancy. In this case, partitioning
would not be necessary.) If the single flash file system fails, the router
has no backup file system from which to boot.

Partitioning the file system divides it into two independent volumes of
equal size. You can store default boot images and configuration files on
each volume for redundancy. Then, if you are unable to boot the router
from the primary file system, Site Manager automatically attempts to
boot the router from the secondary (or backup) file system.

For example, suppose the NVFS for your Access Node resides on a 4-
MB SIMM. Partitioning the file system creates two 2-MB volumes. The
volumes function independently, and you reference them with unique
slot and volume identifiers. You could then copy the files from the
primary volume to the secondary volume.

Note: You can partition file systems on 4-MB media only.
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Creating a Partition
To partition the NVFS on an AN or ASN, follow these steps:

1. In the Router Files Manager window, select the volume you want to
partition. Make sure the value for Contiguous free space is no
more than half of the volume’s total size.

To create volumes of equal size, the existing file system cannot be
more than half of the total media size. If the file system is too large,
you might want do one or more of the following so that you will be
able to create a partition:

0 Format the media, as described in the previous section

a Delete some files, as described in “Deleting a File” earlier in
this chapter

7 Compact the files, as described in “Compacting File Space on a
Memory Card or Flash SIMM” earlier in this chapter

2. If you want to partition the file system on an ASN, make sure that
the flash memory card is not write-protected. (By default, we ship
memory cards unprotected.)

See Installing and Maintaining ASN Routers for information on
setting the Read/Write switch on the flash memory card.
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3. Select Commands=>Create Partition

A window appears prompting you to confirm your decision to
partition the media (Figure 5-12).

(@ Site Manager

@ Proceed with "create partition 1:” 2

|Cancel

Figure 5-12. Create Partition Confirmation Window

4. Click on OK in the confirmation window.

Site Manager displays the following message beside the volume box
in the Router Files Manager window:

CREATING media partition. Please wait...

When the process is complete, the following message appears:

Media partition created. Issuing DIRECTORY command.

The partitions function as independent flash media. Site Manager uses
the following format to identify the partitions:

<slot><volume>:

where slot refers to the number of the processor board that contains
the partitioned media, and volume is a for the primary volume and b
for the secondary volume.

In the AN, the slot is always 1. In an ASN, the slot can be from 1 to 4,
depending on the setting of the Slot ID selector. (See Installing and
Maintaining ASN Routers for information on setting the slot ID.) For
example, suppose you partition an AN’s file system. Site Manager
refers to the primary volume as 1a and the secondary as 1b (Figure
5-13).
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[® Router Files Manager i
File Options Commands

System Name: 192,32, 37,42

Yolume:

anboot, exe 01, 1994 0z 01
andiag, exe 201862 Jan 01, 1994 00:02
log, fault 19416 Jan 01, 1994 00:06
config 2552 Jan 01, 1994 00:11

Total size: 2097152
Available free space: 916708
Contiguous free space: 914278

Figure 5-13. Volume Identifiers for Partitioned Media

To manage the files on a partitioned volume, you can use any of the
commands that you would normally use to manage the files on an
unpartitioned volume. For example, you can compact the files on one

volume without affecting the files on the other.

You can use Command->Copy to copy the router

files to the new

volume. See “Copying a File” earlier in this chapter.

Note: In partitioning the volume, the router creates a special
partition file in the secondary volume. (You will not see the file
in the secondary volume’s list of files.) The partition file takes
up 98 bytes of space in the secondary volume only.
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Deleting a Partition

If you partitioned the NVFS on your AN or ASN, you can remove the
partition to revert to a single flash file system. You might want to do
this, for example, if the router software image is larger than half of the
total media size.

t '
Warning Deleting a partition deletes all files from the secondary
volume. Files on the primary volume remain intact, and the

primary volume then represents the entire size of the
medium.

To delete a partition, follow these steps:

1. In the Router Files Manager, click on the volume box and switch to
the primary volume.

2. Select Commands=>Delete Partition.

A window appears prompting you to confirm your decision to delete
the partition (5-14).

[® Site Manager

@ Proceed with “delete partition la:” ?

§ 0K | Cancel

Figure 5-14. Delete Partition Confirmation Window

3. Click on OK in the confirmation window.
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Site Manager displays the following message beside the volume box
in the Router Files Manager window:

DELETING media partition. Please wait...
When the process is complete, the following message appears:

Media partition deleted. Issuing DIRECTORY command.
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Chapter 6
Using the Report Generator and Audit Trail
Feature

For general information about tracking router configuration file
changes, see “Monitoring Changes to Router Configuration Files” in
Chapter 1. For specific information about using buttons, windows, and
other Site Manager features, refer to Using Site Manager Software.

You can monitor changes to router configuration files by doing the
following:

o Generating configuration file reports

0 Maintaining an audit trail log
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Generating Configuration File Reports

You can generate reports from a router’s configuration file from the
following:

a0 Site Manager
a The UNIX command line

0 Windows on a PC

The following sections describe each method.

Generating Reports from Site Manager

To generate a configuration file report from Site Manager, select
Tools=>Report Generator from the Site Manager main window. The
Configuration Report Generator window appears. Figure 6-1 shows a
sample window.

[® Configuration Report Generator
Qutput Format Options Configuration File
M Show Defaults |
B Tag Defaults Select File |
M Show MIB Names Report File
M Show Raw Data (hex) I
M Use Report Template L Select File |
M Warn on Unrecognized Report Template File
M Warn on No Default |

L Select |

j Generate Report | { Cancel |

Figure 6-1. Configuration Report Generator Window
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To complete the Configuration Report Generator Window, follow these
steps:

1. Select the Output Format Options that you want to use in the
report. To select an option, simply click in its box. Table 6-1
describes each option.

Table 6-1.  Output Format Options

Option Description

Show Defaults Includes the MIB default value for any configurable
attribute for which you did not specify a value in the
configuration file.

Tag Defaults Includes the label “[default]” beside any attribute
that uses the MIB default value.

If you click on Tag Defaults while Show Defaults is
not selected, Site Manager automatically selects
Show Defaults as well.

Show MIB Names Includes MIB attribute identifier names in addition
to the ASCII translation of those names.

Show Raw Data Includes the raw hex configuration data along with
(hex) the ASCII translation of that data.

You might want to show the raw data if you intend
to use the Technician Interface to enter configura-
tion data. In the Technician Interface, you must
enter the data in raw format.

continued on the next page
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Table 6-1.  Output Format Options (continued)

Option Description
Use Report Tem- Indicates that you want to use a report template
plate other than the default. The default is a version-spe-

cific template based on the version of the configura-
tion file. For example, the report generator uses a
7.80 template file to generate a report of a 7.80 con-
figuration file. You might want to use a different
report template, for example, a 7.60 template, to
generate a report of a 7.80 configuration file.

If you select this option, the Report Template File
field appears in the window (as Figure 6-1 shows).
You must enter a filename in the Report Template
File field, as described later.

Warn on Unrecog- Includes the warning “Unrecognized Attribute” for
nized any attribute that is in the configuration file but is
not present in the MIB.

Warn on No default | Includes the warning “NO VALUE, NO DEFAULT”
for any attribute for which you did not specify a
value in the configuration file and that does not
have a MIB default value.

2. Click on the Select File button beneath the Configuration File field.
The Select Configuration File Window appears (Figure 6-2).
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[®] Select Configuration File
Filter
|/ extra/smgr/* §
Directories Files
L] . Jauthority
. , Kdefaults
. builder dir . Xdefaults, open
. cetables .bin
.eln . cshre
. mosaic-personal-annotations . cshre, fmsave
. wastebasket . desksetdefaults
.wfscrns . login
ET =
Selection
|/ extra/smgr/ §
Cancel

Figure 6-2. Select Configuration File Window

Complete the Select Configuration File window as follows:

a. In the Directories window, select the directory path that
contains the configuration file from which you want to generate
a report.

b. In the Files window, select the configuration file.
The path and filename appear in the Selection window.
c. Click on OK.
You return to the Configuration Report Generator window.
3. Click on the Select File button beneath the Report File field.

Note: You can skip this step if you want the Report Generator to send
the output to <stdout>.
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The Save Report File As window appears (Figure 6-3).

[®] Save Report File As §
Filter
I,/ extra/smgr/* 2
Directories Files
A |, fauthority
. . Adefaults
, builder_dir . Xdefaults, open
,cetables .bin
Lelm . cshre
, mosaic-personal-annotations . cshre, fisave
. wastebasket . desksetdefaults
.wiscrns . login
A = K
Selection
|/extra/smg‘r/
| OK | Cancel

Figure 6-3. Save Report File As Window

Complete the Save Report File As window as follows:

a. In the Directories window, select the directory path where you
want to store the configuration file report.

The path appears in the Selection window.

b. Enter a filename for the report after the path in the Selection
window.

c. Click on OK.
You return to the Configuration Report Generator window.

4. If you select Use Report Template in the list of Output Format
Options, the Report Template File field appears in the
Configuration Report Generator window. Click on the Select button
beneath the Report Template File field.
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The Report Template File window appears (Figure 6-4).

[@] Use report Template File 2]
Filter

|/extra/smgr/* ;
Directories ‘ Files
T - (. fauthority

o | | Adefaults

. builder_dir by | Adefaults, open

. cetables |, bin

.eln |, cshre

. mosaic-personal-annotations ; & |, cshre, fusave

. wastebasket |, deskeetdefaults

. wfscrns 9 | login

- 4

Selection

|/extra/smgr/ g

Cancel

Figure 6-4. Report Template File Window

Complete the Report Template File window as follows:

a. In the Directories window, select the directory path that
contains the template file you want to use.

b. In the Files window, select the template file you want.

On UNIX workstations, template files are in /usr/wf/lib. On
PCs, the template files are in c¢:\wf\lib. The format of the

template filename is

<version>.rpt

For example, the template file for the version 7.80 configuration

file is 7_80.rpt.

The path and filename appear in the Selection window.

6-7



Generating Configuration File Reports

c. Click on OK.
You return to the Configuration Report Generator window.

5. Click on Generate Report.

Site Manager generates the configuration file report and saves the
report under the filename you selected. You can then open the report in
a text editor.

Figure 6-5 shows part of a report.
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[®] Console

Report produced by smcfgrpt Version {2, 00}

date:; Wed dug 3 10:25:46 1994
configuration file: 8 00_c
Router Software/MIB Ver51on {8, 00>

Hardware Configuration Group (wfHwBase)
Backplane Id (wfHwBpIdOpt) = Backbone Link Node (BLN) (0x00004100)
wilwEntry Table

wilwEntry Entry
wiHwS1lot (10} = 4 (OXOOOOOOO )
Module Type (witwtodIdOpt) = DSDEL (0x00000070)

witwEntry Entry
wiHwS1ot {10y = 5 (0x00000005)
Module Type (wfHwModIdOpt) = SYNCI1 (0x00000010)

wiProtocols Group

wfIPROTOLoad = 3087007744 (UXbSOOOOOO)
wiDECNETLoad = NO VAUE, NO DEF
wfATLoad = NO VAUE, NO DEFAULT
wERNSLoad = NO VAUE, NO DEFAULT
wEIPXLoad = NO VAUE, NO DEFAULT
wf0SILoad = NO VAUE, NO DEFAULT
wiX25DTELoad = NO VAUE, NO DEFAULT
wiX25DCELoad = NO VAUE, NO DEFAULT
wiVINESLoad = NO VAUE, NO DEFAULT
wiFRLoad = NO VAUE, NO DEFAULT
WERARPLoad = NO VAUE, NO DEFAULT
wiATMLoad = 402653184 (0x18000000)
wiDLSLoad = NO VAUE, NO DEFAULT
willMLoad = NO VAUE, NO DEFAULT
wfTelnetLoad = NO VAUE, NO DEFAULT
wiTFTPLoad = 3087007744 EOXbSOOOOOO%
wiBNPLoad = 3087007744 (0zb8000000
wiTCPLoad = NO VAUE, NO DEFAULT
waGPLoad NO UAUE NO DEFAULT
wiEGPLoa
waSPFLoad = 2684354560 (OanOOOOOO)
wiWPROXYLoad = 402653184 (OXISOOOOOU)
wiLLC2Load = NO VAUE, NO DEFAUL
wiSMDSLoad = NO VAUE, NO DEFAULT
wiPPPLoad = NO VAUE, NO DEFAULT
wfPktCaptureload = fio VAUE, NO DEFAULT
wiFRSHCNGCLoad = NO VAUE, NO DEFAULT
] waWPROXYLoad NO VAUE, NO DEFAULT

Figure 6-5. Sample Configuration File Report
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Generating Configuration File Reports from UNIX

You can generate a configuration file report from the UNIX command
line. The format of the UNIX command you use is as follows:

smcfgrpt [-d] [-t] [-h] [-m] [-W <warning level>] [-r <report template>]
[-c] <configuration file> [[-0] <report file>]

where
-d

Includes the MIB default value for any configurable attribute
for which you did not specify a value in the configuration file.

Produces the same result as -d, except that default values are
tagged “[Default].”

Includes raw hexadecimal data in addition to the ASCII
translation of that data.

Includes the MIB attribute identifier names in addition to the
ASCII translation of those names.

-W <warning level>

Sets the warning level to indicate types of warnings to include
in the report:

0 = no warning; this is the default warning level.
1 = warn on unrecognized attributes

2 = warn on unrecognized records

3 = combination of levels 1 and 2

4 = warn on unset attributes with no default

7 = combination of 3 and 4
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-r <report template>

Specifies the report template file to use. By default, the Report
Generator uses a version-specific template based on the version
of the configuration file. Template files are in /usr/wf/lib. The
format of the template filename is

<version>.rpt

For example, the template file for the version 7.80 configuration
file is 7_80.rpt.

-c <configuration file>

Specifies the name of the configuration file from which you want
to generate a report.

-0 <report file>

Specifies the pathname of the report file. If you omit this
argument, the Report Generator sends the output to <stdout>.

Generating Configuration File Reports from Windows
You can generate a configuration file report from Windows on a PC. To
do so, follow these steps:
1. Bring up Windows on your PC.
2. Select File®Run.
The Run window appears.

3. In the Command Line field of the Run window, enter the smcfgrpt
command in the following format:

smcfgrpt [-d] [-t] [-h] [-m][-W <warning level>]
[-r <report template>] [-¢] <configuration file> [-0] <report file>
where
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-d

Includes the MIB default value for any configurable
attribute for which you did not specify a value in the
configuration file.

Produces the same result as /d, except that default values
are tagged “[Default].”

Includes raw hexadecimal data in addition to the ASCII
translation of that data.

Includes the MIB attribute identifier names in addition to
the ASCII translation of those names.

-W <warning level>

Sets the warning level to indicate types of warnings to
include in the report:

0 = no warning; this is the default warning level.
1 = warn on unrecognized attributes

2 = warn on unrecognized records

3 = combination of levels 1 and 2

4 = warn on unset attributes with no default

7 = combination of 3 and 4

-r <report template>

Specifies the report template file to use. By default, the
Report Generator uses a version-specific template based on
the version of the configuration file. Template files are in
c:\wf\lib. The format of the template filename is

<version>.rpt

For example, the template file for the version 7.80
configuration file is 7_80.rpt.
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-¢ <configuration file>

Specifies the name of the configuration file from which you want
to generate a report. If the path to the configuration file is not in
your PATH statement, be sure to enter the full pathname.

-0 <report file>
Specifies the pathname of the report file.

4. Click on OK in the Run window.

Maintaining an Audit Trail Log

To use the audit trail feature, you must edit the default audit trail
configuration file that comes with Site Manager. You edit the file to

0 Specify an audit trail community; that is, the routers for which you
want to create audit trail log files.

a Specify whether you want auditing on or off. By default, the audit
trail feature is off.

The following section describes how to edit the audit trail configuration
file.

Editing the Audit Trail Configuration File

Site Manager provides a default audit trail configuration file, audit.cfg.
The file resides in /usr/wf on UNIX workstations, and in ¢:\wf on
PCs. You must edit the file to specify the following for each router you
want to audit:

o The IP address of the router
0 The pathname of the audit trail log file

0 The email addresses of all users that the audit trail feature should
notify if the router’s configuration file changes

0 Whether the audit trail feature is on or off
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To edit the audit trail configuration file, follow these steps:

1. To edit the audit trail configuration file on a UNIX workstation,

copy the audit.cfg file to a directory where you have write
permission.

Open audit.cfg in a standard text editor.
Figure 6-6 shows the default file.

#ROUTER=192.32.156.66

#AUDIT=0ON

#FILE=/usr/wf/routerA.adt
#EMATIL=jdoelwellfleet.com, jsmith@wellfleet.com

Figure 6-6. Default Audit Trail Configuration File

3.

Copy the four default lines in the file and insert them at the end of
the file.

Delete the pound sign at the beginning of the ROUTER= line. After
the equal sign, overwrite the default value with the IP address of
the router you want to audit.

For example, you might type
ROUTER=192.32.156.3

Delete the pound sign at the beginning of the FILE= line. After the
equal sign, overwrite the default value with the path and filename
for the audit trail log file for the router.

On UNIX workstations, the path for your audit trail log file should
point to a directory in your UNIX environment where you have
write permission. On PCs, the path is c:\wf. The filename should
be the router’s name (not its IP address) followed by the .adt
extension.

For example, you might type
FILE=/usrl/jb/southcape.adt
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6. Delete the pound sign at the beginning of the EMAIL= line. After
the equal sign, overwrite the default value with the email
addresses of users you want to notify of configuration changes. Use
a comma to separate each email address.

For example, you might type
EMAIL=pgrant,llantz,odiaz

If you do not want to use mail notification, delete the pound sign at
the beginning of the EMAIL= line and delete the default email
addresses.

Note: The mail notification feature is not available on PCs.

7. Delete the pound sign at the beginning of the AUDIT= line. To
enable audit trail logging, leave the default value, ON. To disable
audit trail logging, type off after the equal sign.

8. Repeat steps 2 through 6 for each router that you want to audit.

9. Save your changes and exit the file.

You must specify the new pathname for the AUDIT_PATH
environment variable. For UNIX platforms, this variable should point
to the directory where you have placed the modified audit trail
configuration file. For example:

AUDIT_PATH=/usrl/jake/audit.cfg

For the PC, the variable should point to the directory c:\wf\audit.cfg.
For example:

set audit_path=c:\wf\audit.cfg

Viewing an Audit Trail Log File

Once Site Manager creates an audit trail log file and appends
information to it, you can open it in any standard text editor. You can
also print the file. Figure 6-7 shows a sample audit trail log file.
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Wed Jul
192.32
Wed Jul
192.32
Wed Jul

192.32.

Wed Jul
192.32
Wed Jul
192.32
Wed Jul
192.32
Wed Jul
192.32
Wed Jul
192.32
Wed Jul
192.32
Wed Jul

192.32.

Wed Jul
192.32
Wed Jul
192.32
Wed Jul
192.32
Wed Jul

192.32.

Wed Jul

6 04:57:13 1994

.156.71 wfSerialPortTable.l1l1=2 ksnow remote.

6 04:57:13 1994

.156.71 wfSerialPortTable.1l1=15 ksnow remote.

6 04:58:37 1994
156.71 wfSoftwareConfig.20=4 ksnow remote.
6 04:58:37 1994

.156.71 wfSoftwareConfig.30=5 ksnow remote.

6 04:58:37 1994

.156.71 wfSoftwareConfig.30=1 ksnow remote.

6 04:58:37 1994

.156.71 wfCSMACDTable.1l6.2=6 ksnow remote.

6 04:58:37 1994

.156.71 wfLineMappingTable.1106102=4 ksnow remote.

6 04:58:37 1994

.156.71 wfLineMappingTable.1106102=3 ksnow remote.

6 04:58:37 1994

.156.71 wfCSMACDTable.1l6.2=38 ksnow remote.

6 04:58:37 1994
156.71 wfCircuitNameTable.12=3 ksnow remote.
6 04:58:37 1994

.156.71 wfCircuitNameTable.1l2=4 ksnow remote.

6 04:58:37 1994

.156.71 wfCircuitNameTable.12=5 ksnow remote.

6 04:58:37 1994

.156.71 wfCircuitNameTable.1l2=6 ksnow remote.

6 04:58:37 1994
156.71 wfCircuitNameTable.12=7 ksnow remote.
6 04:58:37 1994

Figure 6-7. Sample Audit Trail Log File
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Chapter 7
Performing Administrative Functions

For general information about using the Site Manager Administration
menu, see “Performing Administrative Functions,” in Chapter 1. For
specific information about using buttons, windows, and other Site
Manager features, refer to Using Site Manager Software.

Use the Administration menu to do the following:

o Display the Site Manager software release version and router
software release version

Boot a router
Clear the event log
Set a router’s date and time

Ping a remote device

g o o Qo Q

Reallocate memory partitions for a processor module




Displaying Software Versions

Displaying Software Versions

To display the Site Manager version, begin at the Wellfleet Site
Manager window or any tools window. Select Help->Site Manager
Version. The Version window displays the Wellfleet Site Manager
software version. The Description and MIB Version fields in the
Wellfleet Site Manager window display the router software version

(Figure 7-1).
[® Wellfleet Site Manager
File View Options Tools Administration Help

;Connectionl iStatisticsH Traps H Events Jg Files I

We]_l—l(nown Connectlons

System Name/IP A “nAn mn ta A
SNMP ID (Communit j[@] Version

Site Manager Version 1. 80/Int 20

Svsten Name:

Contact:

Location:

j Description: " Tnag dev/tco].ley/S 00/33 Created on Wed Jul 20

12: 04 00 EDT 1094,

MIB Version: %8, 00

Model: Link Node (LN}
Power Supply 1: Not 8pplicable
Power Supply 2: Mot &pplicable
Power Supply 3: WNot Applicable
Power Supply 4: Not &pplicable
Fan: Not &pplicable
Temperature: Not &pplicable

Figure 7-1. Displaying Version Information
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Ensure that the version of Site Manager is compatible with the version
of the router software (for example: 1.70 and 7.70, or 1.60 and 7.60).

Router Booting Procedures

Booting a router warm-starts every processor module in the router.
Pressing the Reset button on the front panel of the router performs the
same procedure.

Note: You can use Site Manager to warm-start a router only. To cold-
start a router to initiate diagnostic tests, you must physically
power off and then power on the router, or use the diags
command from the Technician Interface (TT). Refer to Using
Technician Interface Software for more information.

You must boot a router to use a new configuration file or router
software image.

FN/LN/CN Router Boot Prerequisite

The PCMCIA/Floppy switch on the Flash System Controller board of
an FN, LN, or CN determines where the router looks for the image
(ace.out) and configuration file when it is booting. The PCMCIA
(Personal Computer Memory Card International Association) position
is for memory card boot access, and the Floppy position is for diskette
boot access.

You can use Site Manager and the Technician Interface to access both
the memory card and diskette files, regardless of the position of this
switch. But you cannot override the switch setting when booting. For
example, you cannot boot from a diskette if the switch is set in the
PCMCIA position.

When you use the Site Manager to boot the router, or specify an image
and configuration file in a Technician Interface boot command, the
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software verifies the file’s existence before allowing the boot to take
place.

If the PCMCIA/Floppy switch is in the PCMCIA setting, and you boot
the router, the following occurs:

1. The router boots from I1:ace.out if it is available. If not, it boots from
2:ace.out if it is available. If both are unavailable, a boot error
occurs.

2. The router configures from I:config if it is available. If not, it
configures from 2:config if it is available. If both are unavailable, a
configuration error occurs.

Booting a Router

You can boot a Wellfleet router as follows:

1. From the Wellfleet Site Manager window, select
Administration>Boot Router.

The Boot Router window shows default filenames for the router
software image and the configuration file (Figure 7-2).

[®] Boot Router
Cancel

Boot Image: |ace. out ;
Configuration: Iconfig g

Figure 7-2. Boot Router Window

You can enter alternative filenames in this window. The Boot
Router window also shows two default router volumes for the
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9.

10.

router software image and configuration file. You can select
alternative volumes as well.

To boot from a router software image other than the one displayed,
enter an image filename in the Boot Image field.

Select the rectangle next to the Boot Image volume. A pop-up
window shows the available router volumes.

Select the volume where the image specified in step 2 is located.
The pop-up window closes and the new volume is displayed.

To boot from an alternative configuration file, enter a configuration
filename in the Configuration field.

Select the rectangle next to the Configuration volume shown. A
pop-up window shows the available router volumes.

Select the volume where the configuration file specified in step 5 is
located. The pop-up window closes and the new volume appears.

Click on Boot. A confirmation window appears.
Click on OK. Wait a few minutes to give the router time to reboot.

To determine if the router booted correctly, select
View=>Refresh Display from the Wellfleet Site Manager window.

If the router booted correctly, system information appears in the
Wellfleet Site Manager window.

The same defaults appear in the Boot Router window after every boot.
Depending on the router, the following may appear:

a

the name of the router’s boot image (The section “Default
Filenames” in Chapter 5 lists the names of the boot images for the
different Wellfleet routers.)

config for all routers

Volume number for routers using a memory card or Single Inline
Memory Module (SIMM)

Volume indicated by the letter A for routers using a diskette
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Booting a Processor Module

Booting a processor module by using the Reset Slot option warm-starts
a single processor module in the router.

The reset option allows you to reboot a processor module with the boot
image and configuration file the router is currently using.

You may want to reset a slot to troubleshoot a problem you are having
with a router. To reset a slot, follow these directions:

1. From the Wellfleet Site Manager window, select
Administration>Reset Slot.

The Reset Slot window appears (Figure 7-3), showing the router’s
default slot.

@ Reset Slot @00 00

Reset Cancel

Figure 7-3. Reset Slot Window

2. Click the rectangle adjacent to the slot number. A pop-up window
shows the available slots (Figure 7-4).

Reset

Slot:

o= |00 o

Figure 7-4. Selecting a Slot
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3. Select the slot where you want to boot a processor module. The pop-
up window closes and the slot number you selected appears.

4. Click on Reset. A confirmation window appears.
5. Click on OK.

When you boot a processor module (reset a slot), the following occurs:

0 The operating router software running on the processor module
forwards a boot request to the other processor modules.

a  The first processor module to respond to the boot request forwards
the boot image resident in its memory.

0 The resetting processor module receives and executes the boot
image. At this instant, the router disrupts connectivity to the
associated slot and the services provided in that slot. The other
processor modules resynchronize their routing tables after the slot
fails to receive packets.

a3 The resetting processor module completes the boot process and
requests a configuration. The first available processor module
forwards the configuration resident in its memory.

0 The resetting processor module loads the configuration image and
initiates the services provided by the slot, thus re-establishing
connectivity. The resetting processor module alerts the other
processor modules that it can receive packets.

a The other processor modules resynchronize their routing tables
accordingly.
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Clearing the Event Log

To clear a router’s current event log, follow these steps:
1. Select Administration>Clear Log.
A confirmation window appears.

2. Click on OK to delete all the event messages currently stored in the
router’s memory.

New event messages automatically start filling the event log again.

Setting a Router’s Date and Time

You can use the Router Date and Time command to update the router’s
date, time, and time zone.

To set the time and date recorded on the router, follow these steps:

1. From the Wellfleet Site Manager window, select
Administration>Router Date and Time.

The Router Date and Time window appears (Figure 7-5).
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[® Router Date and Time

=]

Date:
Month

Hour

Minute

Zone (offset from GMI):
Hours

H l
(2]

| 8et | | Cancel |

Figure 7-5. Router Date and Time Window

2. Use the slidebar in each field to specify the correct information.

Then click on Set.

The Zone field lets you specify the number of hours your time zone
is ahead of or behind Greenwich Mean Time (GMT). Move the
slidebar to the left to select a value behind (-) GMT. Move the
slidebar to the right to select a value ahead of GMT. For example,
Eastern Standard Time Zone is 5 hours behind GMT, so you would

select -5.
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Pinging a Remote Device

The Ping from Router option lets you test the reachability of a remote
device using one of five protocols: IP, IPX, OSI, VINES, and AppleTalk.

You ping from the router by selecting Administration>Ping from
Router and then one of the protocols listed in the menu (Figure 7-6).

[® Wellflest Site Manager

File Wiew Options Tools A_dminjstrationl Help

_ jBoot Router...
System Name/IP Address: ]R_eset §lot...

SWMP ID (Community): fClear Log...

Router Date and Time,..

System_Record Ping from Router piIP,..,
,,,, Kernel Configuration,.. (IPX...

System Name: 0sL... ::

Contact: ’"" VINES. .. ::
Location: I"" AppleTalk,.. ——i

Figure 7-6. Selecting Ping from Router Option

The following sections describe the five ping options.

IP Ping

When you ping a remote device using the Internet Protocol, the ping
program residing on the router sends an Internet Control Message
Protocol (ICMP) echo request to the remote address you specified in the
IP Ping window. The remote device responds to the router’s request if

it is reachable. A message window pops up, showing the response or
the result of the request.

To send an ICMP echo request to a remote device running IP, proceed
as follows:

1. Select Administration>Ping from Router->IP. The IP Ping window
appears (Figure 7-7).
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[®] IP Ping

Traceroute (v/n)

IP Address: I [ | §

Timeout:
Retries: IE
Packet, Size: |16 {

Cancel

Figure 7-7. IP Ping Window

2.

In the IP Address field, enter the IP address of the remote device, in
dotted decimal notation.

In the Timeout field, enter the number of seconds after which you
want each ping to time out. The default Timeout is 1 second.

If the router receives a response to a ping after the ping has timed
out, it does not send an “alive” message to Site Manager.

In the Retries field, enter the number of successive times the router
should repeat the ping. The default for Retries is 0.

The router does not wait for the timeout before it sends the next
ping.

In the Packet Size field, enter the number of bytes of data to send
with each ping. The default Packet Size is 16.

In the Traceroute field, specify y (yes), if you want the router to
generate a path report that shows the intervening hop addresses to
the destination. The default for Traceroute is n (no).

Click on Ping.
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IP Ping Responses

Site Manager displays one of the following messages when you select
ping. (If you enter a value other than 0 for Retries, Site Manager
displays one of the following messages for the default ping, plus one for
each additional ping.)

0 An “alive” message appears if the router received an ICMP echo
response from the target device within the timeout allowed. The
message also provides the size of the test packet. Figure 7-8 shows
a sample message.

@mssagepopp 882180 202
"ping 192,32,182,1 -tl -s16 -r0: IP ping: 192,32,182.1 is alive (size = 16
bytes)

Figure 7-8. Ping Is Alive Window

o A “does not respond” message appears if the media access control
(MAC) address of the target device is resolved, but the router did
not receive an ICMP echo response from the target device within
the timeout allowed. Figure 7-9 shows a sample message.

[®] Message Detail

::ping 192,32,182,7 -t1 -s16 -r(: IP ping: 192.32,182,7 does not respond,

Figure 7-9. Ping Does Not Respond Window

0 An “ICMP host unreachable from <y.y.y.y>" message appears if the
router whose address is y.y.y.y cannot forward the ping request any
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IPX Ping

further along the path to the target device. IP updates its IP
routing or ARP table accordingly. A sample message follows:

ping: ICMP host unreachable from 192.32.243.1

o Atarget address “is unreachable” message appears if the router
previously issued an “ICMP host unreachable from <y.y.y.y>"
message. Within 40 seconds, the router receives a subsequent
ICMP echo request addressed to the same target device. The ARP
times out or the address is not resolved. A sample message follows:

ping: 192.32.1.151 is unreachable

When you issue an Internet Packet Exchange Protocol (IPX) ping, the
router sends an IPX configuration request packet to the remote IPX
address that you specify. If the remote device is listening on socket
number 456h for an IPX configuration request packet, it responds if it
can be reached, and Site Manager displays a message indicating that
the device “is alive” or “does not respond.”

IPX configuration request packets are typically used to get
configuration information from other devices on a NetWare® network.
However, the router only uses these packets to test the reachability of
a remote device that listens for and responds to IPX configuration
request packets.

The IPX router will not send or acknowledge IPX configuration request
packets addressed to

o  Network 0x00000000 (local network destination) or network
0xFFFFFFFF

g  Host 0x000000000000 or host OxFFFFFFFFFFFF (broadcast host
destination)

The IPX router will only respond to request packets sent directly to one
of its interface addresses. If you send a request packet from a router to
an IPX interface on that same router, the router does not send the
request packet out onto the line. Instead, the router sends the packet
internally to the specified interface, which then responds internally.
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To send an IPX configuration request packet, proceed as follows:

1. Select Administration>Ping from Router=>IPX. The IPX Ping
window appears (Figure 7-10).

fddress: |1l |
Tineout:
Retries: [0 |

Cancel

Figure 7-10. IPX Ping Window

2. In the Address field, enter the IPX address of the remote device, in
hexadecimal or decimal notation.

An IPX address consists of a 4-byte network address and a 6-byte
host address, separated by a period (for example,
0x0000AB12.0x000000CD1234 [leading zero padding is not
required]). Ox indicates that the address is in hexadecimal
notation.

An IPX address in decimal notation consists of a 4-byte network
address and a 6-byte host address, where each byte is a number
between 0 and 255, inclusive, and each byte is separated from the
next byte by a period (for example, 0.1.23.47.0.0.0.1.2.55).

Note: If you issue an IPX ping to an entity on a Token Ring network,
you must enter the host portion of the IPX address in byte-
swapped (noncanonical) form.
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3.

5.

In the Timeout field, enter the number of seconds after which each
ping times out. The default Timeout is 1 second.

If the router receives a response to a ping after it times out, it does
not send an “alive” message to Site Manager.

In the Retries field, enter the number of successive times the router
should repeat the ping. The default for Retries is 0.

The router does not wait for the timeout before sending the next
ping.
Click on Ping.

IPX Ping Responses

Site Manager displays one of the following messages when you issue
an IPX ping. (If you enter a value other than O for Retries, Site
Manager displays one of the following messages for the default ping,
plus one for each additional ping.)

a

)

A target address “is unreachable” message appears if the router
cannot find the specified network address in its table of IPX
networks. A sample message follows:

IPX ping: O0xAB12.CD1234 is unreachable

An “alive” message appears if the router receives an IPX reply
packet from the target device within the timeout allowed. A sample
message follows:

IPX ping: 0xAB12.CD1234 is alive
A “does not respond” message appears if the IPX address of the
target device is resolved, but the router does not receive an IPX

reply packet from the target device within the timeout allowed. A
sample message follows:

IPX ping: O0xAB12.CD1234 does not respond

An “invalid parameter specified” message appears if the network or
host address is all Os, all Fs, or not a valid IPX address. A sample
message follows:

IPX ping: invalid parameter specified
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OSI Ping

o A “resource error” message appears if the router cannot allocate a
buffer for the request because no buffers are available. A sample
message follows:

IPX ping: resource error

When you issue an OSI ping, the router sends a Connectionless
Network Protocol (CLNP) echo request to the remote network service
access point (NSAP) address you specify. The remote device responds if
it can be reached, and Site Manager displays the response or the result
of the request.

To send a CLNP echo request, proceed as follows:

1. Select Administration=>Ping from Router=>OSI. The OSI Ping
window appears (Figure 7-11).

Address: |1l §
Timeout:
Retries: [0 |

Cancel

Figure 7-11. OSI Ping Window

2. In the Address field, enter the NSAP address of the remote device,
in hexadecimal notation.

3. In the Timeout field, enter the number of seconds the router should
wait for a response from the remote device. The default Timeout is
1.
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4.

5.

In the Retries field, enter the number of successive times the router
should repeat the ping. The router does not wait for the timeout
before it sends the next ping after a response to a previous ping is
received. The default for Retries is 0.

Click on Ping.

OSI Ping Responses

Site Manager displays one of the following messages when you issue
an OSI ping. (If you enter a value other than 0 for Retries, Site
Manager displays one of the following messages for the default ping
plus one for each additional ping.)

a

An “alive” message appears if the router receives a CLNP echo
response from the target device within the timeout allowed. A
sample message follows:

OSI ping: 49000400000a212121200 is alive

A target address “is unreachable” message appears if the local
router cannot find the specified address in its routing table. A
sample message follows:

OSI ping: 49000400000a12121200 is unreachable

A “does not respond” message appears if the NSAP address of the
target device is resolved, but the router does not receive a CLNP
echo response from the target device within the timeout allowed. A
sample message follows:

OSI ping: 49000400000a12121200 does not respond

An “NSAP address is too short” message appears if the NSAP
address is too short. The minimum allowed NSAP address length is
20 hexadecimal characters (10 bytes). A sample message follows:

OSI ping: NSAP address is too short

An “OSI service is not running” message appears if the OSI service
is not enabled on the router. A sample message follows:

OSI ping: OSI service is not running
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VINES Ping

A “resource error” message appears if the router cannot allocate a
buffer for the request because no buffers are available. A sample
message follows:

0SI ping: resource error

A “system error” message appears if the Technician Interface has
failed. A sample message follows:

0SI ping: system error

Ay yyy.yy.y.y.y.Y.y.y.y.y.y.y.y.y.y.y> is a bad NSAP address”
message appears if the NSAP address is more than 20 hexadecimal
characters or nonhexadecimal characters.

V.Y.V.Y.Y.V.Y.Y.V.Y.V.V.V.y.y.y.y.y.y.y is the address of the CLNP host.
A sample message follows.
OSI ping: 123456Z 1is a bad NSAP address

When you issue a VINES ping to a remote VINES device, the router
responds if the device can be reached, and Site Manager displays the
response or the result of the request.

To send a VINES request to determine the network connectivity of a
VINES host, proceed as follows:

1. Select Administration>Ping from RouterVINES. The VINES

Ping window appears (Figure 7-12).
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(o VINES Ping R D B

Packet Size:

Traceroute (y/n)

Net, Host: l 1 E

Timeout: IE
Retries: E

Cancel

Figure 7-12. VINES Ping Window

2.

In the Network Host field, enter the network and host address of
the remote device you want to ping. The Network ID is the 32-bit
serial number of the server node that identifies the logical grouping
of nodes on a VINES network. The Host address is the 16-bit
subnetwork number, which identifies the node within the server
node’s logical grouping.

Note: You can enter the network and host addresses in decimal or

3.

hexadecimal format. If you use hexadecimal format, precede
each address with the Ox prefix.

In the Timeout field, enter the number of seconds after which each
ping times out. The default Timeout is 1 second.

If the router receives a response to a ping after it has timed out, it
does not send an “alive” message to Site Manager.

In the Retries field, enter the number of successive times the router
should repeat the ping. The default for Retries is 0.

The router does not wait for the timeout before it sends the next
ping.
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5. In the Packet Size field, enter the number of bytes of data to send
with each ping. The default is 16.

6. In the Traceroute field, specify y (yes) if you want the router to
generate a path report that displays the intervening hop addresses
to the destination. The default is n (no).

7. Click on Ping.

VINES Ping Responses

Site Manager displays one of the following messages when you issue a
VINES ping (if you enter a value for Retries, Site Manager displays
one of the following messages for the default ping, plus one for each
additional ping):

)

An “alive” message appears if the router receives a response from
the target device within the timeout allowed. The message also
indicates the size of the test packet. A sample message follows:

VINES ping: 2705682.8003 is alive (size = 16 bytes)

A “does not respond” message appears if the address of the target
device is resolved, but the system did not receive a response from
the target device within the timeout allowed. A sample message
follows:

VINES ping: 2705682.8003 does not respond

A target address “is unreachable” message appears if the router
cannot find the specified address in its routing table. A sample
message follows:

VINES ping: 2705682.8003 is unreachable

A “resource error” message appears if the router cannot allocate a
buffer for the request because no buffers are available. A sample
message follows:

VINES ping: resource error
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o An “invalid parameter specified” message appears if you specify an
invalid parameter when you issue a VINES ping. A sample
message follows:

VINES ping: invalid parameter specified

a A “VINES service is not running” message appears if the VINES
service is not enabled on the router. A sample message follows:

VINES ping: VINES service is not running

AppleTalk Ping

When you issue an AppleTalk ping to a remote AppleTalk device, the
router responds if the device can be reached, and Site Manager
displays the response or the result of the request.

To send an AppleTalk request to determine the network connectivity of
an Appletalk host, proceed as follows:

1. Select Administration>Ping from Router->AppleTalk. The
AppleTalk Ping window appears (Figure 7-12).

[® AppleTalk Ping EREEEEE N £

Net. Host: I §

Tﬁmmm:lll
Retries: E
Packet Size: !ﬁll

Cancel

Figure 7-13. AppleTalk Ping Window
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2. In the Net.Host field, enter the network address and node ID of the
remote device you want to ping. The range of valid values for an
AppleTalk network address is from 1 to 65279 (decimal). The range
of valid values for an AppleTalk node ID is from 1 to 254 (decimal).

Note: You can enter the network address and node ID in decimal or
hexadecimal format. (If you use hexadecimal format, precede
each address or node ID with the Ox prefix.)

3. In the Timeout field, enter the number of seconds after which each
ping times out. The default Timeout is 1 second.

If the router receives a response to a ping after it has timed out, it
does not send an “alive” message to Site Manager.

4. Inthe Retries field, enter the number of successive times the router
should repeat the ping. The default for Retries is 0.
The router does not wait for the timeout before it sends the next
ping.

5. In the Packet Size field, enter the number of bytes of data to send

with each ping. The default is 16 bytes, and the maximum is 585
bytes.

6. Click on Ping.

AppleTalk Ping Responses

Site Manager displays one of the following messages when you issue
an AppleTalk ping (if you enter a value for Retries, Site Manager
displays one of the following messages for the default ping, plus one for
each additional ping):

o An “alive” message appears if the router receives a response from
the target device within the timeout allowed. The message also
indicates the size of the test packet. A sample message follows:

AppleTalk ping: 2553.217 is alive (size = 16 bytes)
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A “does not respond” message appears if the address of the target
device is resolved, but the system did not receive a response from
the target device within the timeout allowed. A sample message
follows:

AppleTalk ping: 2553.217 does not respond

A target address “is unreachable” message appears if the router
cannot find the specified address in its routing table. A sample
message follows:

AppleTalk ping: 2553.217 is unreachable

A “resource error” message appears if the router cannot allocate a
buffer for the request because no buffers are available. A sample
message follows:

AppleTalk ping: resource error

An “invalid parameter specified” message appears if you specify an
invalid parameter when you issue an AppleTalk ping. A sample
message follows:

AppleTalk ping: invalid parameter specified

An “AppleTalk service is not running” message appears if the
AppleTalk service is not enabled on the router. A sample message
follows:

AppleTalk ping: Appletalk service is not running
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Reallocating Memory Partitions for a Processor Module

Using the Site Manager’s Kernel Configuration tool, you can reallocate

memory for the following routers and processor modules:

AFN The AFN router contains a single processor module.
AN The AN router contains a single processor module.
ASN The ASN router contains a single processor module.
ACE32 (8 MB or | The ACE32 processor module is used in VME-based
greater) routers—CN, LN, FN, and ALN.

FRE2 The FRE2 processor module is used in the BLN,

BLN-2, and BCN routers.

Partitioning Overview

Processor modules in a router use three types of memory:

o Global memory

o Local memory

a Nonvolatile RAM (NVRAM)

Global and local memory are separate partitions of a single,
contiguous, memory address space. The RAM chips associated with
this address space exist physically on each processor module.

The NVRAM for each processor module stores the memory partitioning

configuration associated with that module. You cannot partition

NVRAM.

7-24




Performing Administrative Functions

Note carefully the differences in how NVRAM supports processor
modules in PPX- and VME-bus Wellfleet routers:

FRE2 NVRAM is present on each | If you move a FRE2 module to

(PPX- FRE2 processor module another slot in the router, the
based inside the router. memory partitioning configura-
routers) tion moves with the FRE2 mod-

ule to the new slot.

ACE32 For routers using ACE32 If you move an ACE32 module

(VME- processor modules, to another slot in the router,

based NVRAM is only present on the memory partitioning config-

routers) | the SYSCON processor uration does not move with the
module. ACE32 module to the new slot.

The partitioning remains in
effect at the original slot loca-
tion.

You can specify the amount of local and global memory (that is, the size
of the local and global memory partitions) used by a given processor
module. Increasing the size of the Global Memory partition
automatically decreases the size of the Local Memory partition. The
router software ensures that the sum of local and global memory
always equals the total amount of memory available on a given
processor.

Site Manager does not allow you to configure more than 4 MB of global
memory to an ACE32 processor if an ACE25 module resides in the
same router. You overcome this constraint in a router with an ACE32
processor by upgrading any ACE25 processors in the same router to
ACE32 processors.
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Repartitioning Global and Local Memory

Caution:  You should change memory partitioning only at the
recommendation of, or under the direction of, your local Bay
Networks Help Desk. Under normal router and network
operating conditions, you should have no need to modify the
default memory partitions established for a processor
module. You reallocate processor memory partitions in rare
instances, and only for the purpose of network
troubleshooting.

Use the following procedure to
0 Establish a connection to a router
0 Repartition global and local memory on a processor module

1. From the Wellfleet Site Manager window, select Options=>Router
Connection.

The Router Connection Options window appears (Figure 7-14).

[®] Router Comnection Options §80

Node Name/IP &ddress

Identity (Community)

Timeout (seconds) h

Retries (per request) h

Figure 7-14. Specifying Router Connection Options
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2. Enter the IP address of a router that requires processor memory
repartitioning, and set the Timeout and Retry options. Then click
on OK.

3. From the Wellfleet Site Manager window, select
Administration->Kernel Configuration.

The Kernel Configuration window appears (Figure 7-15).

[®] Kernel Configuration 80

Memory Configuration (in KBytes)
Total on Specified Slot: 5120
Dedicated to Local Pool: 4096

Dedicated to Global Pool: [1024 |

Update | | Default | { Done |

Figure 7-15. Kernel Configuration Window

Note: If the router you are configuring is not an AN, AFN, or ASN, or
if the router does not contain an ACE32 or a FRE2 processor
module, a window appears with the following message:

No valid modules were found.

The message also means that the processor modules found in
the currently connected router are not user-configurable. Such
is the case when the Kernel Configuration routine immediately
finds only ACE25 or FRE module(s) in the currently connected

router.
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The Site Manager Kernel Configuration window displays the
following information:

Total memory for the

Total memory displayed depends on the type

specified slot of processor module.
Memory dedicated to Local pool refers to the memory used to man-
the local pool age the router. For example, it contains the

statistics, event log, bootable image, and
configuration file, along with the routes that
IP has learned.

Memory dedicated to Global pool refers to the memory dedicated
the global pool for message buffers.

Select the slot of the processor module that requires memory
repartitioning.

To do so, click on and hold the Slot button to display all the slots in
the router. Then drag the pointer to the desired slot number and
release the mouse button.

Enter an amount in the Dedicated to Global Pool field.

To add more memory to the global pool, click on the Up button until
the desired amount of memory appears, or type a value in the
Dedicated to Global Pool field. As you increase the amount of global
memory, you decrease the amount of local memory proportionally.

To add more memory to the local pool, click on the Down button

until the desired amount of memory appears or type a value in the
field.

To restart the slot with the new values, click on Update. A
confirmation window prompts

Restart slot?

(To reset the memory allocation to the factory-default values, click
on Default rather than Update. A message then prompts you to
confirm your decision to reset the values.)

Click on OK to restart the processor module located in that slot.
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Site Manager stores the new configuration in NVRAM and restarts
the module (ACE32 or FRE2) or router (AN, AFN, or ASN). This
store-and-restart process takes about 10 seconds to complete.

Repeat steps 2 through 7 to reallocate memory partitioning on a
different processor module, if applicable.

Repeat steps 1 through 7 to reallocate memory partitioning on a
processor module in a different router.

When you finish, click on Done in the Kernel Configuration
window. (The Wellfleet Site Manager window reappears.)
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Chapter 8
Using the Ping MIB

For general information about the Ping management information base
(MIB), refer to “Tracking Network Availability and Response Time” in
Chapter 1. For specific information about using buttons, windows and
other Site Manager features, refer to Using Site Manager Software.

To use the Ping MIB to track network availability and response time,
you
a Configure IP ping requests

o Review IP ping statistics
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Configuring IP Ping Requests

To configure the ping requests for which you want to store the results
in the Ping MIB, follow the steps in this section.

Note: For Site Manager Release 2.10, the Ping MIB supports IP ping
requests only.

1. From the Wellfleet Site Manager main window, select
Options>Router Connection. The Router Connection Options
window appears (Figure 8-1).

[®] Router Connection Options

Node Name/IP f&ddress 2, 32, 156, 68
Identity (Community)

Timeout (seconds) h
Retries (per request) M

Figure 8-1. Router Connection Options Window

2. In the Node Name/IP Address field, type the IP address of the
router you want to configure. Then click on OK.

3. Select Tools>Configuration Manager, and then select the
configuration mode you want (Local File, Remote File, or Dynamic).

If you choose Local File, the File Selection window appears (Figure
8-2). If you choose Remote File, the Edit Remote Configuration File
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window appears, and if you choose Dynamic, the Configuration
Manager window appears. This chapter assumes you chose the
Local File configuration mode. See Configuring Wellfleet Routers for
information on using the Remote File and Dynamic configuration

modes.

(@ File Selection

Path: | Jextra/smgr Open
File
Directory: |srrugr f File: Iconﬁg Delete
File
Path List Directories List:  Files List Teleta
/ B wastebasket . openwin-init, BA Dj;ecetory
bruce . wisminit
Jinn . wflaunch
has . Kdefaults, open Cancel
lori . logout
builder_dir . witemp
tocleanout . remote_sm Help
.cetables . Rerrorlog
mark
ksc . remote_snap
.eln . twmre
v Mail clarify, env
A > EE

Figure 8-2. File Selection Window

4. Specify the name of the router’s configuration file. Then click on
Open File to open the file in the Wellfleet Configuration Manager
window (Figure 8-3).
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[® Configuration Manager B
File Options Platform Circuits Protocols Dialup Window Help

Configuration Mode: local
P Agent: LOCAL FILE .
File Name: /extra/smgr/config
Model: Backbone Link Node (BLN)
MIB Version: 7.70

Color Key: Used Unused

slot Description Connectors

5 § Epty Slot I I o
4 ] Empty Slot || NONE |: NONE |i NONE |{ NONE |
3 | Eupty Slot |{ NONE |i NONE || NONE || NONE |
2 (5430 Dual Sync, Dual Ethernet| [ CoMz | [ CoMi | [ WovRz | INEEER

1 System Resource Module | JEENERN

Figure 8-3. Configuration Manager Window

5. From the Wellfleet Configuration Manager window, select
Platform=>Ping at Intervals>IP. The Ping at Intervals window
appears (Figure 8-4).
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[® PING at Intervals

il

Done
dpply

il

Source Route

| Ping Start
. Ping Stop
| Delete

Yalues, ..
Help...

il

IP Address

Ping Site Name

Packet Size

Time Out

l

|

|

|
Ping Retry r

r

Ping Delay

SR § N £ SO E U | S |

Figure 8-4. Ping at Intervals Window

6. Click on the Add button. The IP Ping Parameters window appears

(Figure 8-5).
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[®] IP Ping Parameters

Cancel

Configuration Mode: local OK
SNMP Agent: LOCAL FILE Values. ..
Help...

i

IP Address ( |

Figure 8-5. IP Ping Parameters Window

7. Enter the IP address that you want to ping. Then click on OK.
You then return to the Ping at Intervals window.

8. In the display area in the window, click on the IP address for which
you want to configure the ping request.

9. Enter values for the parameters in the Ping at Intervals window, as
described in the next section.

10. Click on Apply.

11. Click on Ping Start to begin pinging the IP address at the interval
you specified.

Site Manager stores the results of the ping requests in the Ping
MIB tables.

12. Repeat steps 8 through 11 to configure (and start) ping requests for
additional IP addresses.

To stop pinging an address, select the address in the Ping at Intervals
window and click on Ping Stop.
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Specifying Values for Ping at Intervals Parameters

Use the information in this section to specify values for the parameters
in the Ping at Intervals window. For each parameter, this section
provides the following information:

0 Default setting

All valid parameter options

Function or purpose of the parameter

Instructions for setting the parameter value

The Management Information Base (MIB) object ID

N L

Note: The Technician Interface lets you modify parameters by issuing
set and commit commands with the MIB object ID. This process
is equivalent to modifying parameters using Site Manager. For
more information about using the Technician Inerface to access
the MIB, refer to Using Technician Interface Software.

Parameter: IP Address
Default: None
Range:  Any valid IP address

Function:  Specifies the IP address of the device you want to
ping.
Instructions:  To change the IP address that appears in this

field, type the new address in place of the existing
one.

MIB Object ID:  1.3.6.1.4.1.18.3.3.2.13.1.1.4
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Parameter:
Default:
Range:

Function:
Instructions:
MIB Object ID:

Parameter:
Default:
Range:

Function:
Instructions:

MIB Object ID:

Parameter:
Default:
Range:

Function:

Instructions:
MIB Object ID:

Parameter:
Default:
Range:

Ping Site Name
None

Any name you want to correspond to the device
from which you are pinging

Serves as descriptive information for your use.
Optionally, enter a name for your ping site.
1.3.6.1.4.1.18.3.3.2.13.1.1.17

Packet Size
16
1 to 4850

Specifies the size of the Internet Control Message
Protocol (ICMP) packet in bytes.

Enter the number of bytes of data that you want
to send with each ping.

1.3.6.1.4.1.18.3.3.2.13.1.1.5

Time Out
5 seconds
1 to 65535

Sets the length of time (in seconds) after which an
unsuccessful ping expires.

Enter a value from 1 through 65535 seconds.
1.3.6.1.4.1.18.3.3.2.13.1.1.6

Ping Retry
1
1 to 65535
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Function:

Instructions:
MIB Object ID:

Parameter:
Default:
Range:

Function:

Instructions:

MIB Object ID:

Parameter:
Default:
Range:

Function:
Instructions:

MIB Object ID:

Parameter:
Default:
Range:

Function:

Specifies the number of successive times to repeat
a ping.

Enter a value from 1 through 65535
1.3.6.1.4.1.18.3.3.2.13.1.1.7

Ping Delay
250 milliseconds
1 to 65535

Specifies the amount of time (in milliseconds) to
wait between sending ICMP echo packets.

Enter a value from 1 through 65535
1.3.6.1.4.1.18.3.3.2.13.1.1.9

Timer
0
Any integer

Specifies the number of minutes that will pass
before the ping occurs again.

Enter a value (in minutes) or enter 0 if you want
to initiate the ping request only once.

1.3.6.1.4.1.18.3.3.2.13.1.1.11

Trace Route
PING_NOTRACE
PING _NOTRACE/PING_TRACE

Lets you turn on the Trace Routes features to
show the intermediate IP addresses (hops) the
ICMP echo packet went through to reach the

destination address.
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Instructions:

MIB Object ID:

Parameter:

Default:
Range:

Function:

Instructions:

MIB Object ID:

Select PING_TRACE to turn on the Trace Routes
feature; otherwise, leave the default,
PING_NOTRACE.

1.3.6.1.4.1.18.3.3.2.13.1.1.8

Source Route
PING_NOSOURCEROUTE

PING_NOSOURCEROUTE/
PING_STRICTSOURCEROUTE/
PING_LOOSESOURCEROUTE

Lets you override the routing table and specify the
alternate addresses you want the ping to go
through.

Choose the default PING_NOSOURCEROUTE to
use the routing table.

Choose PING_STRICTSOURCEROUTE if you
want to specify all the IP addresses that the ping
must go through to reach the destination address.
You must know all of the addresses for strict
source routing to work. With strict source routing,
if the ping cannot get from one of the specified
addresses to another, the ping will terminate.

Choose PING_LOOSESOURCEROUTE if you
want to specify the addresses that the ping should
go through to reach the destination address;
however, the ping might pass through
intermediate hops between the addresses you
specify.

If you choose strict or loose source routing, click on
the Source Route button to specify the routes. See
“Specifying Source Routes,” later in this chapter.

1.3.6.1.4.1.18.3.3.2.13.1.1.12
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Parameter:
Default:
Range:

Function:
Instructions:

MIB Object ID:

Parameter:
Default:
Range:

Function:

Instructions:

MIB Object ID:

Ping Source Address
0.0.0.0
Any valid IP address

Specifies the IP address of the source of the ping
request.

Optionally, enter the IP address you want to use
as the source address of the ping request.

1.3.6.1.4.1.18.3.3.2.13.1.1.13

Ping Type of Service
1 (Normal)

1 through 8, where
1=normal, routine service
2=priority

3=immediate

4=flash

5=flash override

6=critic ecp
T=internetwork control
8=network control

Specifies the quality of service (service
precedence) for handling the ICMP packet.

Select 1 for normal service, or enter a value from
2 through 8 to specify a different type of service.
Refer to an IP programmer’s manual for
information on the different types of services.

1.3.6.1.4.1.18.3.3.2.13.1.1.14
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Parameter:
Default:
Range:

Function:

Instructions:

MIB Object ID:

Deleting Ping Requests

Num Hist Buckets Requested
1
1 through 60

If the ping is on a timer (see the Timer
parameter), this parameter specifies the number
of entries that you want to store in the Ping
History table. In other words, you can save
information about each ping request sent on the
expiration of a timer. (If the ping is not on a timer,
the ping generates only one entry in the history
table.)

Enter a number from 1 though 60 to specify the
number of instances of the ping you want to save
information about in the Ping History table.

1.3.6.1.4.1.18.3.3.2.13.1.1.15

To remove the results of a ping request from the Ping MIB, follow these

steps:

1. Inthe display area at the top of the Ping at Intervals window, select
the ping request you want to delete.

2. Click on Delete.

3. Click on Apply or Done.

Site Manager removes all entries for the selected request from the
appropriate tables.

Specifying Source Routes

If you chose in the Ping at Intervals window to use strict or loose
source routing (see the description of the Source Route parameter in
the previous section), you must specify the routes that you want to use.
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To do so, click on the Source Route button in the Ping at Intervals
window. The Source Route Entries window appears (Figure 8-6).

[@ Source Route Entries
e P | Done |
Ping Source Route Address |

Figure 8-6. Source Route Entries Window

Proceed as follows:
1. Click on the Add button.

The Source Ping Parameters window appears (Figure 8-7).

[® Source Ping Parameters
Configuration Mode: local
SNMP Agent: LOCAL FILE
Source Address II

Figure 8-7. Source Ping Parameters Window
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2. In the Source Address field, enter the IP address of the device you
want the ping to go through to reach its destination. Then click on

OK.

You return to the Source Route Entries window. The IP address you
just entered appears in the display area.

3. To enter additional source route addresses, repeat steps 1 and 2.

You can enter as many as eight source route addresses. Figure 8-8
shows the Source Route Entries window with four completed

entries.

Be sure to enter the source route addresses in the order that you
want the packet to traverse them (from source to destination).

[@® Source Route Entries

Source dddress: 192,32, 156,68 P Done
Source Address: 192,32, 37,42 Epply
Source Address: 192, 32, 154, 33

bource Address: 192, 52, 166, 55

Delete
| Values, ..
HelP- .

idiidil

A
Y
b

Ping Source Route Address |19,2. 32,166,506 7

Figure 8-8. Completed Source Route Entries

4. Click on Done. You then return to the Ping at Intervals window.
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Changing or Deleting Source Route Addresses
To change an IP address that appears in the Source Route Entries
display window, follow these steps:
1. Click on the address you want to change.
The address appears in the Ping Source Route Address field.
2. Type the new address in place of the old one.

3. Click on Apply (to save your changes and remain in the window) or
click on Done (to save your changes and return to the Ping at
Intervals window).

To delete an address from the list of source route addresses, follow
these steps:

1. Click on the address in the display area of the Source Route Entries
window.

2. Click on Delete.

3. Click on Apply (to save your changes and remain in the window) or
click on Done (to save your changes and return to the Ping at
Intervals window).

Site Manager removes the entry from the Source Route Entries
window and from the Ping MIB tables.
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Reviewing IP Ping Statistics

You can view the information in the Ping MIB using the Statistics
Manager in Site Manager. The Statistics Manager provides four
default screens that contain information from the Ping MIB. Table 8-1
describes the four screens.

Table 8-1.  Default Ping MIB Statistics Screens

Screen Name Contents

pingmain.dat | Information from the main Ping MIB table

pinghist.dat Information from the Ping history table

pingsrc.dat Information from the Ping source route table

pingtre.dat Information from the Ping trace route table

Refer to Chapter 4 for information on viewing statistics screens.

Removing Entries from the Ping MIB

You should periodically clear entries from the Ping MIB to prevent the
entries from using up too much of your router’s memory resources.

To remove entries from the ping tables (main, history, source route,
and trace route), follow these steps:

1. Inthe Ping at Intervals display window, select the IP address of the
device whose ping information you want to remove from the ping
tables.

2. Click on Delete.
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Appendix A
Using UNIX Commands to Start Site Manager

This appendix provides instructions for directly accessing Site
Manager tools. You can use the commands from this appendix only if
you use a UNIX computer to run Site Manager.

These commands are optional and are recommended only for
experienced Site Manager users.

Table A-1 lists commands you can enter to start Site Manager tools
from a UNIX command line. Table A-2 lists options you can enter when
you use these commands.

You can add options to the startup commands listed in Table A-1 to
override Site Manager default settings. Table A-2 lists the options, the
startup commands with which they can be used, their function, the
default setting, and an example of how you enter the option.

Note: To start the Image Builder tool, type builder at the command
line. You cannot use the command options listed in Table A-2
with the builder command.

To start a Site Manager tool from the UNIX command line, follow these
directions:

1. Start the X Window System on your UNIX workstation, if it is not
already running.




2. At a command line, enter one of the commands listed in Table A-1
and any number of command options you want from Table A-2.

Append the command with a space and an ampersand (&), so that
you can continue to enter commands in the command line window
while the tool is running.

For example, you can enter the following command to start the
Configuration Manager with a connection to IP address 192.32.4.2
and an SNMP timeout of 10 seconds:

wfcfg -a 192.32.4.2 -t10 &

The tool’s window appears, displaying the IP address and the
community name of the router you specified.

Table A-1.  Site Manager Startup Commands

Command Function

wfsm Starts Site Manager, which establishes a connection with
the router.

wicfg Starts the Configuration Manager, which establishes a
connection with the router.

wilog Starts the Events Manager.

wftraps Starts the Trap Monitor.

wirfs Starts the Router Files Manager, which establishes a

connection with the router. (Note: You must specify the
SNMP agent’s IP address using the
-a <SNMP Agent IP Address> startup option.)

wistats Starts the Statistics Manager, which establishes a
connection with the router. (Note: You must specify the
SNMP agent’s IP address using the

-a <SNMP Agent IP Address> startup option.)

wflaunch Displays an individual statistics window. (Note: You must
specify the SNMP agent’s IP address using the
-a <SNMP Agent IP Address> startup option.)
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Table A-2. Site Manager Startup Command Options

Startup

Start-Up Option Commands Function Default Setting | Sample Use of Option
-¢ <SNMP Com- All Specifies the public wfsm -c Sitemgr
munity> SNMP commu-
nity string.
-a <SNMP Agent All Specifies the none wfstats -a
IP Address> SNMP agent’s IP 192.32.4.2
address.
-m <SNMP MIB All Specifies the MIB | WFMIB.defs | wfcfg -m
Definitions File> definitions file in mymib.defs
the path /usr/
wfllib.
-t <SNMP retry All Specifies the 3 wirfs -r 5
count> number of SNMP
retries.
<t <SNMP Time- All Specifies the 5 wflog -t 10
out> number of sec-
onds for the
SNMP timeout.
-s <SNMP Desti- All Specifies the UDP | 0 wftraps -s 1161
nation Port> port for the
SNMP destina-

tion. The default
setting causes
the application to
retrieve the
SNMP destina-
tion port from
/etc/ services.

continued on the next page
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Table A-2. Site Manager Startup Command Options (continued)

Start-Up Option

Startup
Commands

Function

Default Setting

Sample Use of Option

- <SNMP Trap
Port>

wfsm
wftraps

Specifies the UDP
port on which the
Trap Monitor
should listen for
SNMP traps. The
default setting
causes the appli-
cation to retrieve
the SNMP trap
port from

/etc/ services.

0

wftraps -e 1161

v <Config Vol-

ume>

wfsm
wicfg

Specifies the vol-
ume for remote
configuration file
access.

wfsm -v 3

f </path/> <file>

wicfg
wflaunch

Specifies the con-
figuration or sta-
tistics screen
filename.

wicfg -f Iwf/
file.cfg

-0 <Config Mode>

wicfg

Specifies the con-
figuration mode:
local, remote, or
dynamic.

local

wfcfg -o remote

P

wflaunch

Displays an indi-
vidual statistics
window in pre-
view mode (with-
out displaying
data).

10

wflaunch -p 1
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Appendix B
Configuring a Router with a New Link Module

When you install (in a Wellfleet router) a replacement link module or
net module that is a different type than you removed, you must edit
the router’s configuration file to reflect this change.

Note: Only the Wellfleet ASN router uses net modules.

This appendix describes how to edit a router’s configuration file to
include the new link module or net module information. This appendix
covers the following topics:

Copying the router’s configuration file

Transferring the configuration file to a local directory
Editing the configuration file

Transferring the edited configuration file to the router
Rebooting the router with the edited configuration file

Deleting the old configuration file from the router

g O o a a o a

Renaming the edited configuration file to the default
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Copying the Configuration File

Copying the Configuration File

To work with a router’s configuration file, you should first create a copy
of the file to transfer to your workstation. To copy the file, follow these
steps:

1. Connect to the router by selecting Options>Router Connection
from the Wellfleet Site Manager window.

2. Enter the router’s IP address and click on OK.

3. From the Wellfleet Site Manager window, select Tools=>Router
Files Manager. The Router Files Manager window appears

(Figure B-1).
[® Router Files Manager
File Options Commands Help

Systen Name: 192,168, 130, 170

Yolume:
startup. cfg 1568 fug 11, 1994  16:22 i
fr, VT 9716 Sep 0L, 199  (9:36
pcl. cfg 2% Sep 01, 19%  09:43
boot, exe 1617573 Nov 02, 1994 14:52

fr,al 5692 Noy 02, 1994 16:45

asn_br, bat, 16302 199 17:41

Total size: 2097152
Available free space: 438317
Contiguous free space: 425637

Figure B-1. Router Files Manager Window
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4. Select the router volume where the configuration file resides.

5. Select the configuration file from the list that appears in the Router
Files Manager window (Figure B-1).

6. Select Commands->Copy. The Router Files Manager displays the
source filename in a window (Figure B-2).

0]
Copy File
Source Filename: | M:config i

Figure B-2. Copy File Window Source Filename

7. Click on OK.
A window prompts you for the destination filename (Figure B-3).

@
Copy File

Destination Filename: |1:test. cfzll i

Figure B-3. Copy File Window/Destination Filename

8. Enter a new filename for the copy, such as test.cfg.
9. Click on OK. A confirmation window appears.
10. Click on OK.

The router copies the source file to the filename and volume you
specified.
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Transferring the Configuration File to a Local Directory

To transfer the copy of the configuration file from the router to your
Site Manager workstation, follow these steps from the Router Files
Manager window:

1. Select the router volume where you stored the copy of the router’s
configuration file.

2. Select the file; that is, the copy of the configuration file.
3. Select File®TFTP->Get File(s).

A window appears prompting you to confirm your decision to get
the configuration file (Figure B-4).

[® TFTP Get Files
Proceed with TFTP Get of file(s) 2
test, cfg

” o M o

Destination Directory:

|Hextra/ Smgr ;
i

Figure B-4. TFTP Get File Window

4. In the Destination Directory field, enter the directory where you
want to store the file on your Site Manager workstation.

5. Click on Yes to proceed.

The configuration file now resides in a local directory on your Site
Manager workstation.
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Editing the Configuration File

Use the Configuration Manager tool to edit the configuration file you
retrieved from the router.

1. Select Tools=»Configuration Manager->Local File. The File
Selection window appears (Figure B-5).

[® File Selection
Path: | Jextra/sogr § gﬁn
e
Directory: Isrrugr ;File: |te,3t. cfg i Delete
File
Path List: . Directories List:  Files List Delete
/ bect, ofz :
bruce configlocal Darectory
Jill mainwithadmin
has Julie, bak Cancel
Jori mod_0079, cfg
builder_dir mod_0081. cfg
tocleanout . wftraps-log Help
. cetables mod_0082, cfg
mark mod_0089, cfg
ksc mod_0090, cfg
.eln . witminit
¥ Mail mainwithtools
E < »

Figure B-5. File Selection Window

2. Open the configuration file you transferred to the Site Manager
workstation.

You can select the file and the directory path to the file by clicking
on the Path List, Directories List, and Files List. The Path List
shows the path from the root directory to the current directory.
Select from the Path List to move up a directory level.

The Directories List shows the directories available from the
current directory. Select from the Directories List to move down a
directory level. The Files List shows files available from the current
directory.
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Your current selections appear in the Path, Directory, and File
boxes at the top of the window. You can edit this information
directly by clicking on the appropriate box and entering a path,
directory, or file.

Once you specify the file, click on Open File. The Wellfleet
Configuration Manager window appears. Figure B-6 shows the
Configuration Manager window for an ASN.

File Options Platform Circuits Protocols Dialup Window Help

Configuration Mode: local
SNMP Agent: LOCAL FILE
File Name: /extra/smer/test,cfs
Model: Access Stack Node (ASN)
MIB Version: 8.10

Color Key: Used Unused

Slot  Module Description Commectors
4 ¢ | Enpty Module | WONE ] [NONE ] [NONE | [ HONE

f Empty Module |
Empty Module
Enpty Module

WONE | [ WORE | [ HONE | [ ONE
NOME | [ NoNE | [ ToNE | [ TONE
WONE ] | NONE | [ WONE | | NONE

3 Enpty Module NONE |{ NONE ]! NONE || NONE
Enpty Moduls NONE NONE |{ NONE || NONE
Empty Module
Empty Module NONE NONE |i NONE || NONE

Empty Module NONE NONE |i NONE || NONE
Enpty Module NONE |{ NONE |! NONE || NONE
Empty Module NONE

|
% |
% |
i |
§ |
L |
I o T |
§ |
§ |
i |
§ I
i |
§ |

I
I
|
|
NONE | [NONE | [NORE | [ ONE
|
|
|
I

Empty Module
34001 Dual Sync
34000 Dual Ethernet
Empty Module

oo
oo W = o W e W e W

| |
{ |
| |
| |
| |
{ |
1 Eapty Module |
l |
| |
[ |
| |
{ |
| |
| |

Figure B-6. Wellfleet Configuration Manager Window

3. Select Circuits>Delete Circuit from the Configuration Manager
window. The Circuit List window appears (Figure B-7).
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(@ Circuit List
Configuration Mode: local
SNMP Agent: LOCAL FILE
Circuits

R

E122

5131

5132

¥

{Bdit...| { Delete | | Done |

Figure B-7. Circuit List Window

4. Select each circuit on the slot (and module for ASNs) in which you
swapped the link module or net module. Then click on Delete. A
confirmation window appears.

5. Click on Delete again.

6. Click on Done in the Circuit List window when you are done
deleting circuits from this list.

7. In the Wellfleet Configuration Manager window, click on the link
module or net module you swapped. The Module List window
appears (Figure B-8).
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® Foduls List
SE000 DAl BLlernet i
34001 Dual Sync

34005 Dual Sync/ISDN BRI
34003 FDDI MultiMode (DAS)
34002 Dual Token Ring (4/16Mb)
Empty Module

Cancel

Figure B-8. Module List Window

8. Select the link module or net module you inserted into the router
and click on OK. A confirmation window appears (Figure B-9).

[®] message_popup @

@ 811 circuits configured on this Link Module will be deleted!
Do you REALLY want to change this Link Module?

Cancel

Figure B-9. Confirming a Circuit Delete Request

9. Click on OK in the confirmation window.
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10. Select File>Save to save your changes. A confirmation window

appears (Figure B-10).

[®] messagze_pET

File saved!

Figure B-10. File Save Confirmation Window

11. Click on OK in the confirmation window.

Transferring the Edited Configuration File to the Router

Use the Router Files Manager to transfer the configuration file back to

the router.

1. Select Tools>Router Files Manager to redisplay the Router Files
Manager window.

2. Select a router volume.

3. Select File®>TFTP->Put File(s).

The TFTP Put File Selection window appears (Figure B-11).
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[® TFTP Put File Selection

Path: | Bextra/sner

Fileg: Files To Put:

doetn |
. wastebasket. '
. Adefaults

. operwin-sm

. authority

. deskeetdefaults
, openwin-init

. openwin-menu
wicfginit v ¥

Multiple Routers:

Figure B-11. TFTP Put File Selection Window

4. In the Path box, enter the pathname of the directory on the Site
Manager workstation that contains the configuration file.
The files in that directory appear in the Files window.

5. In the Files window, click on the copy of the configuration file you
just edited. Then click on Add. The file appears in the Files to Put
window.

6. Click on No in the Multiple Routers field.
7. Click on OK.

When the transfer is complete, the TFTP Put File Selection window
closes and you return to the Router Files Manager window.
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Rebooting the Router with the Edited Configuration File

Use the Administration menu to reboot the router.

1. From the Wellfleet Site Manager window, select
Administration>Boot Router. The Boot Router window appears.

2. Specify the correct volume and boot image.

3. Select the correct router volume and the new configuration file.
Then click on Boot. A confirmation window appears.

4. Click on OK in the confirmation window and wait a few minutes.
5. Select View>Refresh Display from the Wellfleet Site Manager
window to verify that the router booted correctly.

If the router booted correctly, the new system information appears in
the Wellfleet Site Manager window.

If the router did not boot correctly, system information does not appear.
In this case, make sure that you followed the procedures described in
this chapter.

Note: If you have any questions, call your local Bay Networks Help
Desk.

Deleting the Old Configuration File from the Router

Use the Router Files Manager to delete the old configuration file from
the router.

1. Select Tools=>Router Files Manager.

2. Select the old configuration file from the available volumes.
3. Select Commands->Delete. A confirmation window appears.
4

Click on OK in the confirmation window.

Note: Ifthe router uses a memory card, use the Commands=>Compact
option to compact the memory card.
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Renaming the Edited Configuration File to the Default

By default, the file named config is the configuration file used to boot
the router. Use the Router Files Manager to change the name of your
edited configuration file to the default filename and delete the old file.

1. Select Tools=>Router Files Manager.

2. Select the edited configuration file from the list of files in the
Router Files Manager window.

3. Select Commands=>Copy so that you can copy the new
configuration file to a file named config on the router.

A window displays the source filename you selected.
4. Click on OK in the window.
A window prompts you for the name of the copy.
5. Enter config in the window, and then click on OK.
A confirmation window appears.
6. Click on OK in the confirmation window.
7. Select the edited configuration file.

8. Select Commands=>Delete to delete your edited configuration file
from the router.

A confirmation window appears.

9. Click on Yes in the confirmation window.

Your edited configuration file has effectively been renamed to the
default filename config.
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B-6
LN, 5-5, 7-24
Load Local Log File window, 3-6
Load Screen window, 4-34
local memory, 7-28
log
audit trail, 6-13 to 6-15
events, 1-4
clearing, 3-12
current, 3-3
displaying, 3-3
local, 3-6
remote, 3-5
searching for, 3-9

loose source routing, 8-10

MAC address, 4-32, 7-12
manager

adding, 2-5

SNMP, 2-5
media

partitioning, 5-3, 5-28 to 5-33

Index-5



memory
card
compacting, 5-26, B-11
erasing, 5-26
formatting, 5-27
router software on, 5-3
global, 7-28
local, 7-28
module
router software on, 5-3
partitioning, 7-24
MIB
browser, 4-3, 4-5, 4-6, 4-7, 4-31
description, 1-12
object groups, 4-6
Objects window, 4-4
Ping, 1-18, 8-1
configuring IP Ping requests, 8-2 to
8-12
deleting IP Ping requests, 8-12
specifying IP Ping source routes, 8-12
to 8-14
viewing IP Ping statistics, 8-16
standards, 4-38
variables, 5-7
Version field, 7-2
viewing, 1-11
Wellfleet, 1-11, 4-3, 4-5
modifying configuration files, 5-24
Module List window, B-8
monitoring traps, 2-16
multiple routers
setting up, 5-15

N

net module
replacement, B-1
selecting in Module List window, B-7

NetWare network, 7-13

network
1D, 7-19
management applications, 2-6
NetWare, 7-13
Token Ring, 7-14

NONE trap category, 2-10
NSAP address, 7-16, 7-17, 7-18

Num Hist Buckets Requested parameter,
8-12

NVRAM, 7-24, 7-29

0]

object
groups, 4-5, 4-6
MIB, 4-4
type, 4-8
opening configuration file, B-5

08I
Ping, 7-16

overwrite, 5-9, 5-21

P

packet information, 4-6
Packet Size parameter, 8-8

parameters
editing SNMP global, 2-15
see also individual names
partitioning media, 5-28 to 5-33
partitioning memory, 7-24
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Ping
1P, 7-10
1PX, 7-13, 7-14
MIB, 1-18, 8-1
configuring IP Ping requests, 8-2 to
8-12
deleting IP Ping requests, 8-12
specifying IP Ping source routes, 8-12
to 8-14
viewing IP Ping statistics, 8-16
0OSI, 7-16
remote devices, 7-10
router, 5-20
VINES, 7-18, 7-19, 7-21
Ping Delay parameter, 8-8, 8-9
Ping Retry parameter, 8-8
Ping Site Name parameter, 8-8
Ping Source Address parameter, 8-11
Ping Type of Service parameter, 8-11
polling
rate, 1-13, 4-18
router, 1-11, 4-17
ports, A-4
power supply
router, 4-6
previewing statistics screens, 4-34
processor module
booting, 7-6
partitioning memory, 7-24
PROM, 5-6, 5-7
boot, 5-6
diagnostic, 5-6
protocol state information, 4-6
Put File option, B-9
putting files on multiple routers, 5-15

Q

Quick Get
Facility window, 4-4, 4-8
retrieval filter, 4-8
tool, 1-12, 4-3

quitting Site Manager, 2-7

R

Radix field, 4-32
reallocating memory, 7-24
real-time display of trap messages, 2-16

refreshing
Events Manager window, 3-10
Site Manager window, 7-5
statistics, 4-17, 4-24

remote configuration mode, 5-24

remote mode
description of, 1-2

renaming configuration file, B-11
replacement link module or net module,

B-1
report
generating from configuration file, 6-2 to
6-13

format options, 6-3
from UNIX, 6-10
from Windows, 6-11
specifying a template, 6-7
reset
button, 7-3
slot, 7-6
retrieval filter
Quick Get, 4-8
statistics, 4-22, 4-26
window, 4-27
Retrieve Request option, 4-12
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retrieving
a file, 5-18
statistics files, 4-36

router
backplane ID, 4-6
boot procedures, 7-3
circuit name table, 4-6
cold-starting, 7-3
connection, 2-2, 3-2, 4-3
date and time, 7-8
default software image, 7-4
Ping, 5-20, 7-10
polling, 4-17
power supply, 4-6
serial number, 4-6
software version, 7-2
system record, 4-6
temperature, 4-6
warm-starting, 7-3

Router Date and Time window, 7-8
Router Files Manager
tool, A-2
window, B-2
routes, IP, 7-28
routing tables, 4-6, 7-7

S

Save Log window, 3-11

saving
configuration, 2-6
event messages, 3-10
trap messages, 2-22

Screen
Builder Facility window, 4-31
Builder tool, 1-13, 4-36, 4-37
Launch Facility tool, 1-13, 4-15
Manager tool, 1-13, 4-13

screens
default statistics, 4-14
designing, 4-30

Search Options window, 4-29
searching the event log, 3-9
Selected Trap Types window, 2-19

serial number
router, 4-6

Set Address Filters option, 2-18

severity
filtering events by, 3-7
messages, 2-19

Site Manager
Administration menu, 1-18
exiting, 2-7

restarting from command line, 2-8

startup commands, A-2
workstation ID, 2-3

slot
default, 7-6
filtering events by, 3-7
reset, 7-6

SNMP
acronym, 1-3
adding a Manager, 2-5
agent, 1-5, 1-8
configuring, 2-3 to 2-7
enabling, 2-14
IP address, A-2, A-3
specifying an entity, 2-11
Community List window, 2-4
editing global parameters, 2-15
Manager List window, 2-5
polling, 1-11
trap port, 2-6, A-4
socket number 456h, 7-13

software versions
displaying, 7-2

Source Route parameter, 8-9, 8-10
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source routes transferring files, 5-20

specifying for IP Ping requests, 8-12 to viewing event messages, 1-7
8-14 syntax for MIB objects, 4-8
SPECIFIC trap category, 2-10 SYSCON, 7-25
start-up commands, A-1, A-2 system record
statistics router, 4-6

custom-built screens, 1-13, 4-30
database of screens, 1-13
default screens, 1-13, 4-12, 4-14, 4-36 T

des.crlptlon, 1-11 table mode screens, 1-13, 4-35
designing screens, 4-30

display filter, 4-21 Technician Interface, 5-7
displaying, 4-15 diags command, 7-3
files, 1-14, 4-35 temperature
editing, 4-37 router, 4-6
retrieving, 4-36 templates for configuration file reports, 6-4
filter, 4-21 test
generating totals of, 4-33 ©

diagnostics, 7-3
Ping, 5-20, 7-10
VINES Ping, 7-18, 7-19, 7-21

IP Ping, 8-16
IP routing, 4-14
refreshing screen, 4-17

retrieval filters, 4-22, 4-26 TFTP, 5-14
updating, 4-17 ti.cfg, 5-7
Statistics Manager time
Quick Set, 1-12 router, 7-8
tool, 1-11, 4-15, A-2 Time Out parameter, 8-8

Tools menu, 1-11

window, 4-2 Timer parameter, 8-9

Toggle button in Filtering Parameters
window, 3-7

Token Ring network, 7-14

tools
Events Manager, 1-10, 3-1, A-2
Launch Facility, 1-13, 4-15
Screen Builder, 1-13, 4-36, 4-37
Screen Manager, 1-13, 4-13
Statistics Manager, 1-11, 4-15, A-2

strict source routing, 8-10

suggestions
backing up configuration files, 5-6
compacting files, 5-26
customizing statistics screens, 4-32
diagnosing network problems, 3-8
filenaming, 5-8
looking up event messages, 1-10
managing statistics screens, 4-13

putting files, 5-9, 5-21 Trap Monitor, 2-1
starting Site Manager from a UNIX totals
command line, A-1 generating from statistics, 4-33

Index-9



trace messages, 2-11
Trace Route parameter, 8-9

transferring
configuration file, B-4, B-9
files, 5-13
trap history file, 1-4, 2-16
clearing, 2-21
Trap Monitor tool, 1-5, 2-1, 2-18, A-2
traps
adding, 2-13
categories of, 2-10
clearing from Trap Monitor window, 2-21
configuring
by category, 2-8
by entity, 2-11
by event type, 2-12
exceptions lists, 2-12, 2-14
filtering, 2-18 to 2-21
by IP address, 2-19
by severity, 2-19
monitoring, 2-16
port, 2-6, 2-7, A-4
saving, 2-22
types, 2-7, 2-18, 2-19
viewing, 1-6, 2-16
troubleshooting, 7-6
type
MIB object, 4-8

U

UDP, A-4

port for traps, 2-6
UNIX, A-1

command line, A-1

v

Version window, 7-2

viewing trap messages, 2-16

VINES
Ping, 7-18, 7-19, 7-21

VME, 7-24

volume
displaying contents, 5-2
number, 7-5
partitioning, 5-3, 5-28 to 5-33

w

warm-starting a router, 7-3
warning messages, 2-11, 2-19

Wellfleet
MIB, 1-11, 4-3, 4-5

wfApplication, 4-5, 4-6, 4-7
wfHardwareConfig, 4-5, 4-6
wifLine, 4-5

wfLines, 4-6
wiSoftwareConfig, 4-5, 4-6
wiSystem, 4-5, 4-6
workstation ID, 2-3

X

X Window System, A-1

y4

zeroing counter objects, 4-18
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