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12.

Third-party owners from whom Bay Networks has acquired license rights to software that is incorporated
into Bay Networks products shall have the right to enforce the provisions of this license against licensee.

Licensee shall not remove or obscure any copyright, patent, trademark, trade secret, or similar intellectual
property or restricted rights notice within or affixed to any Software and shall reproduce and affix such
notice on any backup copy of Software or copies of software resulting from modification or combination
performed by licensee as permitted by this license.

Licensee shall not reverse assemble, reverse compile, or in any way reverse engineer the Software. [Note:
For licensees in the European Community, the Software Directive dated 14 May 1991 (as may be
amended from time to time) shall apply for interoperability purposes. Licensee must notify Bay Networks
in writing of any such intended examination of the Software and Bay Networks may provide review and
assistance.]

Notwithstanding any foregoing terms to the contrary, if licensee licenses the Bay Networks product “Site
Manager,” licensee may duplicate and install the Site Manager product as specified in the Documentation.
This right is granted solely as necessary for use of Site Manager on hardware installed with licensee’s
network.

This license will automatically terminate upon improper handling of Software, such as by disclosure, or
Bay Networks may terminate this license by written notice to licensee if licensee fails to comply with any
of the material provisions of this license and fails to cure such failure within thirty (30) days after the
receipt of written notice from Bay Networks. Upon termination of this license, licensee shall discontinue
all use of the Software and return the Software and Documentation, including all copies, to Bay Networks.

Licensee’s obligations under this license shall survive expiration or termination of this license.
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About This Guide

If you are responsible for configuring and managing Wellfleet® routers
but have no experience using Site Manager, you need to read this book,
which provides the following information:

o An overview of Site Manager, its graphical user interface, and how
it works with the Wellfleet MIB (refer to Chapter 1)

0 Information about using Site Manager windows (refer to
Chapter 2)

0 Information about performing basic Site Manager functions (refer
to Chapter 3)

For details about the router management tasks you can perform using
Site Manager, refer to Chapter 1 of Managing Wellfleet Routers.

For information about using the Site Manager Configuration Manager
tool to configure protocol services for Wellfleet routers, refer to
Configuring Wellfleet Routers.

For information on using the Technician Interface instead of Site
Manager, refer to Using Technician Interface Software. (The
Technician Interface is a command-line interface you can use as a
backup when Site Manager is not available.)

Note: The Site Manager windows shown in this book are from an
X Window System™ UNIX® environment. Minor variations
in screen appearance may occur from platform to platform.




Before You Begin

Before You Begin

Before you use this guide, you must install the Site Manager
application using the instructions provided in Quick-Starting Wellfleet

Routers.

How to Get Help

For additional information or advice, contact the Bay Networks Help

Desk in your area:
United States
Valbonne, France
Sydney, Australia
Tokyo, Japan

Conventions

arrow character (=)
user entry text
italic text

quotation marks (“”)

1-800-2LAN-WAN
(33) 92-966-968
(61) 2-903-5800
(81) 3-328-0052

Separates menu and option names in instructions.
Example: Protocols=>AppleTalk identifies the
AppleTalk option in the Protocols menu.

Denotes text that you need to enter. Example: Start
up the Windows environment by entering the
following after the prompt: win

Indicates variable values in command syntax
descriptions, new terms, file and directory names,
and book titles.

Indicate the title of a chapter or section within a
book.




About This Guide

Acronyms

GAME
ICMP
MIB
MDI
OSI
RFC
SNMP
TCP/IP
TFTP

Gate Access Management Entity

Internet Control Message Protocol
Management information base

Multiple Document Interface

Open Systems Interconnection

Request for Comments

Simple Network Management Protocol
Transmission Control Protocol/Internet Protocol
Trivial File Transfer Protocol

Xi






Chapter 1
Overview of Site Manager

Site Manager is an application you use to configure and manage
Wellfleet routers. This application runs on PC and UNIX workstations.
You can integrate Site Manager with many popular Simple Network
Management Protocol (SNMP) based network management
applications, such as the Hewlett-Packard® OpenView Network Node
Manager.

Refer to this chapter for information on the following subjects:
0 The Site Manager Graphical User Interface
o Site Manager and the Wellfleet MIB
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The Site Manager Graphical User Interface

The Site Manager Graphical User Interface

The Site Manager graphical user interface organizes, summarizes, and
simplifies router information. You configure and monitor Wellfleet
routers using Site Manager tools.

The main screen of the Site Manager interface displays basic router
information such as IP address, SNMP community, system name, and
management information base (MIB) version (Figure 1-1).

[® Wellfleet Site Manager
File View Options Tools Administration Help
{Comectioﬂ {Statjsticsl E Traps | f Events I { Files I

Well-Known Connections
142, 2z, 1, 107 1p
192,32,18,103  Down

System Name/IP Address: 192,32, 18,107
SNMP ID (Community) : public

System Name:

ny

Contact:

Location:

Description: n

MIB Version: xXY.YY

Model: Backbone Concentrator Node (BCN)
Power Supply 1: On Line

Power Supply 2: On Line

Power Supply 3: On Line

Power Supply 4: On Line

Fan: On Line

Temperature: Normal

Figure 1-1. Wellfleet Site Manager Window
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Overview of Site Manager

You can use the Site Manager main menu to access all Site Manager
tools and commands.

There are six submenus that you can access from the main menu bar
(Figure 1-2). Refer to Chapter 3 for information on the options in the
submenus.

[®] Wellfleet Site Manager NS

File View Options Tools Administration Help
[Exit PF10 v
How To Use...
Site Manager VYersion,..

IRefresh Display PF8]

Connections... PF9
Connections List...

N

Configuration Manager &
Statistics Manager...
Trap Monitor... PF6

Router Files Manager...
Report Generator,..

Events Manager... PF7
Image Builder...

!

Boot Router..,

Reset Slot...

Clear Log...

Router Date and Time,.,
Ping from Router >
Kernel Configuration, ..

- Figure 1-2. Main Menu Bar and Submenus




The Site Manager Graphical User Interface

Below the Site Manager main menu bar are five buttons

(Figure 1-1) that you can use for quick access to certain Site Manager
features. For quick access, click on the buttons rather than selecting
the related menu options. Refer to Table 1-1 for information on the

function of each button.

Table 1-1.  Function Selection Buttons

Button Function

Connection Displays the Router Connection Options
window, which lets you choose the Wellfleet
router you want to connect to each Site
Manager tool (refer to “Connecting to Rout-
ers” in Chapter 3).

Statistics Opens the Statistics Manager window (refer
to Managing Wellfleet Routers).

Traps Displays the Trap Monitor window (refer to
Managing Wellfleet Routers).

Events Displays the Events Manager window (refer
to Managing Wellfleet Routers).

Files Displays the Router Files Manager window

(refer to Managing Wellfleet Routers).
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Overview of Site Manager

Site Manager and the Wellfleet MIB

You can access the Wellfleet MIB through Site Manager (Figure 1-3).

[®] Wellfleet Site Manager
File View Options Tools Administration Help
[ lConnectionI [Statisticsl ‘ Traps I I Events | ( Files l

Well-known Connections:

System Name/IP Address:
SNMP TD (Community) :

System Name:
Contact:
Location:
Description:

MIB Version:
Model:

Power Supply 1:
Power Supply 2:
Power Supply 3:
Power Supply 4:
Fan:
Temperature:

Site Manager User Interface

!

Site Manager SNMP-
| based application l

!

SNMP agent
— || Backbone Node=g =r—a
Management
Information
% Base (MlB)

Figure 1-3. Accessing the Wellfleet MIB
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Site Manager and the Wellfleet MIB

The Wellfleet MIB is a hierarchical database of

o Configuration and statistical objects that the router’s operating
system (GAME) uses

o Protocol image software that defines, limits, and monitors the
behavior of a Wellfleet router in your network

The Wellfleet MIB includes all objects for every protocol that Wellfleet
routers support. The Wellfleet MIB is a Wellfleet specific extension of
the Management Information Base II (MIB II) described in Internet
Request for Comments (RFC) 1213.

Through Site Manager or the Technician Interface, you can
o Read (SNMP GET) the values of many objects in the MIB

a  Write (SNMP SET) the values of a smaller subset of objects in the
MIB

The GAME operating system also has exclusive read/write access
privileges to certain objects in the MIB.

You use Site Manager or the Technician Interface to save MIB objects
and their settings in a configuration file. You then transfer the
configuration file to a router. Using a configuration file on the Wellfleet
router, GAME creates an active MIB that dictates the behavior of that
router on your network.
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Overview of Site Manager

Using Site Manager to Manage MIB Objects

The Wellfleet Site Manager software enables you to

a

Create, retrieve, edit, or delete individual instances (occurrences)
of

— Static configuration objects in the MIB

— Dynamically updated objects (for example, address caches and
real-time operational statistics)

Create, edit, save, copy, or delete configuration files that specify
subsets of MIB objects and their settings for particular Wellfleet
routers in your network.

Generate ASCII reports from router configuration files.

Transfer to or from a specific Wellfleet router any configuration file
that you want to

— Initialize (boot) on a particular router
— Edit before initializing on a particular router

Create, edit, filter, save, or delete your workstation view of certain
MIB objects. (For example, you can use retrieval filters to display
all statistical objects that have a particular instance ID.)

Accessing the MIB via SNMP

Every Wellfleet router incorporates an SNMP management agent. The
agent is a software entity that responds to information and action
request messages from an SNMP-based manager (your Site Manager
workstation). The messages exchanged between manager and router
SNMP agents in turn enable you to access and manage objects in an
active or inactive (stored) MIB on a particular Wellfleet router.
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Site Manager and the Wellfleet MIB

Transferring Files via TFTP

Site Manager uses TFTP to transport files through your high-speed IP
network. (If all IP routing paths between file source and destination
are down, you can use the xmodem/ymodem capabilities of the
Technician Interface. The xmodem/ymodem protocol is, however, a less
efficient method for transferring files.)

Using the ASCII Version of the Wellfleet MIB

Bay Networks distributes with your Site Manager software an ASCII
version of the Wellfleet MIB in ASN.1 syntax. You can use this version
as a reference to MIB objects. You can also compile this version using a
network management application to provide network management
access to Wellfleet routers.

The MIB file WFMIB.asn appears in the /usr/wf/lib directory on
UNIX workstations and in the \wf\lib directory on PCs.
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Chapter 2
Using Site Manager Windows

Refer to this chapter for information about

a

a
)
a

Site Manager Window Types

Site Manager Window Conventions

Entering Data in Configuration Manager Windows
Getting Help
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Site Manager Window Types

Site Manager Window Types

[[® Circuit List H—

Every Site Manager window has either a menu bar or function
buttons.

A menu bar lets you access additional menus and commands. For
example, the Wellfleet Configuration Manager menu bar (Figure 2-1)
gives you access to the File, Options, Platform, Circuits, Protocols,
Dialup, Window, and Help menus.

Configuration lanazer S 8 a0 s
File Options Platform Circuits Protocols Dialup Window Help

Figure 2-1. Menu Bar

Function buttons let you enter and modify data for a specific function.
For example, the Circuit List window (Figure 2-2) contains Edit,
Delete, and Done buttons. You use the Edit button to edit a circuit, the
Delete button to delete a circuit, and the Done button to close the
Circuit List window.

Configuration Mode: dynamic
SNMP Agent: 192,32,156.9

Circuits

R, [

iEdit...| | Delete | | Done |

Figure 2-2. Window with Function Buttons
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Using Site Manager Windows

Site Manager Window Conventions

Site Manager windows use the following conventions:

a Menu bar selections, menu options, and button labels that end with
three dots (...) display a new window when you select them.

a  Menu bar options not followed by three dots and menu options
followed by a shaded arrow ( » ) display a menu or submenu when
you select them.

o Button labels not followed by three dots perform a function when
you click on them.

o Underlined letters in menu bar options and menu options identify
keyboard shortcuts.

— If you are using a Sun® or IBM® keyboard, hold the diamond
key (on either side of the space bar) and press the key
underlined in the menu option to select that option.

— If you are using a PC keyboard, hold the Alt key and press the
key underlined in the menu option to select that option.

Note: Site Manager is not case-sensitive. You can enter keyboard
commands in either uppercase or lowercase letters.

a Use the arrow keys on the keyboard to scroll up, down, right, or left
through the menu bar and menu options.

0 The PF number in a menu option identifies the program function
key shortcut.

a Menu options are gray when they are not active for a particular
window.

0 Some Site Manager windows have vertical scroll bars at the right
side of the window. You can view the entire contents of a window
using the scroll bar.
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Entering Data in Configuration Manager Windows

Entering Data in Configuration Manager Windows

The Configuration Manager is the main tool you use to manage your
router configurations. You access the Configuration Manager from the
Tools menu on the Site Manager main menu bar.

When you configure a router, you need to enter values for parameters
in the Configuration Manager windows. In some windows, you can
choose values from a list of settings (refer to “Choosing Values for
Parameters from a List of Settings”). In other windows, you need to
enter values with the keyboard (refer to “Entering Parameters with
the Keyboard”). For help about a parameter, refer to “Getting Help on
Parameters.”

Choosing Values for Parameters from a List of Settings

Some Configuration Manager windows allow you to choose values for
parameters from a list of settings. Such Configuration Manager
windows contain a Values button in the vertical list of buttons in the
top right corner of the window. For example, the Edit SNMP Global
Parameters window (Figure 2-3) contains a Values button.

[® it SNP Global Paraneters I ——.

Configuration Mode: dynamic
SNP Agent: 192,32, 156,9

Enable {NABLE

Use Lock ENABLE

Lock TireOut [2 |

Authentication Failure Traps |ENABLE i

Figure 2-3. Edit SNMP Global Parameters Window
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Using Site Manager Windows

To view the list of settings,

1. Place the cursor in the field for which you want to view the list of
possible values.

2. Click on the Values button.
For example, suppose you click in the Enable field in the Edit SNMP

Global Parameters window. If you then click on the Values button, a
Values Selection window appears (Figure 2-4).

@] Values Selection §

Enable

4 ENABLE

< DISABLE

Figure 2-4. Values Selection Window

To choose a value,

1. Click in the diamond to the left of the value.
2. Click on the OK button.

The parameter you selected appears in the appropriate field.

To exit the Values Selection window without choosing a value, click on
the Cancel button.

Note: You must close a Values Selection window before you can view
possible values for other parameters.
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Entering Data in Configuration Manager Windows

Entering Parameters with the Keyboard

You need to use the keyboard to enter data in some fields. Site
Manager offers some shortcuts you can use to add or replace data with
the keyboard.

To replace data in a field,

1. Use the mouse to select the existing data entry in the field.
a Double-click on a word to select the word only.
o Triple-click on a word to select the entire field.

2. Use the keyboard to enter data. The data you enter replaces the
entry you selected.

To add or overwrite data in a field,
1. Position the cursor in the field.
2. Toggle the insert key to either insert or overwrite mode.

o When you enter data in insert mode, the cursor appears as an I
(I), and your entry is added to the existing entry.

0 When you enter data in overwrite mode, the cursor appears as a
block (1), and your entry overwrites the existing entry.

3. Use the keyboard to enter data.
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Using Site Manager Windows

Getting Help

Site Manager offers three types of Help facilities:

0 Help on a window

o  Help on a parameter in a Configuration Manager window

0 Help on Site Manager tools

Getting Help on Site Manager Windows

Windows that offer help have a Help button in the horizontal list of
buttons near the bottom of the window. For example, the Trap
Configuration window (Figure 2-5) contains such a Help button.

Trap Configuration

Available Entities

Slot:

411 Entities
ACE

APPLETALK
APPN

&RP

ASYNC

ATM

ATM DXI
ATMINTF
BGP3

BGP

BOD

BOOT
BOOTP
CSMACD
DECnet IV

¥

Current Entities

vaents: 1 Fault

£ Warning £ Debug

{1 Trace

{1 Info

Save

Cancel

Figure 2-5. Trap Configuration Window




; Getting Help

To get help about a window, click on the Help button. For example, if
you click on the Help button in the Trap Configuration window, a Help
window (Figure 2-6) appears.

[@] Help 2]

Trap Configuration Help

To configure an entity to_send SMMP trap messages to the Site
Manager workstation, complete the following steps:

1. Select the appropriate slot.

2. Select an entity whose trap messages you want sent to the
MANAZET,

3. Select the event types for that entity that you want sent to
your workstation,

Figure 2-6. Help on Windows
To exit the Help window, click on the OK button.

Getting Help on Parameters

Configuration Manager windows that offer help on parameters contain
a Help button in the vertical list of buttons in the top right corner of
the window. For example, the Edit SNMP Global Parameters window
(refer to Figure 2-3) contains such a Help button.

To get help about a parameter,

1. Place the cursor in the field for which you want help.

2. Click on the Help button.

For example, suppose you click in the Enable field in the Edit SNMP
Global Parameters window (refer to Figure 2-3).
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Using Site Manager Windows

If you then click on the Help button, a Help window appears
(Figure 2-7).

o> @ @ @@ @@ @@ @ @ - 5B

Enable
Default: Enable
Options: Enable/Disable
Function: Specifies the state of the SNMP agent software on all interfaces

that support IP.

Instructions: Select Enable to enable the SMMP agent software, Select Disable
to disable the SNMP agent software.

Figure 2-7. Help on Parameters

Use the scroll bar on the right side of the screen to see the entire help
text. Click on OK to close the Help window.

Note: You must close out of a Help window before you can get help
about other parameters.

Getting Help on Site Manager Tools

If you installed the Online Library on your Site Manager workstation
or are accessing the Online Library from a CD-ROM device, you can
get additional help that describes how to use each Site Manager tool.

The main Site Manager window and the main window of each tool
include a “How to Use” entry in their Help submenus (refer to

Figure 1-2). When you select the entry “How to Use,” the Online
Library starts and displays the section that describes how to use that
tool. The Online Library is a complete collection of hardware and
software manuals for Wellfleet routers.
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Getting Help

To use this feature

1. Install the Online Library on the workstation that you are using to
run Site Manager (refer to the book Online Library that comes with
the CD).

You can choose to install the entire library on your workstation or
to read data from the CD. If you set up the Online Library to read
data from the CD, be sure to install the CD every time you want to
access the Online library.

Note: If Site Manager cannot access the Online Library, the “How to
Use” entry is gray, and you cannot select it. Check that you
have installed the Online Library on your workstation and that
you have inserted the CD in the CD drive, if necessary.

2. Select Help>How to Use from the main Site Manager window or
the main window of a Site Manager tool.

The appropriate information from the Online Library appears. For
example, if you select “How to Use” from the Help menu of the
main Site Manager window (refer to Figure 1-2), you access
Chapter 3 of this book.

After you have launched the Online Library, you can access any
information in the library. For information about using or exiting
the Online Library, refer to the book Online Library.
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Chapter 3
Performing Basic
Site Manager Operations

Refer to this chapter for information on
Starting Site Manager

Connecting to Routers

Determining Site Manager Version
Starting Site Manager Tools
Exiting Site Manager Tools

a O o o o a

Exiting Site Manager
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Starting Site Manager

Starting Site Manager

You can start Site Manager from a UNIX or a DOS workstation.

‘ Note: Before you attempt to start Site Manager, you must install the
i Site Manager software according to the instructions in Quick-
Starting Wellfleet Routers.

UNIX

Start the Site Manager application as follows:
1. Log in to a user account that recognizes Site Manager software.

2. Start the windowing environment (for example, X Windows). Refer
as necessary to the UNIX workstation user documentation.

3. Change to a directory where you want to store configuration files.

Note: Do not attempt to start Site Manager in the /usr/wf directory or
in any other directory for which Site Manager does not have
write-access privileges.

4. Activate Site Manager by entering
wfsm &

The Router Connection Options window appears. Proceed to the
section “Connecting to Routers.”
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DOS (Disk Operating System)

Start the Site Manager application as follows.

1.

Start the Windows environment by entering the following after the
DOS prompt:

win
The Program Manager window appears.

Double-click on the Site Manager program group from the Program
Manager window.

Activate Site Manager by double-clicking on the PC/Site Manager
icon in the Site Manager program group.

The Router Connection Options window appears. Proceed to the
next section, “Connecting to Routers.”
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Connecting to Routers

When you activate Site Manager, the Router Connection Options
window appears (Figure 3-1).

[® Router Connection Options i

Welcome to Site Manager

Node Name/IP &ddress 192.32.14.39
Tentity (Comunity)

5

Timeout (seconds) ET T
Retries (per request) h

Figure 3-1. Router Connection Options Window

The Router Connection Options window lets you choose the Wellfleet
router connected to each Site Manager tool. You can open a window for
each tool and connect a different router to each one. In this way, you
can manage several Wellfleet routers at the same time.

You need to complete each field (or use defaults) in this window.
Refer to Table 3-1 for a description of the fields in this window.
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Table 3-1.  Entering Values in the Router Connection Options Window

Field Description

Node Name/ | Enter the host name or IP address of the Wellfleet router

IP Address you want to manage. You can use the host name only if it is
in the workstation’s host file.
The IP address you enter becomes the default router con-
nection address. When you open new tool windows and
select Options>Router Connection, the Router Connection
Options window displays this address.

Identity Enter the SNMP community name you want Site Manager

(community) | to use when communicating with the router.*
The community must have read/write access to the Well-
fleet router you want to reconfigure using the Configuration
Manager tool.

Timeout Enter the number of seconds Site Manager should wait for a

(seconds) response from the Wellfieet router after it issues an SNMP

SET or GET before reissuing the command.

The default value is 5 seconds. You can specify a value from
1 to 300.

Retries (per
request)

Enter the number of times you want Site Manager to reis-
sue a command when the Wellfleet router does not respond.

The default value is 3. You can specify a value from 0 to 30.

* On any router that is not configured with a valid SNMP community, Site Manager
configures a “public” community with a wildcard manager (using an IP address of
0.0.0.0). This ensures that Site Manager can access the router. You should reconfig-
ure the “public” community, with universal access limited to read-only privileges. For
more information, refer to Customizing SNMF, BOOTPF, and RARP Services.
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After you complete the fields in the Router Connection Options
window, click on OK. The Wellfleet Site Manager window appears

(Figure 3-2).

Wellfleet Site Manager

File View Options Tools Administration Help
IConnectionl gStatisticsl f Traps | { Events | ; Files |

ell-Known Connections
192, 32, 18, 1007 1p
182,32.18,103  Down

System Name/IP Address: 192,32, 18,107
SNMP ID (Community) : public

ny

System Name:

nn

Contact:

nn

Location:
Description: n

MIB Version: xY.YY

Model: Backbone Concentrator Node (BCN)
Power Supply 1: On Lire

Power Supply 2: On Line

Power Supply 3: On Line

Power Supply 4: On Line

Fan: On Line

Temperature: Normal

Figure 3-2. Wellfleet Site Manager Window

Note: The Wellfleet PC Site Manager uses the Multiple Document
Interface (MDI) Windows standard. (The Windows title bar
appears above every PC Site Manager window.)
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Determining Site Manager Version

To determine which version of Site Manager you are running, select
Help=>Site Manager Version from any window. The Version window
then appears (Figure 3-3).

[® Version

Site Manager Version X.XX

Figure 3-3. Version Window

Starting Site Manager Tools

To use a Site Manager tool, select the appropriate option from the Tools
menu in the Wellfleet Site Manager window (refer to Figure 1-2). Site
Manager tools include the following:

a

o o o o o O

Configuration Manager
Statistics Manager
Trap Monitor

Router Files Manager
Report Generator
Events Manager

Image Builder

Refer to Managing Wellfleet Routers for information on how to start
tools from the UNIX command line.

3-7



Exiting Site Manager Tools

Exiting Site Manager Tools

To exit a Site Manager tool:

1. Select File=Exit from the main window of the tool. A confirmation
window appears.

2. Click on OK.

All windows associated with the tool close when you shut down the
application.

Exiting Site Manager

To exit Site Manager, complete the following steps:

1. Select File»Exit from the Wellfleet Site Manager window. A
confirmation window appears.

2. Click on OK.

When you shut down Site Manager on a UNIX system, only those tools
and associated windows started from the Wellfleet Site Manager
window shut down. Tools started from the command line remain open.

When you shut down Site Manager on a DOS system, a window
indicates which Site Manager tools and associated windows are still
open and tells you to close them. You cannot shut down Site Manager
until you close these windows.
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R

retries parameter, 3-5
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starting, 3-2
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starting, 3-7
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windows
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